libpeas-dev_1.16.0-1ubuntu2_amd64.deb


Advertisement

Description

libpeas-dev - Application plugin library (development files)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libpeas-dev_1.16.0-1ubuntu2_amd64.deb
Package name libpeas-dev
Package version 1.16.0
Package release 1ubuntu2
Package architecture amd64
Package type deb
Category libdevel
Homepage https://wiki.gnome.org/Projects/Libpeas
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 18.04 KB
Installed size 319.00 KB
libpeas is a library that allows applications to support plugins.
This package contains the headers files required for developing software that
uses libpeas.

Alternatives

Package Version Architecture Repository
libpeas-dev_1.16.0-1ubuntu2_i386.deb 1.16.0 i386 Ubuntu Main
libpeas-dev - - -

Requires

Name Value
gir1.2-peas-1.0 = 1.16.0-1ubuntu2
libgirepository1.0-dev >= 1.39.0
libglib2.0-dev >= 2.38.0
libgtk-3-dev >= 3.0.0
libpeas-1.0-0 = 1.16.0-1ubuntu2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libpeas-dev_1.16.0-1ubuntu2_amd64.deb
Source Package libpeas

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpeas-dev deb package:
    # sudo apt-get install libpeas-dev

Files

Path
/usr/include/libpeas-1.0/libpeas/peas-activatable.h
/usr/include/libpeas-1.0/libpeas/peas-autocleanups.h
/usr/include/libpeas-1.0/libpeas/peas-engine.h
/usr/include/libpeas-1.0/libpeas/peas-extension-base.h
/usr/include/libpeas-1.0/libpeas/peas-extension-set.h
/usr/include/libpeas-1.0/libpeas/peas-extension.h
/usr/include/libpeas-1.0/libpeas/peas-object-module.h
/usr/include/libpeas-1.0/libpeas/peas-plugin-info.h
/usr/include/libpeas-1.0/libpeas/peas.h
/usr/include/libpeas-1.0/libpeas-gtk/peas-gtk-autocleanups.h
/usr/include/libpeas-1.0/libpeas-gtk/peas-gtk-configurable.h
/usr/include/libpeas-1.0/libpeas-gtk/peas-gtk-plugin-manager-view.h
/usr/include/libpeas-1.0/libpeas-gtk/peas-gtk-plugin-manager.h
/usr/include/libpeas-1.0/libpeas-gtk/peas-gtk.h
/usr/lib/x86_64-linux-gnu/libpeas-1.0.so
/usr/lib/x86_64-linux-gnu/libpeas-gtk-1.0.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libpeas-1.0.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/libpeas-gtk-1.0.pc
/usr/share/doc/libpeas-dev/AUTHORS
/usr/share/doc/libpeas-dev/NEWS.gz
/usr/share/doc/libpeas-dev/README.gz
/usr/share/doc/libpeas-dev/changelog.Debian.gz
/usr/share/doc/libpeas-dev/copyright
/usr/share/gir-1.0/Peas-1.0.gir
/usr/share/gir-1.0/PeasGtk-1.0.gir
/usr/share/glade/catalogs/libpeas-gtk.xml

Changelog

2016-02-24 - Matthias Klose <doko@ubuntu.com>
libpeas (1.16.0-1ubuntu2) xenial; urgency=medium
* Multiarchify the library packages. LP: #1508611.
2016-01-13 - Barry Warsaw <barry@ubuntu.com>
libpeas (1.16.0-1ubuntu1) xenial; urgency=medium
* debian/control:
- Split the Python 2 and Python 3 loader shared libraries into separate
binary packages so that we can manage the libpython2.7 and libpython3.5
dependencies individually.  This allows for better migration to Python
3 only environments.  (LP: #1440504)
- libpeas-1.0-0-python3loader, libpeas-1.0-0-python2-loader: New
binary packages.
- update-maintainer
* debian/libpeas-1.0-0-python{2,3}loader.install: Added.
* debian/libpeas-1.0-0.install: Modified.
2015-09-22 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.16.0-1) unstable; urgency=medium
* New upstream release.
* Update debian/patches/0001-Fix-Python-plugin-loader-module-paths.patch
- replace patch from gnome bugzilla with commit from upstream git.
2015-09-04 - Michael Biebl <biebl@debian.org>
libpeas (1.14.0-1) unstable; urgency=medium
[ Iain Lane ]
* Depend on adwaita-icon-theme for the test. This is GNOME's new default
icon theme.
[ Jackson Doak ]
* New upstream release
[ Andreas Henriksson ]
* Fix Homepage url (breakage spotted by DUCK by skanz@d.o)
[ Michael Biebl ]
* Bump Build-Depends as per configure.ac.
* Drop obsolete --disable-seed configure flag.
* Update symbols file. Mark private symbols as optional.
* Bump debhelper compatibility level to 9.
* Drop obsolete Conflicts and Replaces from pre-wheezy.
* Fix Python plugin loader module paths. Patch taken from bgo#753401.
2014-11-06 - Emilio Pozuelo Monfort <pochu@debian.org>
libpeas (1.12.1-2) unstable; urgency=medium
* Disable seed support everywhere.
2014-09-22 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.12.1-1) unstable; urgency=medium
* New upstream release.
* Bump libglib2.0-dev build-dependency to >= 2.32.0 according to configure.ac
2014-09-07 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.10.1-4) unstable; urgency=medium
* Also exclude arm64 hppa and arm from the seed build-dependency.
* Add ppc64el and ia64 to archs where we don't enable seed
and exclude them from the seed build-dependency.
2014-09-07 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.10.1-3) unstable; urgency=medium
* Also add arm64 to platforms where we don't enable seed.
2014-09-05 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.10.1-2) unstable; urgency=medium
* Add hppa and alpha to the list of architectures where we don't enable
seed (Closes: #757241)
2014-08-28 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.10.1-1) unstable; urgency=medium
[ Emilio Pozuelo Monfort ]
* debian/rules:
+ Don't run the test suite when DEB_BUILD_OPTIONS contains nocheck.
Thanks to Pino Toscano. Closes: #755251.
* debian/rules,
debian/control.in:
+ Disable seed support on hurd-i386. Thanks to Pino Toscano.
Closes: #755259.
[ Andreas Henriksson ]
* New upstream release.

See Also

Package Description
libpeas-doc_1.16.0-1ubuntu2_amd64.deb Application plugin library (documentation)
libpengine-dev_1.1.14-2ubuntu1_amd64.deb cluster resource manager Policy Engine library development
libpengine10_1.1.14-2ubuntu1_amd64.deb cluster resource manager Policy Engine library
libperl-dev_5.22.1-9_amd64.deb Perl library: development files
libperl4-corelibs-perl_0.003-2_all.deb libraries historically supplied with Perl 4
libperl5.22_5.22.1-9_amd64.deb shared Perl library
libperlio-gzip-perl_0.19-1build1_amd64.deb module providing a PerlIO layer to gzip/gunzip
libpfm4-dev_4.7.0-4_amd64.deb Development files for the libpfm4 library
libpfm4_4.7.0-4_amd64.deb Library to program the performance monitoring events
libpgtypes3_9.5.2-1_amd64.deb shared library libpgtypes for PostgreSQL 9.5
libphobos-5-dev_5.3.1-14ubuntu2_amd64.deb Phobos D standard library
libphobos-dev_5.3.1-1ubuntu1_amd64.deb Phobos D standard library
libpils2-dev_1.0.12~rc1+hg2777-1.2_amd64.deb Reusable cluster development files -- libpils2
libpils2_1.0.12~rc1+hg2777-1.2_amd64.deb Reusable cluster libraries -- libpils2
libpipeline-dev_1.4.1-2_amd64.deb pipeline manipulation library (development files)
Advertisement
Advertisement