libpcre16-3_8.38-3.1_amd64.deb


Advertisement

Description

libpcre16-3 - Perl 5 Compatible Regular Expression Library - 16 bit runtime files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libpcre16-3_8.38-3.1_amd64.deb
Package name libpcre16-3
Package version 8.38
Package release 3.1
Package architecture amd64
Package type deb
Category libs
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 140.43 KB
Installed size 528.00 KB
This is a library of functions to support regular expressions whose syntax
and semantics are as close as possible to those of the Perl 5 language.
This package contains the 16 bit runtime library.

Alternatives

Package Version Architecture Repository
libpcre16-3_8.38-3.1_i386.deb 8.38 i386 Ubuntu Main
libpcre16-3 - - -

Requires

Name Value
libc6 >= 2.14

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libpcre16-3_8.38-3.1_amd64.deb
Source Package pcre3

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpcre16-3 deb package:
    # sudo apt-get install libpcre16-3

Files

Path
/usr/lib/x86_64-linux-gnu/libpcre16.so.3
/usr/lib/x86_64-linux-gnu/libpcre16.so.3.13.2
/usr/share/doc/libpcre16-3/changelog.Debian.gz
/usr/share/doc/libpcre16-3/copyright

Changelog

2016-03-22 - Salvatore Bonaccorso <carnil@debian.org>
pcre3 (2:8.38-3.1) unstable; urgency=medium
* Non-maintainer upload.
* CVE-2016-1283: heap buffer overflow in handling of duplicate named
groups (Closes: #809706)
2016-02-28 - Matthew Vernon <matthew@debian.org>
pcre3 (2:8.38-3) unstable; urgency=low
* Apply Ubuntu patch from Iain Lane (modified by Graham Inggs) to add
symbols files (Closes: #767374)
2016-02-27 - Matthew Vernon <matthew@debian.org>
pcre3 (2:8.38-2) unstable; urgency=low
* Apply upstream patch to fix workspace overflow for (*ACCEPT) with
deeply nested parentheses (Closes: #815921)
2015-12-22 - Matthew Vernon <matthew@debian.org>
pcre3 (2:8.38-1) unstable; urgency=low
* New upstream version
2015-11-21 - Matthew Vernon <matthew@debian.org>
pcre3 (2:8.35-8) unstable; urgency=low
* Remove conflicts with long-vanished pcre{1,2}-dev packages (so new PCRE2 packages can co-exist)
2015-11-02 - John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
pcre3 (2:8.35-7.4) unstable; urgency=medium
* Non-maintainer upload.
* Fix copy-and-paste error in Disable_JIT_on_sparc64.patch.
2015-11-02 - John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
pcre3 (2:8.35-7.3) unstable; urgency=medium
* Non-maintainer upload.
* Add Disable_JIT_on_sparc64.patch to disable JIT on sparc64. The patch
no_jit_x32_powerpcspe.patch to disable JIT on powerpcspe was already
added in 2:8.35-6 (Closes: #765079).
2015-09-11 - Salvatore Bonaccorso <carnil@debian.org>
pcre3 (2:8.35-7.2) unstable; urgency=low
* Non-maintainer upload (with maintainer's permission).
* Add Fix-compiler-crash-misbehaviour-for-zero-repeated-gr.patch.
Fixes "PCRE Library Stack Overflow Vulnerability" (Upstream bug 1503)
* Add Fix-compile-time-loop-for-recursive-reference-within.patch.
Fixes "PCRE Call Stack Overflow Vulnerability" (Upstream bug 1515)
* Add 794589-information-disclosure.patch.
Fixes "pcre_exec does not fill offsets for certain regexps" leading to
information disclosure. (Closes: #794589)
* Add Fix-bad-compile-for-groups-like-2-0-1999.patch.
CVE-2015-2325: heap buffer overflow in compile_branch(). (Closes: #781795)
* Add Fix-bad-compilation-for-patterns-like-1-1-with-forwa.patch.
CVE-2015-2326: heap buffer overflow in pcre_compile2(). (Closes: #783285)
* Add Fix-buffer-overflow-for-named-recursive-back-referen.patch.
CVE-2015-3210: heap buffer overflow in pcre_compile2() /
compile_regex(). (Closes: #787433)
2015-08-04 - Matthias Klose <doko@debian.org>
pcre3 (2:8.35-7.1) unstable; urgency=medium
* Rename libpcrecpp0 to libpcrecpp0v5. Addresses: #791236.
* Add Conflict/Replaces to the old library.
* Add libpcrecpp0v5 symbols file for GCC 5.
2015-06-26 - Matthew Vernon <matthew@debian.org>
pcre3 (2:8.35-7) unstable; urgency=medium
* Apply upstream patch to fix buffer overflow for forward reference
within backward assertion with excess closing parenthesis
(Closes: #790000)

See Also

Package Description
libpcre3-dev_8.38-3.1_amd64.deb Perl 5 Compatible Regular Expression Library - development files
libpcre32-3_8.38-3.1_amd64.deb Perl 5 Compatible Regular Expression Library - 32 bit runtime files
libpcre3_8.38-3.1_amd64.deb Perl 5 Compatible Regular Expression Library - runtime files
libpcrecpp0v5_8.38-3.1_amd64.deb Perl 5 Compatible Regular Expression Library - C++ runtime files
libpcsclite-dev_1.8.14-1ubuntu1_amd64.deb Middleware to access a smart card using PC/SC (development files)
libpcsclite1_1.8.14-1ubuntu1_amd64.deb Middleware to access a smart card using PC/SC (library)
libpe-rules2_1.1.14-2ubuntu1_amd64.deb cluster resource manager Policy Engine rules library
libpe-status10_1.1.14-2ubuntu1_amd64.deb cluster resource manager Policy Engine status library
libpeas-1.0-0-python3loader_1.16.0-1ubuntu2_amd64.deb Application plugin library
libpeas-1.0-0_1.16.0-1ubuntu2_amd64.deb Application plugin library
libpeas-common_1.16.0-1ubuntu2_all.deb Application plugin library (common files)
libpeas-dev_1.16.0-1ubuntu2_amd64.deb Application plugin library (development files)
libpeas-doc_1.16.0-1ubuntu2_amd64.deb Application plugin library (documentation)
libpengine-dev_1.1.14-2ubuntu1_amd64.deb cluster resource manager Policy Engine library development
libpengine10_1.1.14-2ubuntu1_amd64.deb cluster resource manager Policy Engine library
Advertisement
Advertisement