libpango1.0-0_1.38.1-1_amd64.deb


Advertisement

Description

libpango1.0-0 - Layout and rendering of internationalized text (transitional package)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libpango1.0-0_1.38.1-1_amd64.deb
Package name libpango1.0-0
Package version 1.38.1
Package release 1
Package architecture amd64
Package type deb
Category libs
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 3.38 KB
Installed size 212.00 KB
Pango is a library for layout and rendering of text, with an emphasis
on internationalization. Pango can be used anywhere that text layout is
needed. however, most of the work on Pango-1.0 was done using the GTK+
widget toolkit as a test platform. Pango forms the core of text and
font handling for GTK+-2.0.
Pango is designed to be modular; the core Pango layout can be used with
four different font backends:
- Core X windowing system fonts
- Client-side fonts on X using the Xft library
- Direct rendering of scalable fonts using the FreeType library
- Native fonts on Microsoft backends
This is a transitional package.

Alternatives

Package Version Architecture Repository
libpango1.0-0_1.38.1-1_i386.deb 1.38.1 i386 Ubuntu Main
libpango1.0-0 - - -

Requires

Name Value
libpango-1.0-0 = 1.38.1-1
libpangocairo-1.0-0 = 1.38.1-1
libpangoft2-1.0-0 = 1.38.1-1
libpangox-1.0-0 >= 0.0.2-2~
libpangoxft-1.0-0 = 1.38.1-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libpango1.0-0_1.38.1-1_amd64.deb
Source Package pango1.0

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpango1.0-0 deb package:
    # sudo apt-get install libpango1.0-0

Files

Path
/usr/share/doc/libpango1.0-0/AUTHORS
/usr/share/doc/libpango1.0-0/NEWS.gz
/usr/share/doc/libpango1.0-0/README
/usr/share/doc/libpango1.0-0/THANKS
/usr/share/doc/libpango1.0-0/changelog.Debian.gz
/usr/share/doc/libpango1.0-0/copyright

Changelog

2015-10-20 - Andreas Henriksson <andreas@fatal.se>
pango1.0 (1.38.1-1) unstable; urgency=medium
[ Michael Biebl ]
* Use https:// for Vcs-Browser
[ Andreas Henriksson ]
* New upstream release.
* Bump build-dependencies according to configure.ac changes:
- libharfbuzz-dev >= 0.9.30
* Drop debian/patches/tests-needs-asserts.patch, fixed upstream.
* Bump Standards-Version to 3.9.6
* Add "(transitional package)" to libpango1.0-0 short description
(Closes: #714766)
2015-09-28 - Andreas Henriksson <andreas@fatal.se>
pango1.0 (1.38.0-3) unstable; urgency=medium
* Add debian/patches/configure-without-libthai.patch
- make it possible to disable checking for libthai
* debian/rules: configure udeb build --without-libthai
- this avoids the udeb picking up a dependency on libthai which has
no udeb. (Closes: #800356)
2015-09-28 - Andreas Henriksson <andreas@fatal.se>
pango1.0 (1.38.0-2) unstable; urgency=medium
* Add debian/patches/disable-layout-test.patch
- disable flaky test while waiting for feedback on bgo#755733
2015-09-28 - Andreas Henriksson <andreas@fatal.se>
pango1.0 (1.38.0-1) unstable; urgency=medium
* New upstream release.
* Add debian/patches/tests-needs-asserts.patch
- fixes issue in testattributes (bgo#755126) under --disable-debug
* Make tests fatal again.
2015-09-16 - Andreas Henriksson <andreas@fatal.se>
pango1.0 (1.37.5-1) experimental; urgency=medium
* New upstream development release.
- The module system is now deprecated.
* Drop patches obsoleted by module system deprecation:
- 10_scan-module-files-in-dirs.patch
- 11_module-files-append-module-files-d.patch
- 14_makefile_modules_ft2_link_harfbuzz.patch
* Drop lingering unused patch
- 13_configure-thai-modules.patch
* Partial import of Ubuntu gnome3 staging ppa 1.37.4-0ubuntu1~wily0
- symbols files updates
- package updates for modules deprecation
- drop debian/dh_pangomodules.in + debian/libpango1.0-dev.manpages
* Make tests non-fatal while waiting for feedback on BGO#755126
- This seems to be a problem in the test itself rather then pango.
2014-11-18 - Iain Lane <laney@debian.org>
pango1.0 (1.36.8-3) unstable; urgency=medium
* debian/control{,.in}: The testsuite depends on Cantarell. Fixes DEP8 test
failure.
2014-10-06 - Michael Biebl <biebl@debian.org>
pango1.0 (1.36.8-2) unstable; urgency=medium
* Drop Multi-Arch: same for libpango1.0-dev. The libpango1.0-dev package
ships architecture specific binaries in /usr/bin. While those binaries
could eventually be split off into a separate binary package, we just
revert the change for now and defer it until there is actual need for it.
(Closes: #763851)
2014-10-02 - Michael Biebl <biebl@debian.org>
pango1.0 (1.36.8-1) unstable; urgency=medium
* New upstream release.
* Install typelib files into multiarch paths now that gobject-introspection
supports multiarch.
* Mark gir and dev packages as Multi-Arch: same.
2014-09-06 - Andreas Henriksson <andreas@fatal.se>
pango1.0 (1.36.7-1) unstable; urgency=medium
* New upstream release.
* Add build-dependency on fonts-cantarell to avoid test failure.
- We rely on gnome-core pulling this in for us in normal operations.
* Run wrap-and-sort
2014-08-17 - Michael Biebl <biebl@debian.org>
pango1.0 (1.36.6-1) unstable; urgency=medium
* New upstream release.
* Refresh patches.
* Update install path for installed-tests.
* Bump Standards-Version to 3.9.5.
* Drop Suggests ttf-baekmuk and ttf-arphic-*. Those font packages have been
renamed in the mean time and nobody seems to remember why they were added
in the first place. (Closes: #741672, #711292)

See Also

Package Description
libpango1.0-dev_1.38.1-1_amd64.deb Development files for the Pango
libpango1.0-doc_1.38.1-1_all.deb Documentation files for the Pango
libpangocairo-1.0-0_1.38.1-1_amd64.deb Layout and rendering of internationalized text
libpangoft2-1.0-0_1.38.1-1_amd64.deb Layout and rendering of internationalized text
libpangomm-1.4-1v5_2.38.1-1_amd64.deb C++ Wrapper for pango (shared libraries)
libpangomm-1.4-dev_2.38.1-1_amd64.deb C++ Wrapper for pango (development files)
libpangomm-1.4-doc_2.38.1-1_all.deb C++ Wrapper for pango (documentation)
libpangox-1.0-0_0.0.2-5_amd64.deb pango library X backend
libpangox-1.0-dev_0.0.2-5_amd64.deb pango library X backend - development files
libpangoxft-1.0-0_1.38.1-1_amd64.deb Layout and rendering of internationalized text
libpaper-dev_1.1.24+nmu4ubuntu1_amd64.deb library for handling paper characteristics (development files)
libpaper-utils_1.1.24+nmu4ubuntu1_amd64.deb library for handling paper characteristics (utilities)
libpaper1_1.1.24+nmu4ubuntu1_amd64.deb library for handling paper characteristics
libparse-debianchangelog-perl_1.2.0-8_all.deb parse Debian changelogs and output them in other formats
libparse-pidl-perl_4.3.8+dfsg-0ubuntu1_amd64.deb IDL compiler written in Perl
Advertisement
Advertisement