libpam-systemd_229-4ubuntu4_amd64.deb


Advertisement

Description

libpam-systemd - system and service manager - PAM module

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libpam-systemd_229-4ubuntu4_amd64.deb
Package name libpam-systemd
Package version 229
Package release 4ubuntu4
Package architecture amd64
Package type deb
Category admin
Homepage http://www.freedesktop.org/wiki/Software/systemd
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 112.80 KB
Installed size 350.00 KB
This package contains the PAM module which registers user sessions in
the systemd control group hierarchy for logind.
If in doubt, do install this package.
Packages that depend on logind functionality need to depend on libpam-systemd.

Alternatives

Package Version Architecture Repository
libpam-systemd_229-4ubuntu4_i386.deb 229 i386 Ubuntu Main
libpam-systemd_229-4ubuntu21.22_i386.deb 229 i386 Ubuntu Updates Main
libpam-systemd_229-4ubuntu21.22_amd64.deb 229 amd64 Ubuntu Updates Main
libpam-systemd - - -

Requires

Name Value
dbus -
libc6 >= 2.17
libpam-runtime >= 1.0.1-6
libpam0g >= 0.99.7.1
libselinux1 >= 1.32
systemd = 229-4ubuntu4
systemd-shim >= 8-2
systemd-sysv -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libpam-systemd_229-4ubuntu4_amd64.deb
Source Package systemd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpam-systemd deb package:
    # sudo apt-get install libpam-systemd

Files

Path
/lib/x86_64-linux-gnu/security/pam_systemd.so
/usr/share/doc/libpam-systemd/changelog.Debian.gz
/usr/share/doc/libpam-systemd/copyright
/usr/share/man/man8/pam_systemd.8.gz
/usr/share/pam-configs/systemd

Changelog

2016-04-12 - Martin Pitt <martin.pitt@ubuntu.com>
systemd (229-4ubuntu4) xenial; urgency=medium
* 73-special-net-names.rules: Further refine ibmveth naming.
2016-04-12 - Martin Pitt <martin.pitt@ubuntu.com>
systemd (229-4ubuntu3) xenial; urgency=medium
* debian/tests/cmdline-upstart-boot: In test_rsyslog(), check for messages
from dbus instead of NetworkManager. NM 1.2 does not seem to log to syslog
by default any more.
* 73-special-net-names.rules: Refine ibmveth naming.
2016-04-12 - Martin Pitt <martin.pitt@ubuntu.com>
systemd (229-4ubuntu2) xenial; urgency=medium
* debian/tests/unit-config: Call "daemon-reload" to clean up generated units
in between tests.
* debian/tests/unit-config: Check that enable/disable commands are
idempotent.
* debian/tests/unit-config: Detect if system units are in /usr/, so that the
test works on systems with merged /usr.
* debian/tests/unit-config: Use systemd-sysv-install instead of update-rc.d
directly, so that the test works under Fedora too.
* debian/tests/unit-config: Check disabling of a "systemctl link"ed unit,
and check "systemctl enable" on a unit with full path which is not in the
standard directories.
* Rename debian/extra/rules/73-idrac.rules to 73-special-net-names.rules, as
it is going to get rules for other devices. Also install it into the
initramfs.
* debian/extra/rules/73-special-net-names.rules: Add DEVPATH number based
naming schema for ibmveth devices. (LP: #1561096)
* Don't set SYSTEMD_READY=0 on DM_UDEV_DISABLE_OTHER_RULES_FLAG=1 devmapper
devices with "change" events, as this causes spurious unmounting with
multipath devices. (LP: #1565969)
* Fix bogus "No [Install] section" warning when enabling a unit with full
path. (LP: #1563590)
2016-04-07 - Martin Pitt <martin.pitt@ubuntu.com>
systemd (229-4ubuntu1) xenial; urgency=medium
* Merge with Debian unstable. Remaining Ubuntu changes:
- Hack to support system-image read-only /etc, and modify files in
/etc/writable/ instead.
Upgrade fixes, keep until 16.04 LTS release:
- systemd Conflicts/Replaces/Provides systemd-services.
- Remove obsolete systemd-logind upstart job.
- Clean up obsolete /etc/udev/rules.d/README.
- systemd.postinst: Migrate mountall specific fstab options to standard
util-linux "nofail" option.
- systemctl: Don't forward telinit u to upstart. This works around
upstart's Restart() always reexec'ing /sbin/init on Restart(), even if
that changes to point to systemd during the upgrade. This avoids running
systemd during a dist-upgrade. (LP: #1430479)
- Provide shutdown fallback for upstart. (LP: #1370329)
- Break lvm (<< 2.02.133-1ubuntu1) and remove our dummy /etc/init.d/lvm2
on upgrades, as it's shipped by lvm2 now.
- Make udev break on mdadm << 3.3-2ubuntu3, as udev's init script dropped
the "Provides: raid-mdadm".
- Clean up /var/log/udev on upgrade (which is written under upstart, but
not under systemd). (LP: #1537211)
- Migrate existing s390x network configuration to new names. (LP: #1526808)
- systemd.postinst: Bump Version comparison for migrating the UTC setting
from /etc/default/rcS to /etc/adjtime, to run it for upgrades to 16.04.
- VMWare BIOS reports implausibly high onboard numbers. This got fixed in
upstream commit 6c1e69f9. Migrate names in ifupdown accordingly.
(LP: #1550539)
- udev: Don't kill peer processes if we don't run in a cgroup. This happens
when running under/upgrading from upstart. udevd and everything else run
in the root hierarchy on all controllers then, and the alleged cleanup of
"our" cgroup becomes a system-wide killing spree. (LP: #1555237)

See Also

Package Description
libpam0g-dev_1.1.8-3.2ubuntu2_amd64.deb Development files for PAM
libpam0g_1.1.8-3.2ubuntu2_amd64.deb Pluggable Authentication Modules library
libpango-1.0-0_1.38.1-1_amd64.deb Layout and rendering of internationalized text
libpango1.0-0_1.38.1-1_amd64.deb Layout and rendering of internationalized text (transitional package)
libpango1.0-dev_1.38.1-1_amd64.deb Development files for the Pango
libpango1.0-doc_1.38.1-1_all.deb Documentation files for the Pango
libpangocairo-1.0-0_1.38.1-1_amd64.deb Layout and rendering of internationalized text
libpangoft2-1.0-0_1.38.1-1_amd64.deb Layout and rendering of internationalized text
libpangomm-1.4-1v5_2.38.1-1_amd64.deb C++ Wrapper for pango (shared libraries)
libpangomm-1.4-dev_2.38.1-1_amd64.deb C++ Wrapper for pango (development files)
libpangomm-1.4-doc_2.38.1-1_all.deb C++ Wrapper for pango (documentation)
libpangox-1.0-0_0.0.2-5_amd64.deb pango library X backend
libpangox-1.0-dev_0.0.2-5_amd64.deb pango library X backend - development files
libpangoxft-1.0-0_1.38.1-1_amd64.deb Layout and rendering of internationalized text
libpaper-dev_1.1.24+nmu4ubuntu1_amd64.deb library for handling paper characteristics (development files)
Advertisement
Advertisement