libpackagekit-glib2-16_0.8.17-4ubuntu6~gcc5.4ubuntu1_amd64.deb


Advertisement

Description

libpackagekit-glib2-16 - Library for accessing PackageKit using GLib

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libpackagekit-glib2-16_0.8.17-4ubuntu6~gcc5.4ubuntu1_amd64.deb
Package name libpackagekit-glib2-16
Package version 0.8.17
Package release 4ubuntu6~gcc5.4ubuntu1
Package architecture amd64
Package type deb
Category libs
Homepage http://www.packagekit.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 98.17 KB
Installed size 413.00 KB
PackageKit allows performing simple software management tasks over a DBus
interface e.g. refreshing the cache, updating, installing and removing
software packages or searching for multimedia codecs and file handlers.
This package provides an advanced library to access PackageKit using GLib.
It makes use of only async D-Bus calls and provides high level tasks which
peform the "transaction dance".

Alternatives

Package Version Architecture Repository
libpackagekit-glib2-16_0.8.17-4ubuntu6~gcc5.4ubuntu1.4_i386.deb 0.8.17 i386 Ubuntu Updates Main
libpackagekit-glib2-16_0.8.17-4ubuntu6~gcc5.4ubuntu1.4_amd64.deb 0.8.17 amd64 Ubuntu Updates Main
libpackagekit-glib2-16_0.8.17-4ubuntu6~gcc5.4ubuntu1_i386.deb 0.8.17 i386 Ubuntu Main
libpackagekit-glib2-16 - - -

Requires

Name Value
libc6 >= 2.7
libglib2.0-0 >= 2.37.3
libsqlite3-0 >= 3.5.9

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libpackagekit-glib2-16_0.8.17-4ubuntu6~gcc5.4ubuntu1_amd64.deb
Source Package packagekit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpackagekit-glib2-16 deb package:
    # sudo apt-get install libpackagekit-glib2-16

Files

Path
/usr/lib/x86_64-linux-gnu/libpackagekit-glib2.so.16
/usr/lib/x86_64-linux-gnu/libpackagekit-glib2.so.16.3.0
/usr/share/doc/libpackagekit-glib2-16/changelog.Debian.gz
/usr/share/doc/libpackagekit-glib2-16/copyright

Changelog

2015-12-09 - Dimitri John Ledkov <xnox@ubuntu.com>
packagekit (0.8.17-4ubuntu6~gcc5.4ubuntu1) xenial; urgency=high
* Cherrypick
https://github.com/hughsie/PackageKit/commit/30bfee4d41944bbfbd7a40c7f3fa1004fc6effa9
to fix FTBFS with apt 1.1.
2015-12-09 - Dimitri John Ledkov <xnox@ubuntu.com>
packagekit (0.8.17-4ubuntu6~gcc5.4) xenial; urgency=high
* No change rebuild against libapt-pkg5.0 / libapt-inst2.0
2015-10-05 - Michael Vogt <michael.vogt@ubuntu.com>
packagekit (0.8.17-4ubuntu6~gcc5.3) wily; urgency=medium
* No-change rebuild against libapt-pkg4.16
2015-07-20 - Matthias Klose <doko@ubuntu.com>
packagekit (0.8.17-4ubuntu6~gcc5.2) wily; urgency=medium
* Rebuild for apt transition.
2015-07-17 - Steve Langasek <steve.langasek@ubuntu.com>
packagekit (0.8.17-4ubuntu6~gcc5.1) wily; urgency=medium
* No-change test rebuild for g++5 ABI transition
2015-07-17 - Martin Pitt <martin.pitt@ubuntu.com>
packagekit (0.8.17-4ubuntu5) wily; urgency=medium
* Build-depend on libsystemd only, instead of the deprecated libsystemd-*
libs. Backported 02_libsystemd-only.patch from Debian and adjusted to this
old version.
2015-01-26 - Martin Pitt <martin.pitt@ubuntu.com>
packagekit (0.8.17-4ubuntu4) vivid; urgency=medium
* No-change rebuild against libsystemd0.
2014-09-11 - Colin Watson <cjwatson@ubuntu.com>
packagekit (0.8.17-4ubuntu3) utopic; urgency=medium
* Link aptcc against -lutil for forkpty (LP: #1368246).
2014-08-27 - Michael Vogt <michael.vogt@ubuntu.com>
packagekit (0.8.17-4ubuntu2) utopic; urgency=low
* debian/patches/git57c504e.diff
- backport --allow-untrusted option from upstream git #57c504e
(LP: #1360582)
2014-06-19 - Iain Lane <iain@orangesquash.org.uk>
packagekit (0.8.17-4ubuntu1) utopic; urgency=low
* Merge with Debian unstable. Remaining changes:
+ Client tools alternatively depend on or recommend aptdaemon's
compatibility layer
+ packagekit provides the virtual packagekit-system-interface
+ Allow beta versions of firefox-dev >= 30, remove iceweasel-dev.
+ Add break on packagekit-plugin-click <= 0.3
+ Temporarily disable browser plugin on ppc64el, to help with
bootstrapping this new architecture.
+ Drop using ubuntu.series.

See Also

Package Description
libpackagekit-glib2-dev_0.8.17-4ubuntu6~gcc5.4ubuntu1_amd64.deb Library for accessing PackageKit using GLib (development files)
libpagemaker-0.0-0_0.0.3-1ubuntu1_amd64.deb Library for importing and converting PageMaker Documents
libpagemaker-dev_0.0.3-1ubuntu1_amd64.deb Library for importing and converting PageMaker Documents -- development
libpam-apparmor_2.10.95-0ubuntu2_amd64.deb changehat AppArmor library as a PAM module
libpam-cap_2.24-12_amd64.deb POSIX 1003.1e capabilities (PAM module)
libpam-cgfs_2.0.0-0ubuntu2_amd64.deb FUSE based filesystem for LXC
libpam-cracklib_1.1.8-3.2ubuntu2_amd64.deb PAM module to enable cracklib support
libpam-doc_1.1.8-3.2ubuntu2_all.deb Documentation of PAM
libpam-gnome-keyring_3.18.3-0ubuntu2_amd64.deb PAM module to unlock the GNOME keyring upon login
libpam-krb5_4.7-2_amd64.deb PAM module for MIT Kerberos
libpam-modules-bin_1.1.8-3.2ubuntu2_amd64.deb Pluggable Authentication Modules for PAM - helper binaries
libpam-modules_1.1.8-3.2ubuntu2_amd64.deb Pluggable Authentication Modules for PAM
libpam-mount_2.14-1.1_amd64.deb PAM module that can mount volumes for a user session
libpam-p11_0.1.5-4_amd64.deb PAM module for using PKCS#11 smart cards
libpam-pwquality_1.3.0-0ubuntu1_amd64.deb PAM module to check password strength
Advertisement
Advertisement