libotf-dev_0.9.13-3_amd64.deb


Advertisement

Description

libotf-dev - Library for handling OpenType Font - development

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libotf-dev_0.9.13-3_amd64.deb
Package name libotf-dev
Package version 0.9.13
Package release 3
Package architecture amd64
Package type deb
Category libdevel
Homepage http://www.nongnu.org/m17n/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 48.03 KB
Installed size 172.00 KB
The libotf library provides the following facilities:
- Read Open Type Layout Tables from OTF file.  Currently these
tables are supported; head, name, cmap, GDEF, GSUB, and GPOS.
- Convert a Unicode character sequence to a glyph code sequence by
using the above tables.
The combination of libotf and the FreeType library (Ver.2) realizes
CTL (complex text layout) by OpenType fonts.
This package contains the header and development files needed to build
programs and packages using libotf.

Alternatives

Package Version Architecture Repository
libotf-dev_0.9.13-3_i386.deb 0.9.13 i386 Ubuntu Main
libotf-dev - - -

Requires

Name Value
libotf0 = 0.9.13-3
pkg-config -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libotf-dev_0.9.13-3_amd64.deb
Source Package libotf

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libotf-dev deb package:
    # sudo apt-get install libotf-dev

Files

Path
/usr/bin/libotf-config
/usr/include/otf.h
/usr/lib/x86_64-linux-gnu/libotf.a
/usr/lib/x86_64-linux-gnu/libotf.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libotf.pc
/usr/share/doc/libotf-dev/changelog.Debian.gz
/usr/share/doc/libotf-dev/copyright
/usr/share/man/man1/libotf-config.1.gz

Changelog

2016-01-11 - Harshula Jayasuriya <harshula@debian.org>
libotf (0.9.13-3) unstable; urgency=low
* Enable Multi-arch support
* debian/control:
- Update Standards-Version to Debian Policy 3.9.6. (No changes)
2014-09-09 - Harshula Jayasuriya <harshula@debian.org>
libotf (0.9.13-2) unstable; urgency=low
* debian/control:
- Remove DM-Upload-Allowed: yes
- Add Vcs-Git & Vcs-Browser
- Update Standards-Version to Debian Policy 3.9.5. (No changes)
* Fix debian-changelog-has-wrong-weekday
* Use dh-autoreconf (Closes: #749530).
2012-12-15 - Harshula Jayasuriya <harshula@debian.org>
libotf (0.9.13-1) unstable; urgency=low
* New upstream release 0.9.13.
* Upstream has moved to https://savannah.nongnu.org/projects/m17n.
* Updated to debhelper 9.
* debian/copyright: update tarball location, homepage, copyright dates.
* debian/rules: use dpkg-buildflags
2012-05-27 - Harshula Jayasuriya <harshula@debian.org>
libotf (0.9.12-2) unstable; urgency=low
* Update maintainer email address.
* Update Standards-Version to Debian Policy 3.9.3. (No changes)
* debian/control: add libotf-bin conflicts with otf-trace (#673744).
* Fix description-synopsis-starts-with-article.
* Fix debian-rules-missing-recommended-target.
* Add libotf-config man page.
2010-11-12 - Harshula Jayasuriya <harshula@gmail.com>
libotf (0.9.12-1) unstable; urgency=low
* New upstream release 0.9.12.
* Update Standards-Version to Debian Policy 3.9.1. (no changes)
* debian/copyright: update dates
* debian/libotf-dev.install: don't include .la files in -dev.
2010-06-26 - Harshula Jayasuriya <harshula@gmail.com>
libotf (0.9.11-1) unstable; urgency=low
* New upstream release 0.9.11.
* Update Standards-Version to Debian Policy 3.8.4. (no changes)
* Update debian/libotf0.symbols.
* debian/copyright: update dates
* debian/source/format: 3.0 (quilt)
* debian/libotf0.symbols: update symbols
2009-10-26 - Harshula Jayasuriya <harshula@gmail.com>
libotf (0.9.10-1) unstable; urgency=low
* New upstream release 0.9.10.
* Update Standards-Version to Debian Policy 3.8.3. (no changes)
* debian/control:
- move package libotf0-dbg to section debug.
- DM-Upload-Allowed: yes
* debian/copyright: specify the version of the license file.
* Add debian/libotf0.symbols (Closes: #547185).
2009-03-03 - Harshula Jayasuriya <harshula@gmail.com>
libotf (0.9.9-1) unstable; urgency=low
* New upstream release 0.9.9.
* debian/copyright: update the copyright year.
* debian/control: inherit Priority and Section.
2009-02-19 - Harshula Jayasuriya <harshula@gmail.com>
libotf (0.9.8-1) unstable; urgency=low
* New upstream release 0.9.8. (Closes: #466815, #476625)
* New Maintainer. (Closes: #512068)
* Update Standards-Version to Debian Policy 3.8.0. (no changes)
* debian/compat: update to compat level 7.
* debian/control:
- Replace ${Source-Version} with ${binary:Version}.
- Add ${misc:Depends}.
- Add the Homepage field.
* debian/copyright: updated to LGPL 2.1 and added the copyright message.
* debian/rules: stop using CDBS.
* Add debian/{docs,watch}.
* Add the pkg-config file to the package.
2006-01-28 - Hidetaka Iwai <tyuyu@debian.or.jp>
libotf (0.9.4-1) unstable; urgency=low
* New upstream release
* Previous NMU acknowledged (Closes: #335135).
* Added a new package for debugging; libotf0-dbg.
* Updated standards version to 3.6.2.

See Also

Package Description
libotf0_0.9.13-3_amd64.deb Library for handling OpenType Font - runtime
libotp0-heimdal_1.7~git20150920+dfsg-4ubuntu1_amd64.deb Heimdal Kerberos - OTP support library
liboxideqt-qmlplugin_1.13.6-0ubuntu1_amd64.deb Web browser engine for Qt (QML plugin)
liboxideqtcore-dev_1.13.6-0ubuntu1_amd64.deb Web browser engine for Qt (development files for core library)
liboxideqtcore0_1.13.6-0ubuntu1_amd64.deb Web browser engine for Qt (core library and components)
liboxideqtquick-dev_1.13.6-0ubuntu1_amd64.deb Web browser engine for Qt (development files for QtQuick library)
liboxideqtquick0_1.13.6-0ubuntu1_amd64.deb Web browser engine for Qt (QtQuick library)
libp11-2_0.3.1-1_amd64.deb pkcs#11 convenience library
libp11-dev_0.3.1-1_amd64.deb pkcs#11 convenience library - development files
libp11-kit-dev_0.23.2-3_amd64.deb Library for loading and coordinating access to PKCS#11 modules - development
libp11-kit-gnome-keyring_3.18.3-0ubuntu2_amd64.deb GNOME keyring module for the PKCS#11 module loading library
libp11-kit0_0.23.2-3_amd64.deb Library for loading and coordinating access to PKCS#11 modules - runtime
libpackagekit-glib2-16_0.8.17-4ubuntu6~gcc5.4ubuntu1_amd64.deb Library for accessing PackageKit using GLib
libpackagekit-glib2-dev_0.8.17-4ubuntu6~gcc5.4ubuntu1_amd64.deb Library for accessing PackageKit using GLib (development files)
libpagemaker-0.0-0_0.0.3-1ubuntu1_amd64.deb Library for importing and converting PageMaker Documents
Advertisement
Advertisement