liborbit-2-0_2.14.19-1build1_amd64.deb


Advertisement

Description

liborbit-2-0 - high-performance CORBA implementation - common libraries

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename liborbit-2-0_2.14.19-1build1_amd64.deb
Package name liborbit-2-0
Package version 2.14.19
Package release 1build1
Package architecture amd64
Package type deb
Category libs
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 137.04 KB
Installed size 633.00 KB
CORBA (Common Object Request Broker Architecture) is an architecture
that enables program objects to communicate, sending requests and
receiving replies, between different applications, regardless of their
programming language, operating system or network location.
This package contains the run-time libraries needed by applications
that communicate with each other using the ORBit2 implementation of
CORBA.

Alternatives

Package Version Architecture Repository
liborbit-2-0_2.14.19-1build1_i386.deb 2.14.19 i386 Ubuntu Main
liborbit-2-0 - - -

Requires

Name Value
libc6 >= 2.14
libglib2.0-0 >= 2.35.9

Replaces

Name Value
liborbit2 << 1:2.14.19-0.3

Download

Type URL
Mirror archive.ubuntu.com
Binary Package liborbit-2-0_2.14.19-1build1_amd64.deb
Source Package orbit2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liborbit-2-0 deb package:
    # sudo apt-get install liborbit-2-0

Files

Path
/usr/lib/x86_64-linux-gnu/libORBit-2.so.0
/usr/lib/x86_64-linux-gnu/libORBit-2.so.0.1.0
/usr/lib/x86_64-linux-gnu/libORBitCosNaming-2.so.0
/usr/lib/x86_64-linux-gnu/libORBitCosNaming-2.so.0.1.0
/usr/lib/x86_64-linux-gnu/orbit-2.0/Everything_module.so
/usr/share/doc/liborbit-2-0/AUTHORS
/usr/share/doc/liborbit-2-0/NEWS.gz
/usr/share/doc/liborbit-2-0/README
/usr/share/doc/liborbit-2-0/TODO
/usr/share/doc/liborbit-2-0/changelog.Debian.gz
/usr/share/doc/liborbit-2-0/copyright

Changelog

2015-11-27 - Matthias Klose <doko@ubuntu.com>
orbit2 (1:2.14.19-1build1) xenial; urgency=medium
* No-change rebuild for libidl soname change.
2015-05-08 - Emanuele Rocca <ema@debian.org>
orbit2 (1:2.14.19-1) unstable; urgency=low
* QA upload.
* Maintainer field set to QA Group.
* Bump Standards-Version to 3.9.6.
2013-11-17 - Josselin Mouette <joss@debian.org>
orbit2 (1:2.14.19-0.3) unstable; urgency=low
* Non-maintainer upload.
* Move orbit-idl-2 to orbit2, update dependencies accordingly.
* orbit2-config-multiarch.patch: new patch. Remove useless lines from 
orbit2-config that break the MA-same expectation.
* All of this allows us to make liborbit2-dev Multi-Arch: same.
* Drop useless Everything_module.a.
* Move libORBit-2 and libORBitCosNaming-2 to a new liborbit-2-0 
package. This will avoid pulling libidl0 and its cpp dependency on 
machines that need liborbit.
* Bump standards version.
* Convert to 3.0 quilt format.
* Remove m68k patch, we don’t ship this architecture anymore.
* Update package descriptions. Closes: #493468.
* Correctly cleanup built documentation.
* Rename the lintian override file to the correct name.
2013-08-27 - Balint Reczey <balint@balintreczey.hu>
orbit2 (1:2.14.19-0.2) unstable; urgency=low
[Balint Reczey]
* Non-maintainer upload.
* incorporating patches from Ubuntu to fix build failures
[Sebastien Bacher]
* debian/patches/git_new_autotools_build.patch:
- fix the build with the new automake version
* debian/patches/glib_no_deprecations.patch: turn off glib deprecations,
to fix the build with the current version
[ Riku Voipio ]
* Multiarchize.  Closes: #641615.
[ Steve Langasek ]
* Remove .la files from the package, as they're no longer needed.
* debian/patches/pre-multiarch-compatibility.patch: Support pre-
multiarch directory as a compatibility fallback.  Closes: #641615,
LP: #977966.
2011-10-18 - Michael Biebl <biebl@debian.org>
orbit2 (1:2.14.19-0.1) unstable; urgency=low
* Non-maintainer upload, for the GNOME 3 transition.
* New upstream release.
* Update watch file.
* Use dh-autoreconf:
- Drop debian/patches/700-autoreconf.patch.
- Add Build-Depends on dh-autoreconf.
- Add autoreconf.mk include.
* debian/rules:
- Don't include autotools.mk as we already include gnome.mk.
* debian/patches/001-dont-use-atexit-handlers.patch:
- Don't use atexit handlers, as they cause gnome-settings-daemon to crash.
Use a GNU C extension instead. Patch by Rodrigo Moya.
(LP: #788710, Closes: #645704)
2011-05-29 - Luk Claes <luk@debian.org>
orbit2 (1:2.14.18-0.2) unstable; urgency=low
* Non-maintainer upload.
* Remove references to other libraries from dependency_libs field
(Closes: #619205).
2010-04-08 - Sebastian Dröge <slomo@debian.org>
orbit2 (1:2.14.18-0.1) unstable; urgency=low
* Non-maintainer upload.
* New upstream bugfix release, one API addition:
+ debian/patches/700-autoreconf.patch:
- Regenerated for the new version.
2009-11-24 - Sebastian Rittau <srittau@debian.org>
orbit2 (1:2.14.17-2) unstable; urgency=low
* debian/control: Added minimum version to debhelper and pkg-config
build-depends.
* debian/liborbit2.lintian-overrides: Ignore that the package name does
not match the .so names. This has historic reason and is not going to
change.
* debian/control: Fixed a typo in orbit2-nameserver's description.
+ Closes: #557830 "Typo in package description: "This packages""
2009-10-04 - Sebastian Rittau <srittau@debian.org>
orbit2 (1:2.14.17-1) unstable; urgency=low
* Acknowledge NMUs. Thanks, people!
+ Closes: #460403 "diff for NMU version 1:2.14.10-0.1"
+ Closes: #471275 "diff for NMU 2.14.12-0.1"
* Update Standards-Version to 3.8.3, no additional changes needed.
* Bump debhelper compatibility level to 7.

See Also

Package Description
liborbit2-dev_2.14.19-1build1_amd64.deb high-performance CORBA implementation - development
liborbit2_2.14.19-1build1_amd64.deb high-performance CORBA implementation - extra libraries
liborc-0.4-0_0.4.25-1_amd64.deb Library of Optimized Inner Loops Runtime Compiler
liborc-0.4-dev_0.4.25-1_amd64.deb Library of Optimized Inner Loops Runtime Compiler (development headers)
liborc-0.4-doc_0.4.25-1_all.deb Library of Optimized Inner Loops Runtime Compiler (documentation)
liborcus-0.10-0v5_0.9.2-4ubuntu2_amd64.deb library for processing spreadsheet documents
liborcus-dev_0.9.2-4ubuntu2_amd64.deb library for processing spreadsheet documents -- development
liborcus-spreadsheet-model-0.10-0v5_0.9.2-4ubuntu2_amd64.deb library for processing spreadsheet documents - spreadsheet model library
libosmesa6-dev_11.2.0-1ubuntu2_amd64.deb Mesa Off-screen rendering extension -- development files
libosmesa6_11.2.0-1ubuntu2_amd64.deb Mesa Off-screen rendering extension
libosp-dev_1.5.2-13ubuntu1_amd64.deb OpenJade group's SP suite, developer support
libosp5_1.5.2-13ubuntu1_amd64.deb Runtime library for OpenJade group's SP suite
libostyle-dev_1.4devel1-21.1_amd64.deb OpenJade libraries, developer support
libostyle1c2_1.4devel1-21.1_amd64.deb Runtime libraries for OpenJade
libotf-dev_0.9.13-3_amd64.deb Library for handling OpenType Font - development
Advertisement
Advertisement