libopus-dev_1.1.2-1ubuntu1_amd64.deb


Advertisement

Description

libopus-dev - Opus codec library development files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libopus-dev_1.1.2-1ubuntu1_amd64.deb
Package name libopus-dev
Package version 1.1.2
Package release 1ubuntu1
Package architecture amd64
Package type deb
Category libdevel
Homepage http://www.opus-codec.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 191.99 KB
Installed size 703.00 KB
The Opus codec is designed for interactive speech and audio transmission over
the Internet. It is designed by the IETF Codec Working Group and incorporates
technology from Skype's SILK codec and Xiph.Org's CELT codec.
It is intended to suit a wide range of interactive audio applications,
including Voice over IP, videoconferencing, in-game chat, and even remote live
music performances.  It can scale from low bit-rate narrowband speech to very
high quality stereo music. The current features are:
Bit-rates from 6 kb/s 510 kb/s
Sampling rates from 8 to 48 kHz
Frame sizes from 2.5 ms to 60 ms
Support for both constant bit-rate (CBR) and variable bit-rate (VBR)
Audio bandwidth from narrowband to full-band
Support for speech and music
Support for mono and stereo
Support for up to 255 channels (multistream frames)
Dynamically adjustable bitrate, audio bandwidth, and frame size
Good loss robustness and packet loss concealment (PLC)
Floating point and fixed-point implementation
This package provides the Opus library headers and development files.

Alternatives

Package Version Architecture Repository
libopus-dev_1.1.2-1ubuntu1_i386.deb 1.1.2 i386 Ubuntu Main
libopus-dev - - -

Requires

Name Value
libopus0 = 1.1.2-1ubuntu1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libopus-dev_1.1.2-1ubuntu1_amd64.deb
Source Package opus

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libopus-dev deb package:
    # sudo apt-get install libopus-dev

Files

Path
/usr/include/opus/opus.h
/usr/include/opus/opus_defines.h
/usr/include/opus/opus_multistream.h
/usr/include/opus/opus_types.h
/usr/lib/x86_64-linux-gnu/libopus.a
/usr/lib/x86_64-linux-gnu/libopus.so
/usr/lib/x86_64-linux-gnu/pkgconfig/opus.pc
/usr/share/doc/libopus-dev/changelog.Debian.gz
/usr/share/doc/libopus-dev/copyright

Changelog

2016-02-17 - Matthias Klose <doko@ubuntu.com>
opus (1.1.2-1ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Convert to Debhelper 9 with a simpler rules file.
- Build using dh-autoreconf.
- Add a watch file.
- debian/control: close some Lintian errors.
- Pre-depend on multiarch-support.
- Add ${misc:Depends} to package dependencies.
- Convert to debian source format 3.0 (quilt).
- Run the tests.
2016-01-13 - Ron Lee <ron@debian.org>
opus (1.1.2-1) unstable; urgency=medium
* Fixes the transient detector on silence.
* Fixes discontinuities in background noise after extended PLC.
* Make the CELT background noise estimator adapt more quickly on DTX update.
* Fixes max_decay for LFE in fixed-point.
* Fixes patch_transient_decision() for hybrid mode.
* Don't reset the RTCD arch on encoder/decoder reset.
2016-01-07 - Matthias Klose <doko@ubuntu.com>
opus (1.1.1-1ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Convert to Debhelper 9 with a simpler rules file.
- Build using dh-autoreconf.
- Add a watch file.
- debian/control: close some Lintian errors.
- Pre-depend on multiarch-support.
- Add ${misc:Depends} to package dependencies.
- Convert to debian source format 3.0 (quilt).
- Run the tests.
2015-11-27 - Ron Lee <ron@debian.org>
opus (1.1.1-1) unstable; urgency=medium
* Mostly just lots of new optimisation, with a few minor bug fixes and
quality improvements.
2014-08-26 - Ron Lee <ron@debian.org>
opus (1.1-2) unstable; urgency=medium
* Regenerate build system files, mostly to pull in a later libtool.m4
which has fixes for building the ppc64le architecture.  Closes: #751982
2013-12-09 - Ron Lee <ron@debian.org>
opus (1.1-1) unstable; urgency=low
* Bump to the final 1.1 release version.
* Relax the shlibs and track real symbol versions from here on,
now that we have a real stable release version in the distro.
2013-12-04 - Ron Lee <ron@debian.org>
opus (1.1~rc+20131204-1) unstable; urgency=low
* Really 1.1-rc3, except 3 < + to dpkg.
* Fixes fixed-point OPUS_SET_GAIN.
* Fixes fixed-point stereo regression.
2013-11-28 - Ron Lee <ron@debian.org>
opus (1.1~rc+20131128-1) unstable; urgency=low
* Fixes the EDSP asm for ARMv5TE.
* Uses the actually intended NEON code.
2013-11-26 - Ron Lee <ron@debian.org>
opus (1.1~rc-1) unstable; urgency=low
* Adds the new packet padding API and OPUS_SET_PREDICTION_DISABLED ctl.
* Supports the SET_MAX_BANDWIDTH ctl for multstream encoders too.
* Many improvements to surround encoding.
* More asm optimisation for ARM, and speed ups for other CPUs.
* Many fixes for oddball corner cases, and improvements to calibration.
2013-11-18 - Ron Lee <ron@debian.org>
opus (1.1~beta-4) unstable; urgency=low
* Revert bogus NMU.

See Also

Package Description
libopus-doc_1.1.2-1ubuntu1_all.deb libopus API documentation
libopus0_1.1.2-1ubuntu1_amd64.deb Opus codec runtime library
liborbit-2-0_2.14.19-1build1_amd64.deb high-performance CORBA implementation - common libraries
liborbit2-dev_2.14.19-1build1_amd64.deb high-performance CORBA implementation - development
liborbit2_2.14.19-1build1_amd64.deb high-performance CORBA implementation - extra libraries
liborc-0.4-0_0.4.25-1_amd64.deb Library of Optimized Inner Loops Runtime Compiler
liborc-0.4-dev_0.4.25-1_amd64.deb Library of Optimized Inner Loops Runtime Compiler (development headers)
liborc-0.4-doc_0.4.25-1_all.deb Library of Optimized Inner Loops Runtime Compiler (documentation)
liborcus-0.10-0v5_0.9.2-4ubuntu2_amd64.deb library for processing spreadsheet documents
liborcus-dev_0.9.2-4ubuntu2_amd64.deb library for processing spreadsheet documents -- development
liborcus-spreadsheet-model-0.10-0v5_0.9.2-4ubuntu2_amd64.deb library for processing spreadsheet documents - spreadsheet model library
libosmesa6-dev_11.2.0-1ubuntu2_amd64.deb Mesa Off-screen rendering extension -- development files
libosmesa6_11.2.0-1ubuntu2_amd64.deb Mesa Off-screen rendering extension
libosp-dev_1.5.2-13ubuntu1_amd64.deb OpenJade group's SP suite, developer support
libosp5_1.5.2-13ubuntu1_amd64.deb Runtime library for OpenJade group's SP suite
Advertisement
Advertisement