libopenexr-dev_2.2.0-10ubuntu2_amd64.deb


Advertisement

Description

libopenexr-dev - development files for the OpenEXR image library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libopenexr-dev_2.2.0-10ubuntu2_amd64.deb
Package name libopenexr-dev
Package version 2.2.0
Package release 10ubuntu2
Package architecture amd64
Package type deb
Category libdevel
Homepage http://www.openexr.com
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 685.25 KB
Installed size 5.43 MB
OpenEXR is a high dynamic-range (HDR) image file format developed by
Industrial Light & Magic for use in computer imaging applications.
OpenEXR's features include:
* Higher dynamic range and colour precision than existing 8- and
10-bit image file formats.
* Support for the "half" 16-bit floating-point pixel format.
* Multiple lossless image compression algorithms. Some of the
included codecs can achieve 2:1 lossless compression ratios on
images with film grain.
* Extensibility. New compression codecs and image types can easily
be added by extending the C++ classes included in the OpenEXR
software distribution. New image attributes (strings, vectors,
integers, etc.) can be added to OpenEXR image headers without
affecting backward compatibility with existing OpenEXR
applications.
This package contains the header files required if you wish to
compile/develop applications that use OpenEXR libraries.

Alternatives

Package Version Architecture Repository
libopenexr-dev_2.2.0-10ubuntu2.1_amd64.deb 2.2.0 amd64 Ubuntu Updates Main
libopenexr-dev_2.2.0-10ubuntu2.1_i386.deb 2.2.0 i386 Ubuntu Updates Main
libopenexr-dev_2.2.0-10ubuntu2_i386.deb 2.2.0 i386 Ubuntu Main
libopenexr-dev - - -

Requires

Name Value
dpkg >= 1.17.14
libilmbase-dev >= 2.2.0-6
libopenexr22 = 2.2.0-10ubuntu2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libopenexr-dev_2.2.0-10ubuntu2_amd64.deb
Source Package openexr

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libopenexr-dev deb package:
    # sudo apt-get install libopenexr-dev

Files

Path
/usr/include/OpenEXR/ImfAcesFile.h
/usr/include/OpenEXR/ImfArray.h
/usr/include/OpenEXR/ImfAttribute.h
/usr/include/OpenEXR/ImfB44Compressor.h
/usr/include/OpenEXR/ImfBoxAttribute.h
/usr/include/OpenEXR/ImfCRgbaFile.h
/usr/include/OpenEXR/ImfChannelList.h
/usr/include/OpenEXR/ImfChannelListAttribute.h
/usr/include/OpenEXR/ImfChromaticities.h
/usr/include/OpenEXR/ImfChromaticitiesAttribute.h
/usr/include/OpenEXR/ImfCompositeDeepScanLine.h
/usr/include/OpenEXR/ImfCompression.h
/usr/include/OpenEXR/ImfCompressionAttribute.h
/usr/include/OpenEXR/ImfConvert.h
/usr/include/OpenEXR/ImfDeepCompositing.h
/usr/include/OpenEXR/ImfDeepFrameBuffer.h
/usr/include/OpenEXR/ImfDeepImageState.h
/usr/include/OpenEXR/ImfDeepImageStateAttribute.h
/usr/include/OpenEXR/ImfDeepScanLineInputFile.h
/usr/include/OpenEXR/ImfDeepScanLineInputPart.h
/usr/include/OpenEXR/ImfDeepScanLineOutputFile.h
/usr/include/OpenEXR/ImfDeepScanLineOutputPart.h
/usr/include/OpenEXR/ImfDeepTiledInputFile.h
/usr/include/OpenEXR/ImfDeepTiledInputPart.h
/usr/include/OpenEXR/ImfDeepTiledOutputFile.h
/usr/include/OpenEXR/ImfDeepTiledOutputPart.h
/usr/include/OpenEXR/ImfDoubleAttribute.h
/usr/include/OpenEXR/ImfEnvmap.h
/usr/include/OpenEXR/ImfEnvmapAttribute.h
/usr/include/OpenEXR/ImfExport.h
/usr/include/OpenEXR/ImfFloatAttribute.h
/usr/include/OpenEXR/ImfForward.h
/usr/include/OpenEXR/ImfFrameBuffer.h
/usr/include/OpenEXR/ImfFramesPerSecond.h
/usr/include/OpenEXR/ImfGenericInputFile.h
/usr/include/OpenEXR/ImfGenericOutputFile.h
/usr/include/OpenEXR/ImfHeader.h
/usr/include/OpenEXR/ImfHuf.h
/usr/include/OpenEXR/ImfIO.h
/usr/include/OpenEXR/ImfInputFile.h
/usr/include/OpenEXR/ImfInputPart.h
/usr/include/OpenEXR/ImfInt64.h
/usr/include/OpenEXR/ImfIntAttribute.h
/usr/include/OpenEXR/ImfKeyCode.h
/usr/include/OpenEXR/ImfKeyCodeAttribute.h
/usr/include/OpenEXR/ImfLineOrder.h
/usr/include/OpenEXR/ImfLineOrderAttribute.h
/usr/include/OpenEXR/ImfLut.h
/usr/include/OpenEXR/ImfMatrixAttribute.h
/usr/include/OpenEXR/ImfMisc.h
/usr/include/OpenEXR/ImfMultiPartInputFile.h
/usr/include/OpenEXR/ImfMultiPartOutputFile.h
/usr/include/OpenEXR/ImfMultiView.h
/usr/include/OpenEXR/ImfName.h
/usr/include/OpenEXR/ImfNamespace.h
/usr/include/OpenEXR/ImfOpaqueAttribute.h
/usr/include/OpenEXR/ImfOutputFile.h
/usr/include/OpenEXR/ImfOutputPart.h
/usr/include/OpenEXR/ImfPartHelper.h
/usr/include/OpenEXR/ImfPartType.h
/usr/include/OpenEXR/ImfPixelType.h
/usr/include/OpenEXR/ImfPreviewImage.h
/usr/include/OpenEXR/ImfPreviewImageAttribute.h
/usr/include/OpenEXR/ImfRational.h
/usr/include/OpenEXR/ImfRationalAttribute.h
/usr/include/OpenEXR/ImfRgba.h
/usr/include/OpenEXR/ImfRgbaFile.h
/usr/include/OpenEXR/ImfRgbaYca.h
/usr/include/OpenEXR/ImfStandardAttributes.h
/usr/include/OpenEXR/ImfStringAttribute.h
/usr/include/OpenEXR/ImfStringVectorAttribute.h
/usr/include/OpenEXR/ImfTestFile.h
/usr/include/OpenEXR/ImfThreading.h
/usr/include/OpenEXR/ImfTileDescription.h
/usr/include/OpenEXR/ImfTileDescriptionAttribute.h
/usr/include/OpenEXR/ImfTiledInputFile.h
/usr/include/OpenEXR/ImfTiledInputPart.h
/usr/include/OpenEXR/ImfTiledOutputFile.h
/usr/include/OpenEXR/ImfTiledOutputPart.h
/usr/include/OpenEXR/ImfTiledRgbaFile.h
/usr/include/OpenEXR/ImfTimeCode.h
/usr/include/OpenEXR/ImfTimeCodeAttribute.h
/usr/include/OpenEXR/ImfVecAttribute.h
/usr/include/OpenEXR/ImfVersion.h
/usr/include/OpenEXR/ImfWav.h
/usr/include/OpenEXR/ImfXdr.h
/usr/include/OpenEXR/OpenEXRConfig.h
/usr/lib/x86_64-linux-gnu/libIlmImf.a
/usr/lib/x86_64-linux-gnu/libIlmImf.so
/usr/lib/x86_64-linux-gnu/libIlmImfUtil.a
/usr/lib/x86_64-linux-gnu/libIlmImfUtil.so
/usr/lib/x86_64-linux-gnu/pkgconfig/OpenEXR.pc
/usr/share/aclocal/openexr.m4
/usr/share/doc/libopenexr-dev/changelog.Debian.gz
/usr/share/doc/libopenexr-dev/copyright

Changelog

2016-04-17 - Matthias Klose <doko@ubuntu.com>
openexr (2.2.0-10ubuntu2) xenial; urgency=medium
* Add ppc64el to the archs where to ignore test results.
2016-04-05 - Matthias Klose <doko@ubuntu.com>
openexr (2.2.0-10ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Mark as optional symbols that aren't exported when building with -O3.
2016-02-27 - Matteo F. Vescovi <mfv@debian.org>
openexr (2.2.0-10) unstable; urgency=medium
* debian/patches/: patchset updated
- bug815594.patch added (Closes: #815594)
* debian/control: S-V bump 3.9.6 -> 3.9.7 (no changes needed)
2016-02-01 - Steve Langasek <steve.langasek@ubuntu.com>
openexr (2.2.0-9ubuntu1) xenial; urgency=low
* Merge from Debian unstable.  Remaining changes:
- Mark as optional symbols that aren't exported when building with -O3.
2016-02-01 - Matteo F. Vescovi <mfv@debian.org>
openexr (2.2.0-9) unstable; urgency=medium
* Upload to unstable
* debian/control: git:// -> https:// for Vcs-* fields
2016-01-18 - Mathieu Malaterre <malat@debian.org>
openexr (2.2.0-8) experimental; urgency=medium
* Make sure to use latest of ilmbase
2015-12-05 - Steve Langasek <steve.langasek@ubuntu.com>
openexr (2.2.0-7ubuntu1) xenial; urgency=medium
* Mark as optional symbols that aren't exported when building with -O3.
2015-10-19 - Mathieu Malaterre <malat@debian.org>
openexr (2.2.0-7) experimental; urgency=medium
* Fix symbols on armel/powerpc/armhf
2015-10-16 - Mathieu Malaterre <malat@debian.org>
openexr (2.2.0-6) experimental; urgency=medium
* Update symbols for s390x
* Do not run the test suite on mips/alpha/hppa
2015-10-05 - Mathieu Malaterre <malat@debian.org>
openexr (2.2.0-5) experimental; urgency=medium
* Fix tests on big endian arches

See Also

Package Description
libopenexr22_2.2.0-10ubuntu2_amd64.deb runtime files for the OpenEXR image library
libopenhpi-dev_2.14.1-1.4ubuntu1_amd64.deb OpenHPI libraries (development files)
libopenhpi2_2.14.1-1.4ubuntu1_amd64.deb OpenHPI libraries (runtime and support files)
libopenipmi-dev_2.0.18-0ubuntu11_amd64.deb Intelligent Platform Management Interface - development
libopenipmi0_2.0.18-0ubuntu11_amd64.deb Intelligent Platform Management Interface - runtime
libopenobex2-dev_1.7.1-5_amd64.deb OBEX protocol library - development files
libopenobex2_1.7.1-5_amd64.deb OBEX protocol library
libopenvg1-mesa-dev-lts-utopic_10_amd64.deb Transitional package for libopenvg1-mesa-dev-lts-utopic
libopenvg1-mesa-lts-utopic_10_amd64.deb Transitional package for libopenvg1-mesa-lts-utopic
libopts25-dev_5.18.7-3_amd64.deb automated option processing library based on autogen
libopts25_5.18.7-3_amd64.deb automated option processing library based on autogen
libopus-dev_1.1.2-1ubuntu1_amd64.deb Opus codec library development files
libopus-doc_1.1.2-1ubuntu1_all.deb libopus API documentation
libopus0_1.1.2-1ubuntu1_amd64.deb Opus codec runtime library
liborbit-2-0_2.14.19-1build1_amd64.deb high-performance CORBA implementation - common libraries
Advertisement
Advertisement