libnewt-dev_0.52.18-1ubuntu2_amd64.deb


Advertisement

Description

libnewt-dev - Developer's toolkit for newt windowing library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libnewt-dev_0.52.18-1ubuntu2_amd64.deb
Package name libnewt-dev
Package version 0.52.18
Package release 1ubuntu2
Package architecture amd64
Package type deb
Category libdevel
Homepage https://fedorahosted.org/newt/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 58.64 KB
Installed size 257.00 KB
These are the header files and libraries for developing applications
which use newt. Newt is a windowing toolkit for text mode, which provides
many widgets and stackable windows.

Alternatives

Package Version Architecture Repository
libnewt-dev_0.52.18-1ubuntu2_i386.deb 0.52.18 i386 Ubuntu Main
libnewt-dev - - -

Requires

Name Value
libnewt0.52 = 0.52.18-1ubuntu2
libslang2-dev >= 2.0.2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libnewt-dev_0.52.18-1ubuntu2_amd64.deb
Source Package newt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnewt-dev deb package:
    # sudo apt-get install libnewt-dev

Files

Path
/usr/include/newt.h
/usr/lib/x86_64-linux-gnu/libnewt.a
/usr/lib/x86_64-linux-gnu/libnewt.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libnewt.pc
/usr/share/doc/libnewt-dev/README.Debian
/usr/share/doc/libnewt-dev/changelog.Debian.gz
/usr/share/doc/libnewt-dev/copyright
/usr/share/doc/libnewt-dev/tutorial.html/t1.html
/usr/share/doc/libnewt-dev/tutorial.html/x100.html
/usr/share/doc/libnewt-dev/tutorial.html/x197.html
/usr/share/doc/libnewt-dev/tutorial.html/x223.html

Changelog

2016-01-18 - Matthias Klose <doko@ubuntu.com>
newt (0.52.18-1ubuntu2) xenial; urgency=medium
* No-change rebuild to drop python3.4 support.
2015-08-27 - Matthias Klose <doko@ubuntu.com>
newt (0.52.18-1ubuntu1) wily; urgency=medium
* Merge with Debian; remaining changes:
- Fix python-* package descriptions.
- Install/remove alternatives for the ubuntu palette.
- Don't install python-newt example files.
- Install whiptail in /bin instead of /usr/bin.
- Install library into /lib instead of /usr/lib.
* Revert the stage1 changes, the package can be cross-built without it.
2015-07-25 - Alastair McKinstry <mckinstry@debian.org>
newt (0.52.18-1) unstable; urgency=medium
* New upstream release. 
* Patch from Helmut Grohne to enable stage1 build profile
without python. Closes: #757100.
* Standards-Version: 3.9.6
* Patch from Peter Simon correcting whiptail manpage. Closes: #745238
* Patch from Matthias Klose for python3.5 transition. Closes: #793575.
* Fix missing examples. Closes: #714783
* Typos in whiptail.1; Closes: #772142, #773298.
* Move bash_completions.d to /usr/share/bash-completion/completions
2014-06-09 - Alastair McKinstry <mckinstry@debian.org>
newt (0.52.17-1) unstable; urgency=medium
* Move to new release 0.5.17.
- snackmodule now renamed 'snack' in python, tclsh.
- python3 now in upstream. Remove patch.
* Now Standards-Version: 3.9.5 
* Use 'xz' compression. 
* Add bash completion to whiptail. 
* Mark whiptail as 'Mult-Arch: foreign'. Closes:#750767. 
* Add bash_completion for whiptail.
2015-07-24 - Matthias Klose <doko@ubuntu.com>
newt (0.52.15-3ubuntu4) wily; urgency=medium
* Fix the abi tag for python3.5. LP: #1477759.
2015-07-22 - Steve Langasek <steve.langasek@ubuntu.com>
newt (0.52.15-3ubuntu3) wily; urgency=medium
* No-change rebuild for python3.5 transition
2015-07-22 - Steve Langasek <steve.langasek@ubuntu.com>
newt (0.52.15-3ubuntu2) wily; urgency=medium
* No-change rebuild for python3.5 transition
2014-06-03 - Michael Vogt <michael.vogt@ubuntu.com>
newt (0.52.15-3ubuntu1) utopic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- Fix python-* package descriptions.
- Install/remove alternatives for the ubuntu palette.
- Don't install python-newt example files.
- Install whiptail in /bin instead of /usr/bin.
* Still build with tcl8.5 (8.6 is in universe).
2013-09-09 - Alastair McKinstry <mckinstry@debian.org>
newt (0.52.15-3) unstable; urgency=low
* Fix handling of alternatives for /etc/newt/palette in M-A package
libnewt0.52. CLoses: #718635
2014-03-23 - Matthias Klose <doko@ubuntu.com>
newt (0.52.15-2ubuntu5) trusty; urgency=medium
* No-change rebuild to drop Python 3.3 support.

See Also

Package Description
libnewt0.52_0.52.18-1ubuntu2_amd64.deb Not Erik's Windowing Toolkit - text mode windowing with slang
libnfnetlink-dev_1.0.1-3_amd64.deb Development files for libnfnetlink0
libnfnetlink0_1.0.1-3_amd64.deb Netfilter netlink library
libnfsidmap-dev_0.25-5_amd64.deb header files and docs for libnfsidmap
libnfsidmap2_0.25-5_amd64.deb NFS idmapping library
libnih-dbus-dev_1.0.3-4.3ubuntu1_amd64.deb NIH D-Bus Bindings Library (development files)
libnih-dbus1_1.0.3-4.3ubuntu1_amd64.deb NIH D-Bus Bindings Library
libnih-dev_1.0.3-4.3ubuntu1_amd64.deb NIH Utility Library (development files)
libnih1_1.0.3-4.3ubuntu1_amd64.deb NIH Utility Library
libnl-3-200_3.2.27-1_amd64.deb library for dealing with netlink sockets
libnl-3-dev_3.2.27-1_amd64.deb development library and headers for libnl-3
libnl-cli-3-200_3.2.27-1_amd64.deb library for dealing with netlink sockets - cli helpers
libnl-cli-3-dev_3.2.27-1_amd64.deb development library and headers for libnl-cli-3
libnl-genl-3-200_3.2.27-1_amd64.deb library for dealing with netlink sockets - generic netlink
libnl-genl-3-dev_3.2.27-1_amd64.deb development library and headers for libnl-genl-3
Advertisement
Advertisement