libmng2_2.0.2-0ubuntu3_amd64.deb


Advertisement

Description

libmng2 - Multiple-image Network Graphics library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libmng2_2.0.2-0ubuntu3_amd64.deb
Package name libmng2
Package version 2.0.2
Package release 0ubuntu3
Package architecture amd64
Package type deb
Category libs
Homepage http://www.libmng.com
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 165.05 KB
Installed size 583.00 KB
The libmng library supports decoding, displaying, encoding, and various other
manipulations of the Multiple-image Network Graphics (MNG) format image files.
It uses the zlib compression library, and optionally the JPEG library by the
Independent JPEG Group (IJG) and/or lcms (little cms), a color-management
library by Marti Maria Saguar.

Alternatives

Package Version Architecture Repository
libmng2_2.0.2-0ubuntu3_i386.deb 2.0.2 i386 Ubuntu Main
libmng2 - - -

Requires

Name Value
libc6 >= 2.14
libjpeg8 >= 8c
liblcms2-2 >= 2.2+git20110628
multiarch-support -
zlib1g >= 1:1.1.4

Replaces

Name Value
libmng -
libmng-dev << 1.0.0-3

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libmng2_2.0.2-0ubuntu3_amd64.deb
Source Package libmng

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmng2 deb package:
    # sudo apt-get install libmng2

Files

Path
/usr/lib/x86_64-linux-gnu/libmng.so.2
/usr/lib/x86_64-linux-gnu/libmng.so.2.0.2
/usr/share/doc/libmng2/README
/usr/share/doc/libmng2/changelog.Debian.gz
/usr/share/doc/libmng2/copyright

Changelog

2013-12-16 - Matthias Klose <doko@ubuntu.com>
libmng (2.0.2-0ubuntu3) trusty; urgency=medium
* Run make distclean in the clean target, the tarball contains
generated files.
2013-12-16 - Matthias Klose <doko@ubuntu.com>
libmng (2.0.2-0ubuntu1) trusty; urgency=medium
* New upstream version.
* Build using lcms2.
* Build using dh-autoreconf.
* Honor dpkg-buildflags.
* Package pkg-config file.
2012-10-05 - Colin Watson <cjwatson@ubuntu.com>
libmng (1.0.10-3build1) quantal; urgency=low
* Rebuild for new armel compiler default of ARMv5t.
2011-09-16 - Kartik Mistry <kartik@debian.org>
libmng (1.0.10-3) unstable; urgency=low
* debian/control:
+ Switched to libjpeg8. (Closes: #639394)
* debian/copyright:
+ Fixed according to DEP5 format.
2011-08-14 - Kartik Mistry <kartik@debian.org>
libmng (1.0.10-2) unstable; urgency=low
* Added MultiArch support, Thanks to Steve Langasek
<steve.langasek@canonical.com> for patch (Closes: #637735)
* debian/control:
+ Updated Standards-Version to 3.9.2
* debian/rules:
+ Added needed build-* targets
* debian/copyright:
+ Updated to latest DEP-5 format
2010-06-12 - Kartik Mistry <kartik@debian.org>
libmng (1.0.10-1) unstable; urgency=low
* New upstream release (Closes: #535960)
* debian/patches/manpage-typo-fixes.diff:
+ Added patch to fix manpage spelling mistakes
* debian/patches/linux-makefile.diff:
+ Updated for makefile.linux upstream changes
+ Fixed typo at line 87
* debian/patches/kfreebsd-build-fix.diff:
+ Updated for upstream changes
* Updated debian/symbol for new symbol additions
2010-06-03 - Kartik Mistry <kartik@debian.org>
libmng (1.0.9-3) unstable; urgency=low
* Added patch to fix installation of headers files for libmng-dev and better
way to install files using dh_install. Thanks to Arnaud Fontaine
<arnau@debian.org> (Closes: #584414)
2010-06-02 - Kartik Mistry <kartik@debian.org>
libmng (1.0.9-2) unstable; urgency=low
* New maintainer (Closes: #555290)
* Updated to source format 3.0 (quilt)
* debian/control:
+ Updated Standards-Version to 3.8.4
+ Dropped build-depends on the obsolete automake1.7 and autoconf
(Closes: #573050)
+ Wrapped up description, build-depends and depends
+ Removed duplicate Section for libmng1
+ Added Homepage entry
+ Switched to substvar ${binary:Version}
+ Added ${misc:Depends} for libmng1 and libmng-dev
* We don't provide .la file as release goal (Closes: #364744)
* debian/rules:
+ Do not set compat level to 4
+ Used [ ! -f Makefile ] || $(MAKE) distclean for clean target
+ Do not use dh_undocumented
+ Used dh_prep instead of dh_clean -k
* debian/copyright:
+ Updated as per DEP-5 specification
+ Added copyright for debian/* files
* debian/patches:
+ Organized patches and added patch headers
* Added debian/watch file
* Added debian/compat file
* Added debian/symbol file
2006-04-07 - Shiju p. Nair <shiju.p@gmail.com>
libmng (1.0.9-1) unstable; urgency=low
* New upstream release. (closes: #303968, #271979)
* Patch from Aurelien Jarno <aurel32@debian.org> to support GNU/kFreeBSD.
Closes: #314696)
* Patch from Christopher Bodenstein <cb@physicman.net> to support
hurd-i386. (closes: #361103)
* README.Debian provide information on what options are compiled in to
libmng.(closes: #174523)
2004-09-27 - Shiju p. Nair <shiju.p@gmail.com>
libmng (1.0.8-1) unstable; urgency=low
* New upstream release (closes: #250106).
* Removed unwanted dependencies (closes: #256526, #218469)

See Also

Package Description
libmnl-dev_1.0.3-5_amd64.deb minimalistic Netlink communication library (devel)
libmnl0_1.0.3-5_amd64.deb minimalistic Netlink communication library
libmono-2.0-dev_4.2.1.102+dfsg2-7ubuntu4_amd64.deb Mono JIT library - Development files (Default version)
libmono-accessibility4.0-cil_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono Accessibility library (for CLI 4.0)
libmono-c5-1.1-cil_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono C5 library
libmono-cairo4.0-cil_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono Cairo library (for CLI 4.0)
libmono-cecil-private-cil_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono.Cecil library
libmono-cil-dev_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono Base Class Libraries (BCL) - Development files
libmono-codecontracts4.0-cil_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono.CodeContracts library (for CLI 4.0)
libmono-compilerservices-symbolwriter4.0-cil_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono.CompilerServices.SymbolWriter library (for CLI 4.0)
libmono-corlib4.5-cil_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono core library (for CLI 4.5)
libmono-cscompmgd0.0-cil_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono cscompmgd library (for CLI 4.0)
libmono-csharp4.0c-cil_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono.CSharp library (for CLI 4.0)
libmono-custommarshalers4.0-cil_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono CustomMarshalers library (for CLI 4.0)
libmono-data-tds4.0-cil_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono Data Library (for CLI 4.0)
Advertisement
Advertisement