liblpsolve55-dev_5.5.0.13-7build2_amd64.deb


Advertisement

Description

liblpsolve55-dev - Solve (mixed integer) linear programming problems - library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename liblpsolve55-dev_5.5.0.13-7build2_amd64.deb
Package name liblpsolve55-dev
Package version 5.5.0.13
Package release 7build2
Package architecture amd64
Package type deb
Category math
Homepage http://lpsolve.sourceforge.net
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 423.31 KB
Installed size 2.07 MB
The linear programming (LP) problem can be formulated as: Solve A.x >=
V1, with V2.x maximal. A is a matrix, x is a vector of (nonnegative)
variables, V1 is a vector called the right hand side, and V2 is a vector
specifying the objective function.
An integer linear programming (ILP) problem is an LP with the
constraint that all the variables are integers.  In a mixed integer
linear programming (MILP) problem, some of the variables are integer
and others are real.
The program lp_solve solves LP, ILP, and MILP problems. It is slightly
more general than suggested above, in that every row of A (specifying
one constraint) can have its own (in)equality, <=, >= or =. The result
specifies values for all variables.
lp_solve uses the 'Simplex' algorithm and sparse matrix methods for
pure LP problems.  If one or more of the variables is declared
integer, the Simplex algorithm is iterated with a branch and bound
algorithm, until the desired optimal solution is found.  lp_solve can
read MPS format input files.
This package contains the static library for developing programs using
liblpsolve.
Homepage http://www.geocities.com/lpsolve/

Alternatives

Package Version Architecture Repository
liblpsolve55-dev_5.5.0.13-7build2_i386.deb 5.5.0.13 i386 Ubuntu Main
liblpsolve55-dev - - -

Requires

Name Value
libsuitesparse-dev -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package liblpsolve55-dev_5.5.0.13-7build2_amd64.deb
Source Package lp-solve

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblpsolve55-dev deb package:
    # sudo apt-get install liblpsolve55-dev

Files

Path
/usr/include/lpsolve/commonlib.h
/usr/include/lpsolve/lp_Hash.h
/usr/include/lpsolve/lp_MDO.h
/usr/include/lpsolve/lp_MPS.h
/usr/include/lpsolve/lp_SOS.h
/usr/include/lpsolve/lp_crash.h
/usr/include/lpsolve/lp_explicit.h
/usr/include/lpsolve/lp_fortify.h
/usr/include/lpsolve/lp_lib.h
/usr/include/lpsolve/lp_matrix.h
/usr/include/lpsolve/lp_mipbb.h
/usr/include/lpsolve/lp_presolve.h
/usr/include/lpsolve/lp_price.h
/usr/include/lpsolve/lp_pricePSE.h
/usr/include/lpsolve/lp_report.h
/usr/include/lpsolve/lp_rlp.h
/usr/include/lpsolve/lp_scale.h
/usr/include/lpsolve/lp_simplex.h
/usr/include/lpsolve/lp_solveDLL.h
/usr/include/lpsolve/lp_types.h
/usr/include/lpsolve/lp_utils.h
/usr/include/lpsolve/lp_wlp.h
/usr/include/lpsolve/mmio.h
/usr/include/lpsolve/myblas.h
/usr/lib/liblpsolve55.a
/usr/lib/liblpsolve55_pic.a
/usr/share/doc/liblpsolve55-dev/NEWS.Debian.gz
/usr/share/doc/liblpsolve55-dev/changelog.Debian.gz
/usr/share/doc/liblpsolve55-dev/copyright
/usr/share/doc/liblpsolve55-dev/examples/demo.c

Changelog

2015-12-01 - Graham Inggs <graham@nerve.org.za>
lp-solve (5.5.0.13-7build2) xenial; urgency=medium
* No-change rebuild against suitesparse 1:4.4.5-2
2013-12-23 - Colin Watson <cjwatson@ubuntu.com>
lp-solve (5.5.0.13-7build1) trusty; urgency=medium
* Rebuild for suitesparse 4.2.1.
2009-12-03 - Rene Engelhard <rene@debian.org>
lp-solve (5.5.0.13-7) unstable; urgency=low
* move to "3.0 (quilt)" format; move downloaded docs into extra docs
tarball and move change from 5.5.0.10-6 from only in .diff.gz (oops!)
to proper patch
* include headers needed for plugin libraries (closes: #555830), thanks
Matthias K├╝mmerer
* add ${misc:Depends} 
* remove debian/watch (closes: #529154) 
2009-06-10 - Rene Engelhard <rene@debian.org>
lp-solve (5.5.0.13-6) unstable; urgency=low
* build against suitesparse 3.4.0 (libcolamd2.7.1)
2009-05-06 - Rene Engelhard <rene@debian.org>
lp-solve (5.5.0.13-5) unstable; urgency=low
* make liblpsolve55-dev depend on libsuitesparse-dev (closes: #524295) 
2009-02-22 - Rene Engelhard <rene@debian.org>
lp-solve (5.5.0.13-4) unstable; urgency=low
* rebuild with suitesparse 1:3.2.0-2 to only get a dep on libcolamd-3.2.0
* upload to unstable 
2009-01-26 - Rene Engelhard <rene@debian.org>
lp-solve (5.5.0.13-3) experimental; urgency=low
* build against suitesparse 3.2.0 
2008-12-28 - Rene Engelhard <rene@debian.org>
lp-solve (5.5.0.13-2) experimental; urgency=low
* add Homepage: (closes: #509917) 
2008-12-01 - Rene Engelhard <rene@debian.org>
lp-solve (5.5.0.13-1) experimental; urgency=low
* New upstream release (closes: #507462)
2008-02-22 - Rene Engelhard <rene@debian.org>
lp-solve (5.5.0.10-10) unstable; urgency=low
* build against libsuitesparse-3.1.0

See Also

Package Description
liblqr-1-0-dev_0.4.2-2_amd64.deb converts plain array images into multi-size representation (developments files)
liblqr-1-0_0.4.2-2_amd64.deb converts plain array images into multi-size representation
liblrm2-dev_1.0.12~rc1+hg2777-1.2_amd64.deb Reusable cluster development files -- liblrm
liblrm2_1.0.12~rc1+hg2777-1.2_amd64.deb Reusable cluster libraries -- liblrm2
liblrmd-dev_1.1.14-2ubuntu1_amd64.deb cluster resource manager LRMD library development
liblrmd1_1.1.14-2ubuntu1_amd64.deb cluster resource manager LRMD library
liblsan0_5.3.1-14ubuntu2_amd64.deb LeakSanitizer -- a memory leak detector (runtime)
libltdl-dev_2.4.6-0.1_amd64.deb System independent dlopen wrapper for GNU libtool
libltdl7_2.4.6-0.1_amd64.deb System independent dlopen wrapper for GNU libtool
liblua5.1-0-dev_5.1.5-8ubuntu1_amd64.deb Development files for the Lua language version 5.1
liblua5.1-0_5.1.5-8ubuntu1_amd64.deb Shared library for the Lua interpreter version 5.1
liblua5.1-rrd-dev_1.5.5-4_all.deb Transitional package to lua-rrd-dev
liblua5.2-0_5.2.4-1ubuntu1_amd64.deb Shared library for the Lua interpreter version 5.2
liblua5.2-dev_5.2.4-1ubuntu1_amd64.deb Development files for the Lua language version 5.2
liblua5.3-0_5.3.1-1ubuntu2_amd64.deb Shared library for the Lua interpreter version 5.3
Advertisement
Advertisement