libldb-dev_1.1.24-1ubuntu3_amd64.deb


Advertisement

Description

libldb-dev - LDAP-like embedded database - development files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libldb-dev_1.1.24-1ubuntu3_amd64.deb
Package name libldb-dev
Package version 1.1.24
Package release 1ubuntu3
Package architecture amd64
Package type deb
Category libs
Homepage http://ldb.samba.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 212.27 KB
Installed size 1.08 MB
ldb is a LDAP-like embedded database built on top of TDB.
What ldb does is provide a fast database with an LDAP-like API designed
to be used within an application. In some ways it can be seen as a
intermediate solution between key-value pair databases and a real LDAP
database.
This package contains the development files.

Alternatives

Package Version Architecture Repository
libldb-dev_1.1.24-1ubuntu3.1_i386.deb 1.1.24 i386 Ubuntu Updates Main
libldb-dev_1.1.24-1ubuntu3.1_amd64.deb 1.1.24 amd64 Ubuntu Updates Main
libldb-dev_1.1.24-1ubuntu3_i386.deb 1.1.24 i386 Ubuntu Main
libldb-dev - - -

Requires

Name Value
libc6-dev -
libldb1 = 2:1.1.24-1ubuntu3
libtalloc-dev -
libtdb-dev -
pkg-config -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libldb-dev_1.1.24-1ubuntu3_amd64.deb
Source Package ldb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libldb-dev deb package:
    # sudo apt-get install libldb-dev

Files

Path
/usr/include/ldb.h
/usr/include/ldb_errors.h
/usr/include/ldb_handlers.h
/usr/include/ldb_module.h
/usr/include/ldb_version.h
/usr/lib/x86_64-linux-gnu/libldb.a
/usr/lib/x86_64-linux-gnu/libldb.so
/usr/lib/x86_64-linux-gnu/pkgconfig/ldb.pc
/usr/share/doc/libldb-dev/changelog.Debian.gz
/usr/share/doc/libldb-dev/copyright
/usr/share/doc/libldb-dev/examples/ldbreader.c
/usr/share/doc/libldb-dev/examples/ldifreader.c
/usr/share/man/man3/ldb.3.gz

Changelog

2016-02-18 - Matthias Klose <doko@ubuntu.com>
ldb (2:1.1.24-1ubuntu3) xenial; urgency=medium
* Build Python3 bindings.
* Bump debhelper and standards version.
* Do not generate symbols for the extension module
* Do not encode the SOABI and the multiarch string into the pytalloc-util
library, just append a '-py3'.
* Make the build log a bit more verbose.
* Remove empty maintainer script.
2016-01-06 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
ldb (2:1.1.24-1ubuntu1) xenial; urgency=medium
* Merge with Debian, remaining changes:
- debian/patches/skip-ftbfs-tests-s390x.patch: Skip FTBFS tests cases
on s390x, reported upstream.
2015-12-13 - Jelmer Vernooij <jelmer@debian.org>
ldb (2:1.1.24-1) unstable; urgency=high
* Drop '-b unstable' flag to Vcs-Git.
* New upstream release. Fixes:
- CVE-2015-3223: Denial of Service.
- CVE-2015-5330: Remote memory read.
2015-12-04 - Dimitri John Ledkov <xnox@ubuntu.com>
ldb (2:1.1.23-1ubuntu1) xenial; urgency=high
* Skip FTBFS tests cases on s390x, reported upstream.
2015-11-08 - Jelmer Vernooij <jelmer@debian.org>
ldb (2:1.1.23-1) unstable; urgency=medium
* New upstream version.
2015-09-19 - Jelmer Vernooij <jelmer@debian.org>
ldb (2:1.1.21-1) unstable; urgency=medium
* New upstream release.
* Drop patch 03_revert_ldflags_atend: applied upstream.
2015-04-27 - Jelmer Vernooij <jelmer@debian.org>
ldb (2:1.1.20-2) unstable; urgency=medium
* Add patch 01_manpage_dates: add fixed manpage dates, making the
build reproducible.
2015-04-25 - Jelmer Vernooij <jelmer@debian.org>
ldb (2:1.1.20-1) unstable; urgency=medium
* New upstream release.
* Bump standards version to 3.9.6 (no changes).
* Add patch 03_revert_ldflags_atend: revert upstream change preventing
use of -Wl,--as-needed.
* Make libldb1-dbg Multi-Arch: same.
* python-ldb-dev: Fix capitalization of 'python'.
2015-02-23 - Ivo De Decker <ivodd@debian.org>
ldb (2:1.1.17-2) unstable; urgency=high
* No changes from 1:1.1.17-1 (currently in jessie)
* Increment epoch to revert upload of 1:1.1.18-1 to unstable
* Urgency high to allow samba security upload to migrate to jessie
2014-07-05 - Jelmer Vernooij <jelmer@debian.org>
ldb (1:1.1.18-1) unstable; urgency=medium
* New upstream release.
+ Depend on tdb >= 1.3.2.
+ Fixes __attribute__((visibility)) check to not use nested functions.
Closes: #749987
* Use canonical URL in Vcs-Git field.
* Specify branch in Vcs-Git field.
* Add 02_hurd: link against pthread on the Hurd, to fix ldb module
loading. Closes: #749095

See Also

Package Description
libldb1_1.1.24-1ubuntu3_amd64.deb LDAP-like embedded database - shared library
libldl2.2.1_4.4.6-1_amd64.deb simple LDL' factorization library for sparse matrices
libldns-dev_1.6.17-8_amd64.deb ldns library for DNS programming
libldns1_1.6.17-8_amd64.deb ldns library for DNS programming
libleveldb-dev_1.18-5_amd64.deb fast key-value storage library (development files)
libleveldb1v5_1.18-5_amd64.deb fast key-value storage library
liblightdm-gobject-1-0_1.18.1-0ubuntu1_amd64.deb LightDM GObject client library
liblightdm-gobject-1-dev_1.18.1-0ubuntu1_amd64.deb LightDM GObject client library (development files)
liblightdm-gobject-1-doc_1.18.1-0ubuntu1_all.deb LightDM client library (documentation)
liblightdm-qt-3-0_1.18.1-0ubuntu1_amd64.deb LightDM Qt client library
liblightdm-qt-dev_1.18.1-0ubuntu1_amd64.deb LightDM Qt client library (development files)
liblightdm-qt5-3-0_1.18.1-0ubuntu1_amd64.deb LightDM Qt 5 client library
liblightdm-qt5-3-dev_1.18.1-0ubuntu1_amd64.deb LightDM Qt 5 client library (development files)
liblinear-dev_2.1.0+dfsg-1_amd64.deb Development libraries and header files for LIBLINEAR
liblinear-tools_2.1.0+dfsg-1_amd64.deb Standalone applications for LIBLINEAR
Advertisement
Advertisement