libjs-underscore_1.7.0~dfsg-1ubuntu1_all.deb


Advertisement

Description

libjs-underscore - JavaScript's functional programming helper library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libjs-underscore_1.7.0~dfsg-1ubuntu1_all.deb
Package name libjs-underscore
Package version 1.7.0~dfsg
Package release 1ubuntu1
Package architecture all
Package type deb
Category web
Homepage http://underscorejs.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 45.57 KB
Installed size 222.00 KB
Underscore is a utility-belt library for JavaScript that provides a lot
of the functional programming support that you would expect in
Prototype.js (or Ruby), but without extending any of the built-in
JavaScript objects.  It's the tie to go along with jQuery's tux.
Underscore provides 60-odd functions that support both the usual
functional suspects: map, select, invoke - as well as more specialized
helpers: function binding, javascript templating, deep equality
testing, and so on.  It delegates to built-in functions, if present, so
modern browsers will use the native implementations of forEach, map,
reduce, filter, every, some and indexOf.

Alternatives

Package Version Architecture Repository
libjs-underscore_1.7.0~dfsg-1ubuntu1_all.deb 1.7.0~dfsg all Ubuntu Main
libjs-underscore - - -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libjs-underscore_1.7.0~dfsg-1ubuntu1_all.deb
Source Package underscore

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libjs-underscore deb package:
    # sudo apt-get install libjs-underscore

Files

Path
/usr/share/doc/libjs-underscore/README.md
/usr/share/doc/libjs-underscore/changelog.Debian.gz
/usr/share/doc/libjs-underscore/copyright
/usr/share/doc/libjs-underscore/index.html
/usr/share/javascript/underscore/underscore.js
/usr/share/javascript/underscore/underscore.min.js

Changelog

2015-02-17 - Dmitry Shachnev <mitya57@ubuntu.com>
underscore (1.7.0~dfsg-1ubuntu1) vivid; urgency=low
* Merge from Debian unstable, remaining changes:
- Suggest javascript-common instead of recommending it.
- Build using yui-compressor, we don't want uglifyjs's dependencies
in main.
2014-10-16 - Jonas Smedegaard <dr@jones.dk>
underscore (1.7.0~dfsg-1) unstable; urgency=medium
[ upstream ]
* New upstream release(s).
* Add README.source emphasizing control.in file as *not* a
show-stopper for contributions, referring to wiki page for details.
* Declare compliance with Debian Policy 3.9.6.
* Fix use canonical Vcs-Git URL.
* Update copyright info:
+ Bump packaging license to GPL-3+.
+ Extend packaging coverage to include recent years.
+ Add alternate git source URL.
+ Extend coverage for main upstream authors.
+ Cover docs/docco.css: BSD-3-clause licensed.
* Repackage source to avoid unimportant and potentially DFSG-nonfree
fonts.
* Update Vcs-Browser URL to use cgit web frontend.
* Stop track md5sum of upstream tarball.
2013-06-19 - Dmitry Shachnev <mitya57@ubuntu.com>
underscore (1.4.4-2ubuntu1) saucy; urgency=low
* Merge from Debian unstable, remaining changes:
- Suggest javascript-common instead of recommending it.
- Build using yui-compressor, we don't want uglifyjs's dependencies
in main.
2013-05-13 - Jonas Smedegaard <dr@jones.dk>
underscore (1.4.4-2) unstable; urgency=low
* Add README.source emphasizing control.in file as *not* a
show-stopper for contributions, referring to wiki page for details.
* Bump packaging license to GPL-3+, and extend coverage to include
current year.
* Add git URL as alternate source.
* Stop tracking md5sum of upstream tarball.
2013-03-05 - Jonas Smedegaard <dr@jones.dk>
underscore (1.4.4-1) unstable; urgency=low
[ upstream ]
* New upstream release:
+ Added _.findWhere, for finding the first element in a list that
matches a particular set of keys and values.
+ Added _.partial, for partially applying a function without
changing its dynamic reference to this.
+ Simplified bind by removing some edge cases involving constructor
functions. In short: don't _.bind your constructors.
+ A minor optimization to invoke.
* Update copyright file:
+ Fix drop an obsolete reference to GPL.
+ Extend coverage of main copyright holder.
+ Fix add dummy GPL-2 License paragraph.
* Have git-import-orig suppress .gitignore files.
* Bump standards-version to 3.9.4.
* Use anonscm.debian.org URL for control file Vcs-Git field.
2013-02-16 - Dmitry Shachnev <mitya57@ubuntu.com>
underscore (1.4.3-1ubuntu1) raring; urgency=low
* Merge from Debian unstable (LP: #1127115). Remaining changes:
- Suggest javascript-common instead of recommending it.
- Build using yui-compressor, we don't want uglifyjs's dependencies
in main.
2012-12-06 - Jonas Smedegaard <dr@jones.dk>
underscore (1.4.3-1) unstable; urgency=low
[ upstream ]
* New upstream release.
+ Improved compatibility with Adobe's JS engine that can be used to
script Illustrator, Photoshop, and friends.
+ Added a default _.identity iterator to countBy and groupBy.
+ The uniq function can now take array, iterator, context as the
argument list.
+ The times function now returns the mapped array of iterator
results.
+ Simplified and fixed bugs in throttle.
+ For backwards compatibility, returned to pre-1.4.0 behavior when
+ passing null to iteration functions. They now become no-ops.
[ Jonas Smedegaard ]
* Bump dephelper compatibility level to 8.
* Update watch and rules files to use new github.com URL.
* Build-depend on devscripts, to always check copyrights during build.
* Update copyright file:
+ Update Files sections for included code copies of other projects.
+ Fix use pseudo-license and pseudo-comment sections to obey silly
restrictions of copyright format 1.0.

See Also

Package Description
libjs-yui3-common_3.5.1-1ubuntu3_all.deb Yahoo User Interface Library v3 (common files)
libjs-yui3-debug_3.5.1-1ubuntu3_all.deb Yahoo User Interface Library v3 (debug files)
libjs-yui3-doc_3.5.1-1ubuntu3_all.deb Documentation and examples for the Yahoo User Interface Library v3
libjs-yui3-full_3.5.1-1ubuntu3_all.deb Yahoo User Interface Library v3 (full, uncompressed files)
libjs-yui3-min_3.5.1-1ubuntu3_all.deb Yahoo User Interface Library v3 (minified files)
libjson-c-dev_0.11-4ubuntu2_amd64.deb JSON manipulation library - development files
libjson-c-doc_0.11-4ubuntu2_all.deb JSON manipulation library - documentation files
libjson-c2_0.11-4ubuntu2_amd64.deb JSON manipulation library - shared library
libjson-glib-1.0-0_1.1.2-0ubuntu1_amd64.deb GLib JSON manipulation library
libjson-glib-1.0-common_1.1.2-0ubuntu1_all.deb GLib JSON manipulation library (common files)
libjson-glib-dev_1.1.2-0ubuntu1_amd64.deb GLib JSON manipulation library (development files)
libjson-glib-doc_1.1.2-0ubuntu1_all.deb GLib JSON manipulation library (documentation)
libjson-perl_2.90-1_all.deb module for manipulating JSON-formatted data
libjson-xs-perl_3.010-2build1_amd64.deb module for manipulating JSON-formatted data (C/XS-accelerated)
libjson0-dev_0.11-4ubuntu2_amd64.deb JSON manipulation library (transitional package)
Advertisement
Advertisement