libjs-sphinxdoc_1.3.6-2ubuntu1_all.deb


Advertisement

Description

libjs-sphinxdoc - JavaScript support for Sphinx documentation

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libjs-sphinxdoc_1.3.6-2ubuntu1_all.deb
Package name libjs-sphinxdoc
Package version 1.3.6
Package release 2ubuntu1
Package architecture all
Package type deb
Category web
Homepage http://sphinx-doc.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 56.13 KB
Installed size 110.00 KB
Sphinx is a tool for producing documentation for Python projects, using
reStructuredText as markup language.
This package provides JavaScript code for documentation generated by Sphinx.

Alternatives

Package Version Architecture Repository
libjs-sphinxdoc_1.3.6-2ubuntu1.2_all.deb 1.3.6 all Ubuntu Updates Main
libjs-sphinxdoc_1.3.6-2ubuntu1.2_all.deb 1.3.6 all Ubuntu Updates Main
libjs-sphinxdoc_1.3.6-2ubuntu1_all.deb 1.3.6 all Ubuntu Main
libjs-sphinxdoc - - -

Requires

Name Value
libjs-jquery >= 1.11.1
libjs-underscore >= 1.3.1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libjs-sphinxdoc_1.3.6-2ubuntu1_all.deb
Source Package sphinx

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libjs-sphinxdoc deb package:
    # sudo apt-get install libjs-sphinxdoc

Files

Path
/usr/share/doc/libjs-sphinxdoc/changelog.Debian.gz
/usr/share/doc/libjs-sphinxdoc/changelog.gz
/usr/share/doc/libjs-sphinxdoc/copyright
/usr/share/javascript/sphinxdoc/index
/usr/share/javascript/sphinxdoc/1.0/css3-mediaqueries.js
/usr/share/javascript/sphinxdoc/1.0/doctools.js
/usr/share/javascript/sphinxdoc/1.0/jquery.js
/usr/share/javascript/sphinxdoc/1.0/searchtools.js
/usr/share/javascript/sphinxdoc/1.0/sidebar.js
/usr/share/javascript/sphinxdoc/1.0/theme_extras.js
/usr/share/javascript/sphinxdoc/1.0/underscore.js

Changelog

2016-03-05 - Dmitry Shachnev <mitya57@ubuntu.com>
sphinx (1.3.6-2ubuntu1) xenial; urgency=medium
* Merge with Debian unstable, remaining change:
- debian/control: Drop the build-dependency on python[3]-whoosh.
2016-03-03 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.3.6-2) unstable; urgency=medium
* Use implementation of jstest from Iain Lane in hope it succeeds on
buildds.
2016-03-02 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.3.6-1) unstable; urgency=medium
* New upstream bugfix release.
* Port jstest to WebKit2 (closes: #814909).
* Remove the now obsolete debian/TODO file.
* Update debian/source/lintian-overrides for new Lintian versions.
* Use https in Vcs-Git field.
* Bump Standards-Version to 3.9.7, no changes needed.
2016-01-26 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.3.5-1) unstable; urgency=medium
* New upstream bugfix release.
* Build-depend on Pygments 2.1, the testsuite now requires it.
2016-01-14 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.3.4-1) unstable; urgency=medium
* New upstream bugfix release.
* Clean and ignore auto-generated files.
* jstest.py: Add gi.require_version() calls to fix warnings from PyGI.
* Bump version number in sphinx-autogen manpage.
2015-12-03 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.3.3-1) unstable; urgency=medium
* New upstream bugfix release.
2015-11-30 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.3.2-1) unstable; urgency=medium
* New upstream release.
* Drop the following patches, applied upstream:
- py35compat.diff
- no_theme_rename_warning.diff
- addto_only_babel.diff
- print_help.diff
- compat_css.diff
* Refresh and rebase other patches.
* Stop exporting SOURCE_DATE_EPOCH in debian/rules.
Debhelper does it automatically since version 9.20151004.
* Update sphinx-autogen.1 man page.
2015-11-08 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.3.1-8) unstable; urgency=medium
* Do not fail on removing SOURCES.txt file when it does not exist.
Fixes build with dh-python ≥ 2.20151103.
2015-10-18 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.3.1-7) unstable; urgency=medium
* Make libjs-sphinxdoc depend on libjs-jquery ≥ 1.11.1 and libjs-underscore
≥ 1.3.1, as these are the versions used by upstream.
* Fix command in autopkgtests to make them pass.
* Update Vcs fields for Git migration.
2015-09-03 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.3.1-6) unstable; urgency=medium
* Update reproducibility patches to the latest version from Val Lorentz:
- Update reproducible_grammar.diff.
- Make searchindex generation deterministic (reproducible_searchindex.diff).

See Also

Package Description
libjs-underscore_1.7.0~dfsg-1ubuntu1_all.deb JavaScript's functional programming helper library
libjs-yui3-common_3.5.1-1ubuntu3_all.deb Yahoo User Interface Library v3 (common files)
libjs-yui3-debug_3.5.1-1ubuntu3_all.deb Yahoo User Interface Library v3 (debug files)
libjs-yui3-doc_3.5.1-1ubuntu3_all.deb Documentation and examples for the Yahoo User Interface Library v3
libjs-yui3-full_3.5.1-1ubuntu3_all.deb Yahoo User Interface Library v3 (full, uncompressed files)
libjs-yui3-min_3.5.1-1ubuntu3_all.deb Yahoo User Interface Library v3 (minified files)
libjson-c-dev_0.11-4ubuntu2_amd64.deb JSON manipulation library - development files
libjson-c-doc_0.11-4ubuntu2_all.deb JSON manipulation library - documentation files
libjson-c2_0.11-4ubuntu2_amd64.deb JSON manipulation library - shared library
libjson-glib-1.0-0_1.1.2-0ubuntu1_amd64.deb GLib JSON manipulation library
libjson-glib-1.0-common_1.1.2-0ubuntu1_all.deb GLib JSON manipulation library (common files)
libjson-glib-dev_1.1.2-0ubuntu1_amd64.deb GLib JSON manipulation library (development files)
libjson-glib-doc_1.1.2-0ubuntu1_all.deb GLib JSON manipulation library (documentation)
libjson-perl_2.90-1_all.deb module for manipulating JSON-formatted data
libjson-xs-perl_3.010-2build1_amd64.deb module for manipulating JSON-formatted data (C/XS-accelerated)
Advertisement
Advertisement