libjs-jquery_1.11.3+dfsg-4_all.deb


Advertisement

Description

libjs-jquery - JavaScript library for dynamic web applications

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libjs-jquery_1.11.3+dfsg-4_all.deb
Package name libjs-jquery
Package version 1.11.3+dfsg
Package release 4
Package architecture all
Package type deb
Category web
Homepage http://jquery.com/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 157.28 KB
Installed size 589.00 KB
jQuery is a fast, concise, JavaScript Library that simplifies how you
traverse HTML documents, handle events, perform animations, and add Ajax
interactions to your web pages. jQuery is designed to change the way
that you write JavaScript.

Alternatives

Package Version Architecture Repository
libjs-jquery_1.11.3+dfsg-4_all.deb 1.11.3+dfsg all Ubuntu Main
libjs-jquery - - -

Conflicts

Name Value
jquery -

Replaces

Name Value
jquery -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libjs-jquery_1.11.3+dfsg-4_all.deb
Source Package jquery

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libjs-jquery deb package:
    # sudo apt-get install libjs-jquery

Files

Path
/usr/share/doc/libjs-jquery/README.Debian
/usr/share/doc/libjs-jquery/changelog.Debian.gz
/usr/share/doc/libjs-jquery/copyright
/usr/share/javascript/jquery/jquery.js
/usr/share/javascript/jquery/jquery.lite.js
/usr/share/javascript/jquery/jquery.min.js
/usr/share/javascript/jquery/jquery.min.map
/usr/share/javascript/jquery/jquery.pack.js

Changelog

2015-09-23 - Antonio Terceiro <terceiro@debian.org>
jquery (1.11.3+dfsg-4) unstable; urgency=medium
* debian/rules: remove `//# sourceMappingURL=..` magic comment from minified
file, as uptream does (Closes: #799825)
2015-08-28 - Antonio Terceiro <terceiro@debian.org>
jquery (1.11.3+dfsg-3) unstable; urgency=medium
* move logic from debian/build.mk to debian/rules
* debian/rules: use node-requirejs to build, as does upstream
* debian/build.js: turned into a node-requirejs build file
* debian/control: Build-Depends: node-requirejs
2015-08-25 - Antonio Terceiro <terceiro@debian.org>
jquery (1.11.3+dfsg-2) unstable; urgency=medium
* debian/build.mk: read date from changelog (Closes: #782899)
* Acknowledge previous NMUs (Closes: #748377, #759672)
- Thanks Paul Gevers
- The corresponding changes do not apply anymore since the build is now
completely different.
2015-08-21 - Antonio Terceiro <terceiro@debian.org>
jquery (1.11.3+dfsg-1) unstable; urgency=medium
* New upstream release (Closes: #730014)
* drop debian/patches: only patch in there does not apply anymore
* Added locally-hacked build system:
- debian/build.mk (called from debian/rules)
- debian/build.js (called from debian/build.mk)
- debian/build-1.11.3.txt (used as input by debian/build.mk)
.
This reproduces the build that you would get with grunt, modulo comment
lines and empty lines, which go away when the file is minified anyway.
* debian/install: also ship jquery.min.map
* debian/watch: point at github
* Add myself to Uploaders:
* debian/copyright: list dist/ in Files-Excluded:
* bump debhelper compatibility level to 9
2014-08-29 - Paul Gevers <elbrus@debian.org>
jquery (1.7.2+dfsg-3.2) unstable; urgency=medium
* Non-maintainer upload.
* Fix in previous upload was technically not correct. Re-add the phony build
target again and actually fix the make problem (mixed implicit and normal
rules) by unmixing.
2014-08-27 - Paul Gevers <elbrus@debian.org>
jquery (1.7.2+dfsg-3.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix FTBFS by removing build target as it used deprecated syntax
(Closes: #709901)
2013-08-01 - Marcelo Jorge Vieira (metal) <metal@debian.org>
jquery (1.7.2+dfsg-3) unstable; urgency=low
* Generating jquery minified from source again (Closes: #495178)
* Added lintian override:
jquery source: license-problem-json-evil debian/README.Debian
* Updated Standards-Version to 3.9.4 (no changes)
2013-05-11 - Marcelo Jorge Vieira (metal) <metal@debian.org>
jquery (1.7.2+dfsg-2) unstable; urgency=high
* Added Breaks to movabletype-opensource (Closes: #700527)
Thanks Dominic Hargreaves and gregor herrmann
2012-11-15 - Marcelo Jorge Vieira (metal) <metal@debian.org>
jquery (1.7.2+dfsg-1) unstable; urgency=high
* Removed non-free files in upstream tarball (Closes: #692618)
2012-08-04 - Julien Cristau <jcristau@debian.org>
jquery (1.7.2+debian-2.1) unstable; urgency=high
* Non-maintainer upload.
* Don't ship minified js, uglify is not in wheezy (closes: #679665).
* Make build a phony target explicitly, since there's a build directory in
the source package.

See Also

Package Description
libjs-modernizr_2.6.2+ds1-1ubuntu1_all.deb JavaScript library to detect HTML5 and CSS3 features in the user's browser
libjs-sphinxdoc_1.3.6-2ubuntu1_all.deb JavaScript support for Sphinx documentation
libjs-underscore_1.7.0~dfsg-1ubuntu1_all.deb JavaScript's functional programming helper library
libjs-yui3-common_3.5.1-1ubuntu3_all.deb Yahoo User Interface Library v3 (common files)
libjs-yui3-debug_3.5.1-1ubuntu3_all.deb Yahoo User Interface Library v3 (debug files)
libjs-yui3-doc_3.5.1-1ubuntu3_all.deb Documentation and examples for the Yahoo User Interface Library v3
libjs-yui3-full_3.5.1-1ubuntu3_all.deb Yahoo User Interface Library v3 (full, uncompressed files)
libjs-yui3-min_3.5.1-1ubuntu3_all.deb Yahoo User Interface Library v3 (minified files)
libjson-c-dev_0.11-4ubuntu2_amd64.deb JSON manipulation library - development files
libjson-c-doc_0.11-4ubuntu2_all.deb JSON manipulation library - documentation files
libjson-c2_0.11-4ubuntu2_amd64.deb JSON manipulation library - shared library
libjson-glib-1.0-0_1.1.2-0ubuntu1_amd64.deb GLib JSON manipulation library
libjson-glib-1.0-common_1.1.2-0ubuntu1_all.deb GLib JSON manipulation library (common files)
libjson-glib-dev_1.1.2-0ubuntu1_amd64.deb GLib JSON manipulation library (development files)
libjson-glib-doc_1.1.2-0ubuntu1_all.deb GLib JSON manipulation library (documentation)
Advertisement
Advertisement