libipc-system-simple-perl_1.25-3_all.deb


Advertisement

Description

libipc-system-simple-perl - Perl module to run commands simply, with detailed diagnostics

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libipc-system-simple-perl_1.25-3_all.deb
Package name libipc-system-simple-perl
Package version 1.25
Package release 3
Package architecture all
Package type deb
Category perl
Homepage https://metacpan.org/release/IPC-System-Simple
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 22.27 KB
Installed size 59.00 KB
IPC::System::Simple takes the hard work out of calling external commands; it
provides replacements for system() and the backtick operator that will either
succeed, or die with rich diagnostic messages on errors.
The module also includes the ability to specify acceptable exit values, trap
errors, or process diagnostics.

Alternatives

Package Version Architecture Repository
libipc-system-simple-perl_1.25-3_all.deb 1.25 all Ubuntu Main
libipc-system-simple-perl - - -

Requires

Name Value
perl -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libipc-system-simple-perl_1.25-3_all.deb
Source Package libipc-system-simple-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libipc-system-simple-perl deb package:
    # sudo apt-get install libipc-system-simple-perl

Files

Path
/usr/share/doc/libipc-system-simple-perl/changelog.Debian.gz
/usr/share/doc/libipc-system-simple-perl/copyright
/usr/share/doc/libipc-system-simple-perl/examples/rsync-backup.pl
/usr/share/man/man3/IPC::System::Simple.3pm.gz
/usr/share/perl5/IPC/System/Simple.pm

Changelog

2015-12-06 - Niko Tyni <ntyni@debian.org>
libipc-system-simple-perl (1.25-3) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ Niko Tyni ]
* Set LC_ALL=C when building to fix an author test failure in some locales.
(Closes: #807160)
* Declare the package autopkgtestable.
2013-10-20 - Damyan Ivanov <dmn@debian.org>
libipc-system-simple-perl (1.25-2) unstable; urgency=low
* Team upload
* put back libbsd-resource-perl in build-dependencies
It was dropped upstream because it is optional in tests, but since we have
it, we might as well use it and get more test coverage
2013-10-20 - Damyan Ivanov <dmn@debian.org>
libipc-system-simple-perl (1.25-1) unstable; urgency=low
* Team upload
* Imported Upstream version 1.25
+ Omits extra Debian_CPANTS.txt from distribution
+ no source changes
2013-10-19 - Damyan Ivanov <dmn@debian.org>
libipc-system-simple-perl (1.24-1) unstable; urgency=low
* Team upload
[ Fabrizio Regalli ]
* Bump to 3.9.2 Standard-Version.
* Add myself to Uploaders and Copyright.
* Switch d/compat to 8.
* Build-Depends: switch to debhelper (>= 8).
* Update link for license GPL-1 on d/copyright.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ Damyan Ivanov ]
* Imported Upstream version 1.24
* drop mention of inc/Module/Install* from debian/copyright.
thankfully dropped upstream
* add 2013 to the upstream copyright years
* remove libbsd-resource-perl from build-depends, following upstream
* claim conformance with Policy 3.9.4
2010-03-24 - gregor herrmann <gregoa@debian.org>
libipc-system-simple-perl (1.21-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
[ gregor herrmann ]
* debian/control: improve long description, thanks to Rhonda for the bug
report (closes: #516918).
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
[ gregor herrmann ]
* New upstream release.
* Minimize debian/rules.
* Set Standards-Version to 3.8.4 (no changes).
* Convert to source format 3.0 (quilt).
* Update debian/copyright.
2009-02-13 - gregor herrmann <gregoa@debian.org>
libipc-system-simple-perl (1.18-1) unstable; urgency=low
* New upstream release.
2008-12-19 - gregor herrmann <gregoa@debian.org>
libipc-system-simple-perl (1.17-1) unstable; urgency=low
* New upstream release, contains a workaround for an oddity in Perl 5.10
that can be seen in a test (cf. #509041).
* Add libbsd-resource-perl to Build-Depends-Indep to enable this test.
* Add libtest-nowarnings-perl to Build-Depends-Indep to enable a new test.
* Add /me to Uploaders.
2008-12-12 - Jeremiah C. Foster <jeremiah@jeremiahfoster.com>
libipc-system-simple-perl (0.16-1) unstable; urgency=low
* Initial Release. (Closes: #508507)

See Also

Package Description
libipmiconsole-dev_1.4.11-1ubuntu1_amd64.deb GNU IPMI - ipmiconsole development package
libipmiconsole2_1.4.11-1ubuntu1_amd64.deb GNU IPMI - Serial-over-Lan library
libipmidetect-dev_1.4.11-1ubuntu1_amd64.deb GNU IPMI - ipmidetect development package
libipmidetect0_1.4.11-1ubuntu1_amd64.deb GNU IPMI - IPMI node detection library
libipmimonitoring-dev_1.4.11-1ubuntu1_amd64.deb GNU IPMI - ipmimonitoring development package
libipmimonitoring5a_1.4.11-1ubuntu1_amd64.deb GNU IPMI - Sensor monitoring library
libipset-dev_6.29-1_amd64.deb development files for IP sets
libipset3_6.29-1_amd64.deb library for IP sets
libirs-export141_9.10.3.dfsg.P4-8_amd64.deb Exported IRS Shared Library
libirs141_9.10.3.dfsg.P4-8_amd64.deb DNS Shared Library used by BIND
libisc-export160_9.10.3.dfsg.P4-8_amd64.deb Exported ISC Shared Library
libisc160_9.10.3.dfsg.P4-8_amd64.deb ISC Shared Library used by BIND
libisccc-export140_9.10.3.dfsg.P4-8_amd64.deb Command Channel Library used by BIND
libisccc140_9.10.3.dfsg.P4-8_amd64.deb Command Channel Library used by BIND
libisccfg-export140_9.10.3.dfsg.P4-8_amd64.deb Exported ISC CFG Shared Library
Advertisement
Advertisement