libidl-2-0_0.8.14-4_amd64.deb


Advertisement

Description

libidl-2-0 - library for parsing CORBA IDL files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libidl-2-0_0.8.14-4_amd64.deb
Package name libidl-2-0
Package version 0.8.14
Package release 4
Package architecture amd64
Package type deb
Category libs
Homepage http://ftp.acc.umu.se/pub/gnome/sources/libIDL/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 67.28 KB
Installed size 204.00 KB
libIDL is a small library for creating parse trees of CORBA v2.2 compliant
Interface Definition Language (IDL) files, which is a specification for
defining interfaces which can be used between different CORBA
implementations.  libIDL is used in the ORBit2 IDL compiler, as well
as various language bindings (Perl, Python, etc.) for ORBit2.

Alternatives

Package Version Architecture Repository
libidl-2-0_0.8.14-4_i386.deb 0.8.14 i386 Ubuntu Main
libidl-2-0 - - -

Requires

Name Value
cpp:any -
libc6 >= 2.14
libglib2.0-0 >= 2.16.0

Replaces

Name Value
libidl0 << 0.8.14-3

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libidl-2-0_0.8.14-4_amd64.deb
Source Package libidl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libidl-2-0 deb package:
    # sudo apt-get install libidl-2-0

Files

Path
/usr/lib/x86_64-linux-gnu/libIDL-2.so.0
/usr/lib/x86_64-linux-gnu/libIDL-2.so.0.0.0
/usr/share/doc/libidl-2-0/AUTHORS
/usr/share/doc/libidl-2-0/BUGS
/usr/share/doc/libidl-2-0/NEWS.gz
/usr/share/doc/libidl-2-0/README
/usr/share/doc/libidl-2-0/changelog.Debian.gz
/usr/share/doc/libidl-2-0/copyright

Changelog

2015-11-26 - Matthias Klose <doko@debian.org>
libidl (0.8.14-4) unstable; urgency=medium
* QA upload.
* Add missing Breaks/Replaces: Closes: #806204, #806253.
2015-11-24 - Paulo Roberto Alves de Oliveira (aka kretcheu) <kretcheu@gmail.com>
libidl (0.8.14-3) unstable; urgency=medium
* QA upload.
* Upload to unstable.
2015-11-22 - Paulo Roberto Alves de Oliveira (aka kretcheu) <kretcheu@gmail.com>
libidl (0.8.14-2) experimental; urgency=medium
* QA upload.
* Migrations:
- DH level to 9.
- debian/copyright to 1.0 format.
- DebSrc to version 3.0.
- Dropped the CDBS system.
* debian/control:
- Included Homepage: field.
- Improved long description of package libidl-dev.
- Removed extra Section: field of package libidl-2-0.
- Removed {$shlibs:Depends} from Depends field of package libidl-dev.
- Renamed package libidl0 to libidl-2-0 because SONAME is libIDL-2-0.
- Reorganized Build:Depends field.and Depends field.
* debian/copyright: Revised and updated all information.
* debian/libidl-2-0.install:
- Included file usr/share/info/libIDL2.info.
* debian/libidl-2-0.symbols:
- Regenerated the main symbols file.
* debian/patches:
- Added patch 01-fix-configure.in to include AC_CONFIG_MACRO_DIR.
- Added patch 02-fix-Makefile.am to include ACLOCAL_AMFLAGS
and change name of INCLUDES to ACLOCAL_AMFLAGS.
* debian/rules:
- Included DEB_BUILD_MAINT_OPTIONS for hardening.
- Using autoreconf now.
* debian/watch: upgraded from version 2 to 3 and improved.
2015-02-21 - Emanuele Rocca <ema@debian.org>
libidl (0.8.14-1) unstable; urgency=low
* QA upload.
* Maintainer field set to QA Group.
* Bump Standards-Version to 3.9.6.
2014-08-02 - Manuel A. Fernandez Montecelo <mafm@debian.org>
libidl (0.8.14-0.4) unstable; urgency=medium
* Non-maintainer upload.
* Run dh-autoreconf to update config.{sub,guess} and
{libtool,aclocal}.m4, necessary for some new ports.  Thanks
Brahadambal Srinivasan.  (Closes: #756314)
2013-11-07 - Josselin Mouette <joss@debian.org>
libidl (0.8.14-0.3) unstable; urgency=low
* Non-maintainer upload.
* Replace libidl-config by a wrapper for pkg-config.
* Add corresponding dependency on pkg-config.
* Drop .la files.
* Switch to multiarch. Closes: #641614.
+ Set libdir accordingly.
+ Update installation paths.
+ Make both packages MA: same.
+ Depend on cpp:any.
2011-05-29 - Luk Claes <luk@debian.org>
libidl (0.8.14-0.2) unstable; urgency=low
* Non-maintainer upload.
* Remove references to other libraries from dependency_libs field
Closes: #619202
2010-04-08 - Sebastian Dröge <slomo@debian.org>
libidl (0.8.14-0.1) unstable; urgency=low
* Non-maintainer upload.
* New upstream bugfix release, no API changes.
2009-10-04 - Sebastian Rittau <srittau@debian.org>
libidl (0.8.13-1) unstable; urgency=low
* Acknowledge NMUs. Thanks!
+ Closes: #395037 "Diffs for 0.8.7-0.1, 0.8.8-0.1 and 0.8.9-0.1 NMUs"
+ Closes: #471300 "diff for NMU 0.8.10-0.1"
* Update Standards-Version to 3.8.3, no additional changes needed.
* Bump debhelper compatibility level to 7.
* Capitalize "Perl" and "Python" in libidl0 package description.
2009-03-22 - Sebastian Dröge <slomo@debian.org>
libidl (0.8.13-0.1) unstable; urgency=low
* Non-maintainer upload.
* New upstream bugfix release; no API change.

See Also

Package Description
libidl-dev_0.8.14-4_amd64.deb development files for programs that use libIDL
libidn11-dev_1.32-3ubuntu1_amd64.deb Development files for GNU Libidn, an IDN library
libidn11_1.32-3ubuntu1_amd64.deb GNU Libidn library, implementation of IETF IDN specifications
libido3-0.1-0_13.10.0+15.10.20151002-0ubuntu1_amd64.deb Shared library providing extra gtk menu items for display in
libido3-0.1-dev_13.10.0+15.10.20151002-0ubuntu1_amd64.deb Shared library providing extra gtk menu items for display in
libiec61883-0_1.2.0-0.2_amd64.deb an partial implementation of IEC 61883
libiec61883-dev_1.2.0-0.2_amd64.deb an partial implementation of IEC 61883
libieee1284-3-dev_0.2.11-12_amd64.deb cross-platform library for parallel port access [development files]
libieee1284-3_0.2.11-12_amd64.deb cross-platform library for parallel port access
libijs-0.35_0.35-12_amd64.deb IJS raster image transport protocol: shared library
libijs-dev_0.35-12_amd64.deb IJS raster image transport protocol: development files
libijs-doc_0.35-12_all.deb IJS raster image transport protocol: documentation
libilmbase-dev_2.2.0-11ubuntu2_amd64.deb development files for IlmBase
libilmbase12_2.2.0-11ubuntu2_amd64.deb several utility libraries from ILM used by OpenEXR
libimage-magick-perl_6.8.9.9-7ubuntu5_all.deb Perl interface to the ImageMagick graphics routines
Advertisement
Advertisement