libhpmud-dev_3.16.3+repack0-1_amd64.deb


Advertisement

Description

libhpmud-dev - HP Multi-Point Transport Driver (hpmud) development libraries

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libhpmud-dev_3.16.3+repack0-1_amd64.deb
Package name libhpmud-dev
Package version 3.16.3+repack0
Package release 1
Package architecture amd64
Package type deb
Category libdevel
Homepage http://hplipopensource.com/hplip-web/index.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 7.21 KB
Installed size 112.00 KB
The HP Linux Printing and Imaging System provides full support for
printing on most HP SFP (single function peripheral) inkjets and many
LaserJets, and for scanning, sending faxes and for photo-card access on
most HP MFP (multi-function peripheral) printers.
Shared library that provides direct I/O for each process. Prior to
hpmud, all I/O was serialized through hpiod, a monolithic I/O processor.
The new hpmud direct I/O is faster. Hpmud supports parallel, USB and
JetDirect connectivity.
With hpmud, HPLIP no longer has Linux specific libusb extensions. This
means any UNIX/Linux derivative that supports libusb may work with
HPLIP. A public HPLIP "C" API is exposed through hpmud. See hpmud.h
for documentation. A Python wrapper for hpmud, called hpmudext, is also
available.
This package contains the development headers necessary if you wish
to build packages depending on libhpmud.

Alternatives

Package Version Architecture Repository
libhpmud-dev_3.16.3+repack0-1_i386.deb 3.16.3+repack0 i386 Ubuntu Main
libhpmud-dev - - -

Requires

Name Value
libhpmud0 = 3.16.3+repack0-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libhpmud-dev_3.16.3+repack0-1_amd64.deb
Source Package hplip

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libhpmud-dev deb package:
    # sudo apt-get install libhpmud-dev

Files

Path
/usr/include/hpmud.h
/usr/lib/x86_64-linux-gnu/libhpdiscovery.so
/usr/lib/x86_64-linux-gnu/libhpip.so
/usr/lib/x86_64-linux-gnu/libhpipp.so
/usr/lib/x86_64-linux-gnu/libhpmud.so
/usr/share/doc/libhpmud-dev/changelog.Debian.gz
/usr/share/doc/libhpmud-dev/copyright

Changelog

2016-03-19 - Julian Andres Klode <jak@debian.org>
hplip (3.16.3+repack0-1) unstable; urgency=medium
* Imported Upstream version 3.16.3
2016-03-12 - Julian Andres Klode <jak@debian.org>
hplip (3.16.2+repack0-7) unstable; urgency=medium
* Apply HP-LaserJet_4000-PostScript-PPD.patch like other patches
* Do not run install actions twice in indep+arch builds (Closes: #817883)
2016-03-11 - Julian Andres Klode <jak@debian.org>
hplip (3.16.2+repack0-6) unstable; urgency=medium
* Handle building of only Architecture: any packages
* Use --dbgsym-migration instead of --ddeb-migration
2016-03-10 - Julian Andres Klode <jak@debian.org>
hplip (3.16.2+repack0-5) unstable; urgency=medium
* Add myself as an uploader
* Port the packaging to dh(1) and clean it up internally:
- Drop unused patches
- debian/rules: Drop /usr/share/gnome-pkg-tools/1/rules/sf-get-source.mk
- Delete unused debian/tmpno directory
- Do not set DH_ALWAYS_EXCLUDE for CVS and drop DH_VERBOSE comment
- Drop invalid use of X-Python-Version
- debian/rules: Port to dh(1)
- clean: Restore uncompressed files
- Use the standard source:Version substvar and its friends
- Remove support for installing Linda files
- Do not install lintian overrides manually, use dh_lintian
- Install ppd-updater files directly using dh_install
- Do not pass sourcedir to dh_install
- Install FAX ppds using install files
- Simply use dh_install --list-missing
- Let upstream install html into /usr/share/doc/hplip-doc/
- debian/rules: Stop patching hplip.conf
- Do not pass variables to build/install, not needed anymore
- Delete README.source, outdated
- Rename README.Source to README.source and drop outdated stuff
- Use upstream symlinks; drops hp-hpdio (not a script)
- Clean up lintian overrides
- hplip-data: Override two lintian tags
- Bump Standards-Version to 3.9.7
* Dropped stuff:
- Do not install .la files
- Do not install hpssd into bin, it's not executable
- Drop hp-unload for now, it does not support Python 3
* Install missing manual pages that are available
* Menu entry cleanup
- Drop hplip-gui.menu, having both .desktop and .menu is forbidden now
- Get rid of HPmenu.xpm and hp-logo.xpm, use upstream logo
* Build flag changes:
- Build with as-needed
- Use full hardening
2016-02-25 - Didier Raboud <odyx@debian.org>
hplip (3.16.2+repack0-4) unstable; urgency=medium
* Add patch to order page sizes consistently in hp-scan, to ensure manpage
generation reproducibility
2016-02-23 - Didier Raboud <odyx@debian.org>
hplip (3.16.2+repack0-3) unstable; urgency=medium
* Fix LD_LIBRARY_PATH to include DEB_HOST_MULTIARCH when generating python
tools' manpages; fixes the FTBFS of -2
2016-02-15 - Didier Raboud <odyx@debian.org>
hplip (3.16.2+repack0-2) unstable; urgency=medium
* Multi-arch'ify libsane-hpaio and libhpmud0 (Closes: #813043, #804379)
2016-02-13 - Didier Raboud <odyx@debian.org>
hplip (3.16.2+repack0-1) unstable; urgency=medium
* New 3.16.2 upstream release
- Repack the 3.16.2 upstream release
Uncompress various source files, for better upstream tracking in the VCS
* debian/rules - get-orig-source:
- force upstream/latest-repack merge to use 'theirs' merge strategy and
make it not fail the target
- drop 'modeswitch' copy-paste leftover
* Fix typo in previous changelog entry

See Also

Package Description
libhpmud0_3.16.3+repack0-1_amd64.deb HP Multi-Point Transport Driver (hpmud) run-time libraries
libhsqldb1.8.0-java_1.8.0.10+dfsg-6_all.deb Java SQL database engine
libhtml-form-perl_6.03-1_all.deb module that represents an HTML form element
libhtml-format-perl_2.11-2_all.deb module for transforming HTML into various formats
libhtml-parser-perl_3.72-1_amd64.deb collection of modules that parse HTML text documents
libhtml-tagset-perl_3.20-2_all.deb Data tables pertaining to HTML
libhtml-template-perl_2.95-2_all.deb module for using HTML templates with Perl
libhtml-tree-perl_5.03-2_all.deb Perl module to represent and create HTML syntax trees
libhttp-cookies-perl_6.01-1_all.deb HTTP cookie jars
libhttp-daemon-perl_6.01-1_all.deb simple http server class
libhttp-date-perl_6.02-1_all.deb module of date conversion routines
libhttp-message-perl_6.11-1_all.deb perl interface to HTTP style messages
libhttp-negotiate-perl_6.00-2_all.deb implementation of content negotiation
libhud-client2-dev_14.10+16.04.20160415-0ubuntu1_amd64.deb private library for implementing a HUD frontend
libhud-client2-doc_14.10+16.04.20160415-0ubuntu1_all.deb private library for implementing a HUD frontend
Advertisement
Advertisement