libgutenprintui2-dev_5.2.11-1_amd64.deb


Advertisement

Description

libgutenprintui2-dev - development files for the Gutenprint printer driver user interface library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libgutenprintui2-dev_5.2.11-1_amd64.deb
Package name libgutenprintui2-dev
Package version 5.2.11
Package release 1
Package architecture amd64
Package type deb
Category devel
Homepage http://gimp-print.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 5.35 KB
Installed size 32.00 KB
This package contains the header files for the libgutenprintui
library, along with a static version of libgutenprintui.
libgutenprintui contains GTK+ widgets which may be used for print
dialogs etc. for use with libgutenprint.
Install this package if you wish to develop packages that use
libgutenprintui.
Gutenprint is the print facility for the GIMP, and in addition a
suite of drivers that may be used with common UNIX spooling systems
using GhostScript or CUPS.  These drivers provide printing quality
for UNIX/Linux on a par with proprietary vendor-supplied drivers in
many cases, and can be used for many of the most demanding printing
tasks.  Gutenprint was formerly known as Gimp-Print.

Alternatives

Package Version Architecture Repository
libgutenprintui2-dev_5.2.11-1_i386.deb 5.2.11 i386 Ubuntu Main
libgutenprintui2-dev - - -

Requires

Name Value
dpkg >= 1.17.5
libgutenprintui2-1 = 5.2.11-1
pkg-config -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgutenprintui2-dev_5.2.11-1_amd64.deb
Source Package gutenprint

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgutenprintui2-dev deb package:
    # sudo apt-get install libgutenprintui2-dev

Files

Path
/usr/include/gutenprintui2/curve.h
/usr/include/gutenprintui2/gammacurve.h
/usr/include/gutenprintui2/gutenprintui.h
/usr/include/gutenprintui2/typebuiltins.h
/usr/lib/x86_64-linux-gnu/libgutenprintui2.so
/usr/lib/x86_64-linux-gnu/pkgconfig/gutenprintui2.pc
/usr/share/doc/libgutenprintui2-dev

Changelog

2016-02-16 - Didier Raboud <odyx@debian.org>
gutenprint (5.2.11-1) unstable; urgency=medium
* New 5.2.11 upstream release
* Update uversionmangle in debian/watch to take -pre* account numbers
* Bump Standards-Version to 3.9.7 without changes needed
2015-10-27 - Didier Raboud <odyx@debian.org>
gutenprint (5.2.11~pre2-1) experimental; urgency=medium
* New 5.2.11~pre2 upstream release
* Bump Standards-Version to 3.9.6 without changes needed
* Drop cups-driver-gutenprint transitional package, that was transitional in
oldstable
* Fix 'find' call to use the new '-perm /xxx' syntax (Closes: #803025)
2015-08-09 - Didier Raboud <odyx@debian.org>
gutenprint (5.2.11~pre1-1) experimental; urgency=low
* New 5.2.11~pre1 upstream release
* In autopkgtest, only test the first printer listed in Gutenprint's
Supported printers page (Closes: #785648)
* Add gbp.conf to cope with the new branch names
2014-06-23 - Didier Raboud <odyx@debian.org>
gutenprint (5.2.10-3) unstable; urgency=medium
* Add autopkgtest suite that tests all drivers using cups-client's
test-drivers utility
* On upgrade, remove driver update timestamp in cups' trigger cache to
ensure all earlier printers are refreshed (Closes: #749600)
2014-06-01 - Didier Raboud <odyx@debian.org>
gutenprint (5.2.10-2) unstable; urgency=medium
* Add Pre-Depends against dpkg-dev for dir_to_symlink support
(Closes: #749931)
2014-05-28 - Didier Raboud <odyx@debian.org>
gutenprint (5.2.10-1) unstable; urgency=medium
* New 5.2.10 final upstream release
* Fix drivers listing by re-introduction --libdir as well as the specific
dh_makeshlibs and dh_shlibdeps calls, unfortunately dropped in the
packaging cleanup
* Fix ppd-updater trigger installation
* Drop the upstream patch to fix the usb backend crash; was from upstream
* Rework the /doc/ directories symlinks
2014-05-22 - Didier Raboud <odyx@debian.org>
gutenprint (5.2.10~pre2-2) unstable; urgency=medium
* Fix printer-driver-gutenprint installation of common files on Linux
(Closes: #748761)
* Adopt package from Roger, replace him as Uploader, with many thanks for his
past work! (Closes: #479397)

See Also

Package Description
libgvc6_2.38.0-12ubuntu2_amd64.deb rich set of graph drawing tools - gvc library
libgvpr2_2.38.0-12ubuntu2_amd64.deb rich set of graph drawing tools - gvpr library
libgweather-3-6_3.18.1-1ubuntu1_amd64.deb GWeather shared library
libgweather-3-dev_3.18.1-1ubuntu1_amd64.deb GWeather development files
libgweather-common_3.18.1-1ubuntu1_all.deb GWeather common files
libgxps-dev_0.2.3.2-1_amd64.deb handling and rendering XPS documents (development files)
libgxps-doc_0.2.3.2-1_all.deb library for handling and rendering XPS documents (documentation)
libgxps2_0.2.3.2-1_amd64.deb handling and rendering XPS documents (library)
libhangul-data_0.1.0-3_all.deb Hangul keyboard input library - data
libhangul-dev_0.1.0-3_amd64.deb Hangul keyboard input library - development files
libhangul1_0.1.0-3_amd64.deb Hangul keyboard input library - runtime
libhardware-dev_0.1.0+git20151016+6d424c9-0ubuntu7_amd64.deb Development files for libhardware
libhardware2_0.1.0+git20151016+6d424c9-0ubuntu7_amd64.deb Library to provide access to the Android libhardware HAL
libharfbuzz-dev_1.0.1-1build2_amd64.deb Development files for OpenType text shaping engine
libharfbuzz-doc_1.0.1-1build2_all.deb Documentation files for the HarfBuzz library
Advertisement
Advertisement