libgusb2_0.2.9-0ubuntu1_amd64.deb


Advertisement

Description

libgusb2 - GLib wrapper around libusb1

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libgusb2_0.2.9-0ubuntu1_amd64.deb
Package name libgusb2
Package version 0.2.9
Package release 0ubuntu1
Package architecture amd64
Package type deb
Category libs
Homepage http://www.hughski.com/downloads.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 19.70 KB
Installed size 79.00 KB
GUsb is a GObject wrapper for libusb1 that makes it easy to do
asynchronous control, bulk and interrupt transfers with proper
cancellation and integration into a mainloop.
This package contains the GUsb shared library.

Alternatives

Package Version Architecture Repository
libgusb2_0.2.9-0ubuntu1_i386.deb 0.2.9 i386 Ubuntu Main
libgusb2 - - -

Requires

Name Value
libc6 >= 2.14
libglib2.0-0 >= 2.38.0
libusb-1.0-0 >= 2:1.0.16

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgusb2_0.2.9-0ubuntu1_amd64.deb
Source Package libgusb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgusb2 deb package:
    # sudo apt-get install libgusb2

Files

Path
/usr/lib/x86_64-linux-gnu/libgusb.so.2
/usr/lib/x86_64-linux-gnu/libgusb.so.2.0.10
/usr/share/doc/libgusb2/changelog.Debian.gz
/usr/share/doc/libgusb2/copyright

Changelog

2016-03-21 - Mario Limonciello <mario_limonciello@dell.com>
libgusb (0.2.9-0ubuntu1) xenial; urgency=medium
* New upstream release (0.2.9)
* debian/rules:
- Don't install gusbcmd. It was added as a debugging aide,
however we won't package it for now.
* Update symbols file.
2015-12-02 - Michal Čihař <nijel@debian.org>
libgusb (0.2.8-1) unstable; urgency=medium
* New upstream release.
* Update symbols file.
2015-09-17 - Michal Čihař <nijel@debian.org>
libgusb (0.2.7-1) unstable; urgency=medium
* New upstream release.
2015-07-23 - Michal Čihař <nijel@debian.org>
libgusb (0.2.6-1) unstable; urgency=medium
* New upstream release.
2015-06-08 - Michal Čihař <nijel@debian.org>
libgusb (0.2.5-1) unstable; urgency=medium
* New upstream release.
* Update symbols file as the library started to support versioned symbols.
2015-03-16 - Michal Čihař <nijel@debian.org>
libgusb (0.2.4-1) unstable; urgency=medium
* New upstream release.
* Raised glib dependency to 2.38.
* New exported symbols.
2014-11-27 - Michal Čihař <nijel@debian.org>
libgusb (0.2.2-1) unstable; urgency=medium
* New upstream release.
- Dropped gudev dependency, raised glib and libusb ones.
- Updated symbols table.
* Bump standards to 3.9.6.
2014-01-27 - Michal Čihař <nijel@debian.org>
libgusb (0.1.6-5) unstable; urgency=medium
* Miscellaneous fixes from Ubuntu (Closes: #736827):
* Build-depend on valac (>= 0.20), not valac-0.20.
* Install typelib to /usr/lib as expected, not to the multiarch dir.
* Keep libgusb2.symbols at version 0.1.5 for compatibility with
existing Ubuntu builds.
* Call dh --with gir.
2014-01-20 - Michal Čihař <nijel@debian.org>
libgusb (0.1.6-4) unstable; urgency=medium
* Use dh-autoreconf for newer libtool.
2014-01-20 - Michal Čihař <nijel@debian.org>
libgusb (0.1.6-3) unstable; urgency=medium
* Bump standards to 3.9.5.
* Use debhelper 9.
* Use canonical VCS URLs in debian/control.
* Enable multiarch support.

See Also

Package Description
libgutenprint-dev_5.2.11-1_amd64.deb development files for the Gutenprint printer driver library
libgutenprint-doc_5.2.11-1_all.deb documentation for the Gutenprint printer driver library
libgutenprint2_5.2.11-1_amd64.deb runtime for the Gutenprint printer driver library
libgutenprintui2-1_5.2.11-1_amd64.deb runtime for the Gutenprint printer driver user interface library
libgutenprintui2-dev_5.2.11-1_amd64.deb development files for the Gutenprint printer driver user interface library
libgvc6_2.38.0-12ubuntu2_amd64.deb rich set of graph drawing tools - gvc library
libgvpr2_2.38.0-12ubuntu2_amd64.deb rich set of graph drawing tools - gvpr library
libgweather-3-6_3.18.1-1ubuntu1_amd64.deb GWeather shared library
libgweather-3-dev_3.18.1-1ubuntu1_amd64.deb GWeather development files
libgweather-common_3.18.1-1ubuntu1_all.deb GWeather common files
libgxps-dev_0.2.3.2-1_amd64.deb handling and rendering XPS documents (development files)
libgxps-doc_0.2.3.2-1_all.deb library for handling and rendering XPS documents (documentation)
libgxps2_0.2.3.2-1_amd64.deb handling and rendering XPS documents (library)
libhangul-data_0.1.0-3_all.deb Hangul keyboard input library - data
libhangul-dev_0.1.0-3_amd64.deb Hangul keyboard input library - development files
Advertisement
Advertisement