libgtkmm-3.0-1v5_3.18.0-1_amd64.deb


Advertisement

Description

libgtkmm-3.0-1v5 - C++ wrappers for GTK+ (shared libraries)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libgtkmm-3.0-1v5_3.18.0-1_amd64.deb
Package name libgtkmm-3.0-1v5
Package version 3.18.0
Package release 1
Package architecture amd64
Package type deb
Category libs
Homepage http://www.gtkmm.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 796.39 KB
Installed size 5.71 MB
Gtkmm is a C++ interface for the popular GUI library GTK+, API version 3.0.
Gtkmm provides a convenient interface for C++ programmers to create
graphical user interfaces with GTK+'s flexible OO framework. Highlights
include type safe callbacks, widgets extensible using inheritance and
over 180 classes that can be freely combined to quickly create complex
user interfaces.
This package contains shared libraries.

Alternatives

Package Version Architecture Repository
libgtkmm-3.0-1v5_3.18.0-1_i386.deb 3.18.0 i386 Ubuntu Main
libgtkmm-3.0-1v5 - - -

Requires

Name Value
libatkmm-1.6-1v5 >= 2.24.0
libc6 >= 2.14
libcairomm-1.0-1v5 >= 1.12.0
libgcc1 >= 1:4.1.1
libgdk-pixbuf2.0-0 >= 2.25.2
libglib2.0-0 >= 2.41.1
libglibmm-2.4-1v5 >= 2.46.0
libgtk-3-0 >= 3.18.0
libpangomm-1.4-1v5 >= 2.38.0
libsigc++-2.0-0v5 >= 2.2.0
libstdc++6 >= 5.2

Conflicts

Name Value
libgtkmm-3.0-1 -

Replaces

Name Value
libgtkmm-3.0-1 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgtkmm-3.0-1v5_3.18.0-1_amd64.deb
Source Package gtkmm3.0

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgtkmm-3.0-1v5 deb package:
    # sudo apt-get install libgtkmm-3.0-1v5

Files

Path
/usr/lib/x86_64-linux-gnu/libgdkmm-3.0.so.1
/usr/lib/x86_64-linux-gnu/libgdkmm-3.0.so.1.1.0
/usr/lib/x86_64-linux-gnu/libgtkmm-3.0.so.1
/usr/lib/x86_64-linux-gnu/libgtkmm-3.0.so.1.1.0
/usr/share/doc/libgtkmm-3.0-1v5/AUTHORS
/usr/share/doc/libgtkmm-3.0-1v5/NEWS.gz
/usr/share/doc/libgtkmm-3.0-1v5/README
/usr/share/doc/libgtkmm-3.0-1v5/changelog.Debian.gz
/usr/share/doc/libgtkmm-3.0-1v5/copyright

Changelog

2015-10-08 - Michael Biebl <biebl@debian.org>
gtkmm3.0 (3.18.0-1) unstable; urgency=medium
* New upstream release.
* Update dependencies as per configure.ac:
- Bump libgtk-3-dev to (>= 3.18.0).
- Bump libglibmm-2.4-dev to (>= 2.46.1).
- Bump libcairomm-1.0-dev to (>= 1.12.0).
- Bump libpangomm-1.4-dev to (>= 2.38.1).
- Bump libatkmm-1.6-dev to (>= 2.24.1).
- Bump mm-common to (>= 0.9.8).
* Bump SHVER to 3.18.0.
2015-08-17 - Simon McVittie <smcv@debian.org>
gtkmm3.0 (3.16.0-2) unstable; urgency=medium
* Team upload.
* Rename library for g++-5 transition, from libgtkmm-3.0-1
to libgtkmm-3.0-1v5.
Based on patches from Sebastien Bacher.
- Conflicts/Replaces the old library
- Bump build-dependencies to g++-5-transitioned versions
2015-06-14 - Michael Biebl <biebl@debian.org>
gtkmm3.0 (3.16.0-1) unstable; urgency=medium
* New upstream release.
* Update dependencies as per configure.ac:
- Bump libglibmm-2.4-dev to (>= 2.44.0).
- Bump libgtk-3-dev to (>= 3.16.0).
- Bump mm-common to (>= 0.9.7).
* Bump Standards-Version to 3.9.6.
* Bump SHVER to 3.16.0 due to API additions.
2014-09-24 - Michael Biebl <biebl@debian.org>
gtkmm3.0 (3.14.0-1) unstable; urgency=medium
* New upstream release.
* Update dependencies as per configure.ac:
- Bump libglibmm-2.4-dev to (>= 2.42.0).
- Bump libgtk-3-dev to (>= 3.14.0).
* Use default compression for binary packages.
* Bump SHVER to 3.14.0.
2014-08-28 - Andreas Barth <aba@ayous.org>
gtkmm3.0 (3.12.0-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Use dh-autoreconf to fix FTBFS on ppc64el.
2014-04-14 - Michael Biebl <biebl@debian.org>
gtkmm3.0 (3.12.0-1) unstable; urgency=medium
* New upstream release.
* Bump debhelper compatibility level to 9.
* Bump Build-Depends on debhelper to (>= 9) to match debian/compat.
* Update dependencies as per configure.ac:
- Bump libglibmm-2.4-dev to (>= 2.38.0).
- Bump libgtk-3-dev to (>= 3.12.0).
- Bump libgdk-pixbuf2.0-dev to (>= 2.26.0).
- Bump mm-common to (>= 0.9.6).
* Bump Standards-Version to 3.9.5.
* Bump SHVER to 3.12.0.
2013-05-25 - Michael Biebl <biebl@debian.org>
gtkmm3.0 (3.8.1-1) unstable; urgency=low
* New upstream release.
* Bump dependency on libglibmm-2.4-dev to (>= 2.36.2) and
libgtk-3-dev to (>= 3.8.0).
* Bump SHVER to 3.8.1.
* Drop DM-Upload-Allowed field, DM upload permissions are no longer handled
this way.
* Bump Standards-Version to 3.9.4. No further changes.
2012-09-29 - Michael Biebl <biebl@debian.org>
gtkmm3.0 (3.4.2-1) unstable; urgency=low
* New upstream stable release.
* Don't compress doxygen tag files since doxygen can't handle those.
* Enable xz compression for binary packages.
2012-04-19 - Michael Biebl <biebl@debian.org>
gtkmm3.0 (3.4.0-2) unstable; urgency=low
* Upload to unstable.
2012-04-12 - Michael Biebl <biebl@debian.org>
gtkmm3.0 (3.4.0-1) experimental; urgency=low
* New upstream release.
* Bump dependency on libgtk-3-dev to (>= 3.4.0).
* Bump dependency on libglibmm-2.4-dev to (>= 2.32.0).
* Bump SHVER to 3.4.0.

See Also

Package Description
libgtkmm-3.0-dev_3.18.0-1_amd64.deb C++ wrappers for GTK+ (development files)
libgtkmm-3.0-doc_3.18.0-1_all.deb C++ wrappers for GTK+ (documentation)
libgtksourceview-3.0-1_3.18.2-1_amd64.deb shared libraries for the GTK+ syntax highlighting widget
libgtksourceview-3.0-common_3.18.2-1_all.deb common files for the GTK+ syntax highlighting widget
libgtksourceview-3.0-dev_3.18.2-1_amd64.deb development files for the GTK+ syntax highlighting widget
libgtksourceview-3.0-doc_3.18.2-1_all.deb documentation for the GTK+ syntax highlighting widget
libgtkspell-dev_2.0.16-1.1ubuntu1_amd64.deb Development files for GtkSpell
libgtkspell0_2.0.16-1.1ubuntu1_amd64.deb a spell-checking addon for GTK's TextView widget
libgtkspell3-3-0_3.0.7-2_amd64.deb spell-checking addon for GTK+'s TextView widget
libgtkspell3-3-dev_3.0.7-2_amd64.deb Development files for GtkSpell
libgtop-2.0-10_2.32.0-1_amd64.deb gtop system monitoring library (shared)
libgtop2-common_2.32.0-1_all.deb gtop system monitoring library (common)
libgtop2-dev_2.32.0-1_amd64.deb gtop system monitoring library (devel)
libgtop2-doc_2.32.0-1_all.deb gtop system monitoring library (documentation)
libgucharmap-2-90-7_3.18.2-1ubuntu1_amd64.deb Unicode browser widget library (shared library)
Advertisement
Advertisement