libgrilo-0.2-1_0.2.15-1_amd64.deb


Advertisement

Description

libgrilo-0.2-1 - Framework for discovering and browsing media - Shared libraries

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libgrilo-0.2-1_0.2.15-1_amd64.deb
Package name libgrilo-0.2-1
Package version 0.2.15
Package release 1
Package architecture amd64
Package type deb
Category libs
Homepage https://wiki.gnome.org/Projects/Grilo
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 98.52 KB
Installed size 334.00 KB
Grilo is a framework focused on making media discovery and browsing
easy for application developers.
More precisely, Grilo provides:
* A single, high-level API that abstracts the differences among
various media content providers, allowing application developers
to integrate content from various services and sources easily.
* A collection of plugins for accessing content from various media
providers. Developers can share efforts and code by writing
plugins for the framework that are application agnostic.
* A flexible API that allows plugin developers to write plugins of
various kinds.
This package contains the shared libraries.

Alternatives

Package Version Architecture Repository
libgrilo-0.2-1_0.2.15-1_i386.deb 0.2.15 i386 Ubuntu Main
libgrilo-0.2-1 - - -

Requires

Name Value
libc6 >= 2.4
libglib2.0-0 >= 2.43.2
libsoup2.4-1 >= 2.41.90
libtotem-plparser18 >= 3.10.0
libxml2 >= 2.7.4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgrilo-0.2-1_0.2.15-1_amd64.deb
Source Package grilo

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgrilo-0.2-1 deb package:
    # sudo apt-get install libgrilo-0.2-1

Files

Path
/usr/lib/x86_64-linux-gnu/libgrilo-0.2.so.1
/usr/lib/x86_64-linux-gnu/libgrilo-0.2.so.1.10.0
/usr/lib/x86_64-linux-gnu/libgrlnet-0.2.so.0
/usr/lib/x86_64-linux-gnu/libgrlnet-0.2.so.0.1.10
/usr/lib/x86_64-linux-gnu/libgrlpls-0.2.so.0
/usr/lib/x86_64-linux-gnu/libgrlpls-0.2.so.0.0.5
/usr/share/doc/libgrilo-0.2-1/AUTHORS.gz
/usr/share/doc/libgrilo-0.2-1/NEWS.gz
/usr/share/doc/libgrilo-0.2-1/README
/usr/share/doc/libgrilo-0.2-1/TODO
/usr/share/doc/libgrilo-0.2-1/changelog.Debian.gz
/usr/share/doc/libgrilo-0.2-1/copyright

Changelog

2016-02-28 - Alberto Garcia <berto@igalia.com>
grilo (0.2.15-1) unstable; urgency=medium
* New upstream release.
* debian/control:
- Update homepage link.
- Update Standards-Version to 3.9.7 (no changes).
* debian/libgrilo-0.2-1.symbols:
- Update.
* debian/rules:
- Enable all hardening flags.
* Migrate to automatic -dbgsym packages:
- debian/control:
+ Remove the entries for libgrilo-0.2-1-dbg.
+ Require debhelper >= 9.20151219.
- debian/rules:
+ Replace --dbg-package with --ddeb-migration in dh_strip.
* Enable vala again:
- debian/rules:
+ Pass --enable-vala to configure.
- debian/control:
+ Add valac to the list of build dependencies.
- debian/libgrilo-0.2-dev.install:
+ Install the files from /usr/share/vala.
2015-09-24 - Alberto Garcia <berto@igalia.com>
grilo (0.2.14-1) unstable; urgency=medium
[ Alberto Garcia ]
* New upstream release.
* debian/copyright:
- Update copyright years.
[ Chris Lamb ]
* debian/control:
- Fix spelling of ${shlibs:Depends} (Closes: #792966).
2015-05-26 - Alberto Garcia <berto@igalia.com>
grilo (0.2.12-2) unstable; urgency=medium
* Upload to unstable.
2015-02-18 - Alberto Garcia <berto@igalia.com>
grilo (0.2.12-1) experimental; urgency=medium
* New upstream release.
* Drop manpages.patch, it's already included in this release.
* debian/control:
- Update Standards-Version to 3.9.6 (no changes).
* debian/libgrilo-0.2-1.symbols:
- Update.
* debian/libgrilo-0.2-dev.install,
debian/control,
debian/rules:
- Disable Vala in this release since it requires valac >= 0.27 which
is not in Debian yet.
2014-09-23 - Alberto Garcia <berto@igalia.com>
grilo (0.2.11-2) unstable; urgency=medium
* Make all packages multi-arch compliant, now that gobject-introspection
supports it:
- debian/gir1.2-grilo-0.2.install: update path of typelib files.
- debian/control: build depend on gobject-introspection >= 1.41.4 and
add Multi-Arch: same field to gir1.2-grilo-0.2 and libgrilo-0.2-dev.
2014-08-26 - Alberto Garcia <berto@igalia.com>
grilo (0.2.11-1) unstable; urgency=medium
* New upstream release.
* debian/libgrilo-0.2-1.symbols: update.
* Install the Grilo test UI and Grilo launch binaries:
- debian/control: add build dependency on libgtk-3-dev and update
description.
- debian/libgrilo-0.2-bin.install: install the binaries.
* debian/rules:
- Enable parallel builds.
- Don't override dh_install, it's no longer necessary.
* debian/patches/manpages.patch:
- Add manpages for all commands.
2014-03-19 - Alberto Garcia <berto@igalia.com>
grilo (0.2.10-1) unstable; urgency=medium
* New upstream release.
* debian/control: update build dependency on libglib2.0-dev to 2.34.
* debian/libgrilo-0.2-1.symbols: update.
2014-02-18 - Alberto Garcia <berto@igalia.com>
grilo (0.2.9-1) unstable; urgency=medium
* New upstream release.
* Drop drop-libvala.patch, this is already integrated in this release.
* debian/rules: disable Automake's silent rules.
2014-02-15 - Alberto Garcia <berto@igalia.com>
grilo (0.2.8-1) unstable; urgency=medium
* New upstream release (Closes: #739025, #739028).
* debian/control:
- Update Standards-Version to 3.9.5 (no changes).
- Bump build dependency on libglib2.0-dev to 2.32.
- Add build dependency on libtotem-plparser-dev.
- Build depend on the generic valac package, there's no need for any
specific version of Vala.
* Don't require libvala, it's not used by Grilo at all.
- debian/patches/drop-libvala.patch: remove check in configure.ac
- debian/control: remove build dependency.
* debian/libgrilo-0.2-1.symbols: update.
* debian/copyright: update copyright years.
2013-09-18 - Alberto Garcia <berto@igalia.com>
grilo (0.2.7-1) unstable; urgency=low
* New upstream release.
* Update my e-mail address in debian/*.
* Remove libsoup.patch, it's no longer relevant for this release.
* debian/libgrilo-0.2-1.symbols: update.

See Also

Package Description
libgrilo-0.2-dev_0.2.15-1_amd64.deb Framework for discovering and browsing media - Development files
libgrilo-0.2-doc_0.2.15-1_all.deb Framework for discovering and browsing media - Documentation
libgs-dev_9.18~dfsg~0-0ubuntu2_amd64.deb interpreter for the PostScript language and for PDF - Development Files
libgs9-common_9.18~dfsg~0-0ubuntu2_all.deb interpreter for the PostScript language and for PDF - common files
libgs9_9.18~dfsg~0-0ubuntu2_amd64.deb interpreter for the PostScript language and for PDF - Library
libgsettings-qt-dev_0.1+16.04.20160329-0ubuntu1_amd64.deb Library to access GSettings from Qt - devel
libgsettings-qt1_0.1+16.04.20160329-0ubuntu1_amd64.deb Library to access GSettings from Qt
libgsl-dev_2.1+dfsg-2_amd64.deb GNU Scientific Library (GSL) -- development package
libgsl2_2.1+dfsg-2_amd64.deb GNU Scientific Library (GSL) -- library package
libgssapi-krb5-2_1.13.2+dfsg-5_amd64.deb MIT Kerberos runtime libraries - krb5 GSS-API Mechanism
libgssapi-perl_0.28-2build3_amd64.deb Perl extension providing access to the GSSAPIv2 library
libgssapi3-heimdal_1.7~git20150920+dfsg-4ubuntu1_amd64.deb Heimdal Kerberos - GSSAPI support library
libgssrpc4_1.13.2+dfsg-5_amd64.deb MIT Kerberos runtime libraries - GSS enabled ONCRPC
libgstreamer-plugins-base1.0-0_1.8.0-1ubuntu1_amd64.deb GStreamer libraries from the "base" set
libgstreamer-plugins-base1.0-dev_1.8.0-1ubuntu1_amd64.deb GStreamer development files for libraries from the "base" set
Advertisement
Advertisement