libgraphviz-dev_2.38.0-12ubuntu2_amd64.deb


Advertisement

Description

libgraphviz-dev - graphviz libs and headers against which to build applications

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libgraphviz-dev_2.38.0-12ubuntu2_amd64.deb
Package name libgraphviz-dev
Package version 2.38.0
Package release 12ubuntu2
Package architecture amd64
Package type deb
Category libdevel
Homepage http://www.graphviz.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 59.86 KB
Installed size 264.00 KB
Graphviz is a set of graph drawing tools. See the description of the graphviz
package for a full description.
This package installs the libraries and headers necessary to link graphviz
library routines into an application. It also installs additional man pages.
Note: A graphviz user doesn't need to install this package.

Alternatives

Package Version Architecture Repository
libgraphviz-dev_2.38.0-12ubuntu2.1_i386.deb 2.38.0 i386 Ubuntu Updates Main
libgraphviz-dev_2.38.0-12ubuntu2.1_amd64.deb 2.38.0 amd64 Ubuntu Updates Main
libgraphviz-dev_2.38.0-12ubuntu2_i386.deb 2.38.0 i386 Ubuntu Main
libgraphviz-dev - - -

Requires

Name Value
libcdt5 = 2.38.0-12ubuntu2
libcgraph6 = 2.38.0-12ubuntu2
libexpat1-dev -
libgvc6 = 2.38.0-12ubuntu2
libgvpr2 = 2.38.0-12ubuntu2
libltdl7-dev -
libpathplan4 = 2.38.0-12ubuntu2
libxdot4 = 2.38.0-12ubuntu2
zlib1g-dev -

Provides

Name Value
graphviz-dev -

Conflicts

Name Value
graphviz-dev << 2.12-1
libgraphviz3-dev -
libgraphviz4-dev << 2.16-3

Replaces

Name Value
libgraphviz3-dev -
libgraphviz4-dev << 2.16-3

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgraphviz-dev_2.38.0-12ubuntu2_amd64.deb
Source Package graphviz

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgraphviz-dev deb package:
    # sudo apt-get install libgraphviz-dev

Files

Path
/usr/include/graphviz/arith.h
/usr/include/graphviz/cdt.h
/usr/include/graphviz/cgraph.h
/usr/include/graphviz/color.h
/usr/include/graphviz/geom.h
/usr/include/graphviz/graphviz_version.h
/usr/include/graphviz/gv.cpp
/usr/include/graphviz/gv.i
/usr/include/graphviz/gvc.h
/usr/include/graphviz/gvcext.h
/usr/include/graphviz/gvcjob.h
/usr/include/graphviz/gvcommon.h
/usr/include/graphviz/gvconfig.h
/usr/include/graphviz/gvplugin.h
/usr/include/graphviz/gvplugin_device.h
/usr/include/graphviz/gvplugin_layout.h
/usr/include/graphviz/gvplugin_loadimage.h
/usr/include/graphviz/gvplugin_render.h
/usr/include/graphviz/gvplugin_textlayout.h
/usr/include/graphviz/gvpr.h
/usr/include/graphviz/pack.h
/usr/include/graphviz/pathgeom.h
/usr/include/graphviz/pathplan.h
/usr/include/graphviz/textspan.h
/usr/include/graphviz/types.h
/usr/include/graphviz/usershape.h
/usr/include/graphviz/xdot.h
/usr/lib/libcdt.so
/usr/lib/libcgraph.so
/usr/lib/libgvc.so
/usr/lib/libgvpr.so
/usr/lib/libpathplan.so
/usr/lib/libxdot.so
/usr/lib/graphviz/libgvplugin_core.so
/usr/lib/graphviz/libgvplugin_dot_layout.so
/usr/lib/graphviz/libgvplugin_gd.so
/usr/lib/graphviz/libgvplugin_gdk.so
/usr/lib/graphviz/libgvplugin_gtk.so
/usr/lib/graphviz/libgvplugin_neato_layout.so
/usr/lib/graphviz/libgvplugin_pango.so
/usr/lib/graphviz/libgvplugin_xlib.so
/usr/lib/pkgconfig/libcdt.pc
/usr/lib/pkgconfig/libcgraph.pc
/usr/lib/pkgconfig/libgvc.pc
/usr/lib/pkgconfig/libgvpr.pc
/usr/lib/pkgconfig/libpathplan.pc
/usr/lib/pkgconfig/libxdot.pc
/usr/share/doc/libgraphviz-dev/changelog.Debian.gz
/usr/share/doc/libgraphviz-dev/copyright
/usr/share/man/man3/cdt.3.gz
/usr/share/man/man3/cgraph.3.gz
/usr/share/man/man3/gvc.3.gz
/usr/share/man/man3/pathplan.3.gz

Changelog

2016-03-13 - Matthias Klose <doko@ubuntu.com>
graphviz (2.38.0-12ubuntu2) xenial; urgency=medium
* No-change rebuild for ruby2.3-only support.
2016-02-17 - Nishanth Aravamudan <nish.aravamudan@canonical.com>
graphviz (2.38.0-12ubuntu1) xenial; urgency=medium
* Disable libgv-php5 while swig does not support PHP 7.0
(LP: #1546823).
2015-12-18 - Colin Watson <cjwatson@ubuntu.com>
graphviz (2.38.0-12build1) xenial; urgency=medium
* Rebuild for Perl 5.22.1.
2015-11-17 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
graphviz (2.38.0-12) unstable; urgency=low
* Build with Ruby 2.2 version.
* Remove uninstalled smyrna documentation (closes: #596707).
[ Antonio Terceiro <terceiro@debian.org> ]
* Fix FTBFS with Ruby 2.2 as default (closes: #804799).
2015-10-31 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
graphviz (2.38.0-11) unstable; urgency=low
* Backport build fix of RedHat for Ruby 2.2 transition (closes: #803587).
* Remove libltdl-dev from build dependencies (closes: #746012).
* Call ldconfig during libgvc6 removal.
2015-07-08 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
graphviz (2.38.0-10) unstable; urgency=low
* Use the real libgd-dev for build dependency and not the old transitional
one (closes: #791852).
2015-05-20 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
graphviz (2.38.0-9) unstable; urgency=medium
* Finish dh_python2 transition and use 2.7 as minimal version for Python
(closes: #783680).
2015-04-13 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
graphviz (2.38.0-8) unstable; urgency=medium
* Add dh-python to build depends.
* Add PHP module loading ini (closes: #649015).
* Update Standars-Version to 3.9.6 .
* New maintainer (closes: #736605).
2014-12-10 - Salvatore Bonaccorso <carnil@debian.org>
graphviz (2.38.0-7) unstable; urgency=high
* QA upload.
* Add CVE-2014-9157.patch.
Fix format string vulnerability (CVE-2014-9157) in yyerror() routine
which may allow attackers to cause a denial of service or possibly
execute code.
Thanks to Marc Deslauriers <marc.deslauriers@ubuntu.com> (Closes: #772648)
2014-09-01 - Gilles Filippini <pini@debian.org>
graphviz (2.38.0-6) unstable; urgency=medium
* QA upload.
* Sync and re-enable kfreebsd-hang.patch (thanks to Steven
Chamberlain; closes: #760165).

See Also

Package Description
libgrilo-0.2-1_0.2.15-1_amd64.deb Framework for discovering and browsing media - Shared libraries
libgrilo-0.2-dev_0.2.15-1_amd64.deb Framework for discovering and browsing media - Development files
libgrilo-0.2-doc_0.2.15-1_all.deb Framework for discovering and browsing media - Documentation
libgs-dev_9.18~dfsg~0-0ubuntu2_amd64.deb interpreter for the PostScript language and for PDF - Development Files
libgs9-common_9.18~dfsg~0-0ubuntu2_all.deb interpreter for the PostScript language and for PDF - common files
libgs9_9.18~dfsg~0-0ubuntu2_amd64.deb interpreter for the PostScript language and for PDF - Library
libgsettings-qt-dev_0.1+16.04.20160329-0ubuntu1_amd64.deb Library to access GSettings from Qt - devel
libgsettings-qt1_0.1+16.04.20160329-0ubuntu1_amd64.deb Library to access GSettings from Qt
libgsl-dev_2.1+dfsg-2_amd64.deb GNU Scientific Library (GSL) -- development package
libgsl2_2.1+dfsg-2_amd64.deb GNU Scientific Library (GSL) -- library package
libgssapi-krb5-2_1.13.2+dfsg-5_amd64.deb MIT Kerberos runtime libraries - krb5 GSS-API Mechanism
libgssapi-perl_0.28-2build3_amd64.deb Perl extension providing access to the GSSAPIv2 library
libgssapi3-heimdal_1.7~git20150920+dfsg-4ubuntu1_amd64.deb Heimdal Kerberos - GSSAPI support library
libgssrpc4_1.13.2+dfsg-5_amd64.deb MIT Kerberos runtime libraries - GSS enabled ONCRPC
libgstreamer-plugins-base1.0-0_1.8.0-1ubuntu1_amd64.deb GStreamer libraries from the "base" set
Advertisement
Advertisement