libgraphite2-3_1.3.6-1ubuntu1_amd64.deb


Advertisement

Description

libgraphite2-3 - Font rendering engine for Complex Scripts -- library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libgraphite2-3_1.3.6-1ubuntu1_amd64.deb
Package name libgraphite2-3
Package version 1.3.6
Package release 1ubuntu1
Package architecture amd64
Package type deb
Category libs
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 69.15 KB
Installed size 175.00 KB
Graphite is a system that can be used to create and use "smart fonts" capable
of displaying writing systems with various complex behaviors, such as:
contextual shaping, ligatures, reordering, split glyphs, bidirectionality,
stacking diacritics and complex positioning.
This library was designed and developed by the NRSI (Non-Roman Script
Initiative) within SIL International (www.sil.org) to act as a complement to
other smart font rendering technologies with limited practical local
extensibility. Its purpose is to help meet the needs of a very large number
of "minority language" communities for local extensibility of complex script
behaviors.
The behavior of the rendering engine for a given writing system is specified
through extra tables added to a TrueType font.  These tables are generated by
compiling a GDL (Graphite Description Language) source file into a font using
grcompiler.
This package contains the shared library.

Alternatives

Package Version Architecture Repository
libgraphite2-3_1.3.10-0ubuntu0.16.04.1_i386.deb 1.3.10 i386 Ubuntu Updates Main
libgraphite2-3_1.3.10-0ubuntu0.16.04.1_amd64.deb 1.3.10 amd64 Ubuntu Updates Main
libgraphite2-3_1.3.6-1ubuntu1_i386.deb 1.3.6 i386 Ubuntu Main
libgraphite2-3 - - -

Requires

Name Value
libc6 >= 2.14

Provides

Name Value
libgraphite2-2.0.0 -

Replaces

Name Value
libgraphite2-2.0.0 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgraphite2-3_1.3.6-1ubuntu1_amd64.deb
Source Package graphite2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgraphite2-3 deb package:
    # sudo apt-get install libgraphite2-3

Files

Path
/usr/lib/x86_64-linux-gnu/libgraphite2.so.2.0.0
/usr/lib/x86_64-linux-gnu/libgraphite2.so.3
/usr/lib/x86_64-linux-gnu/libgraphite2.so.3.0.1
/usr/share/doc/libgraphite2-3/changelog.Debian.gz
/usr/share/doc/libgraphite2-3/copyright
/usr/share/lintian/overrides/libgraphite2-3

Changelog

2016-03-09 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
graphite2 (1.3.6-1ubuntu1) xenial; urgency=medium
* Resynchronize on Debian, remaining changes
- Allow the package to cross build.
2016-02-29 - Rene Engelhard <rene@debian.org>
graphite2 (1.3.6-1) unstable; urgency=medium
* New upstream release
2016-02-23 - Sebastien Bacher <seb128@ubuntu.com>
graphite2 (1.3.5-1ubuntu1) xenial; urgency=medium
* Resynchronize on Debian, remaining changes
- Allow the package to cross build.
2016-01-20 - Rene Engelhard <rene@debian.org>
graphite2 (1.3.5-1) unstable; urgency=medium
* New upstream release
- fixes Bidirectional Font BracketPairStack Code Execution Vulnerability
(TALOS-2016-0057/CVE-2016-1522)
- fixes directrun Opcode Handling Code Execution Vulnerability
(TALOS-2016-0058/CVE-2016-1521)
- fixes Context Item Code Execution Vulnerability
(TALOS-2016-0059/CVE-2016-1523)
- fixes Bidirectional Font mFeatureMap Denial of Service Vulnerability
(TALOS-2016-0060/CVE-2016-1522)
- fixes LocaLookup Denial of Service Vulnerability"
(TALOS-2016-0061/CVE-2016-1521)
2016-01-05 - Rene Engelhard <rene@debian.org>
graphite2 (1.3.4-2) unstable; urgency=medium
* debian/patches/revert-collision-info-refactoring-to-fix-alignment.diff:
add from upstream git, thanks Tim Eves (closes: #805323)
* debian/patches/reproducible-build.diff: tell dblatex to use a static
path to make build reproduceable, thanks Reiner Herrmann
(closes: #807838)
* use -DGRAPHITE2_NTRACING:BOOL=ON (instead of :bool=1)
* fix Maintainer:
* migrate from manual -dbg to ddeb
2015-10-31 - Rene Engelhard <rene@debian.org>
graphite2 (1.3.4-1) unstable; urgency=medium
* New upstream release
2015-09-22 - Rene Engelhard <rene@debian.org>
graphite2 (1.3.3-1) unstable; urgency=medium
* New upstream release
2015-09-18 - Rene Engelhard <rene@debian.org>
graphite2 (1.3.2-4) unstable; urgency=medium
* upload to unstable
* add graphviz to B-D-I...
2015-09-16 - Rene Engelhard <rene@debian.org>
graphite2 (1.3.2-3) experimental; urgency=medium
* don't run dh_auto_install when ./build/src/libgraphite2.so.3 doesn't exist
(as for dh_auto_test) so that we don't run a graphite build after building
the docs (as make install of course requires that). Install the docs
manually using .install
2015-09-15 - Rene Engelhard <rene@debian.org>
graphite2 (1.3.2-2) experimental; urgency=medium
* check for existence of ./build/src/libgraphite2.so.3 before running
dh_auto_test to skip the tests on "all" builds

See Also

Package Description
libgraphite2-dev_1.3.6-1ubuntu1_amd64.deb Development files for libgraphite2
libgraphite2-doc_1.3.6-1ubuntu1_all.deb Documentation for libgraphite2
libgraphviz-dev_2.38.0-12ubuntu2_amd64.deb graphviz libs and headers against which to build applications
libgrilo-0.2-1_0.2.15-1_amd64.deb Framework for discovering and browsing media - Shared libraries
libgrilo-0.2-dev_0.2.15-1_amd64.deb Framework for discovering and browsing media - Development files
libgrilo-0.2-doc_0.2.15-1_all.deb Framework for discovering and browsing media - Documentation
libgs-dev_9.18~dfsg~0-0ubuntu2_amd64.deb interpreter for the PostScript language and for PDF - Development Files
libgs9-common_9.18~dfsg~0-0ubuntu2_all.deb interpreter for the PostScript language and for PDF - common files
libgs9_9.18~dfsg~0-0ubuntu2_amd64.deb interpreter for the PostScript language and for PDF - Library
libgsettings-qt-dev_0.1+16.04.20160329-0ubuntu1_amd64.deb Library to access GSettings from Qt - devel
libgsettings-qt1_0.1+16.04.20160329-0ubuntu1_amd64.deb Library to access GSettings from Qt
libgsl-dev_2.1+dfsg-2_amd64.deb GNU Scientific Library (GSL) -- development package
libgsl2_2.1+dfsg-2_amd64.deb GNU Scientific Library (GSL) -- library package
libgssapi-krb5-2_1.13.2+dfsg-5_amd64.deb MIT Kerberos runtime libraries - krb5 GSS-API Mechanism
libgssapi-perl_0.28-2build3_amd64.deb Perl extension providing access to the GSSAPIv2 library
Advertisement
Advertisement