libgpg-error-dev_1.21-2ubuntu1_amd64.deb


Advertisement

Description

libgpg-error-dev - library for common error values and messages in GnuPG components (development)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libgpg-error-dev_1.21-2ubuntu1_amd64.deb
Package name libgpg-error-dev
Package version 1.21
Package release 2ubuntu1
Package architecture amd64
Package type deb
Category libdevel
Homepage http://www.gnupg.org/related_software/libgpg-error/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 66.63 KB
Installed size 262.00 KB
Library that defines common error values for all GnuPG
components.  Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt,
pinentry, SmartCard Daemon and possibly more in the future.
This package contains the headers and other files needed to compile
against this library.

Alternatives

Package Version Architecture Repository
libgpg-error-dev_1.21-2ubuntu1_i386.deb 1.21 i386 Ubuntu Main
libgpg-error-dev - - -

Requires

Name Value
libc6 >= 2.3.4
libgpg-error0 = 1.21-2ubuntu1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgpg-error-dev_1.21-2ubuntu1_amd64.deb
Source Package libgpg-error

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgpg-error-dev deb package:
    # sudo apt-get install libgpg-error-dev

Files

Path
/usr/bin/gpg-error
/usr/bin/gpg-error-config
/usr/include/x86_64-linux-gnu/gpg-error.h
/usr/lib/x86_64-linux-gnu/libgpg-error.a
/usr/lib/x86_64-linux-gnu/libgpg-error.la
/usr/lib/x86_64-linux-gnu/libgpg-error.so
/usr/share/aclocal/gpg-error.m4
/usr/share/doc/libgpg-error-dev/README.gz
/usr/share/doc/libgpg-error-dev/TODO.Debian
/usr/share/doc/libgpg-error-dev/changelog.Debian.gz
/usr/share/doc/libgpg-error-dev/copyright
/usr/share/info/gpgrt.info.gz
/usr/share/lintian/overrides/libgpg-error-dev
/usr/share/man/man1/gpg-error-config.1.gz
/usr/share/man/man1/gpg-error.1.gz

Changelog

2016-02-18 - Matthias Klose <doko@ubuntu.com>
libgpg-error (1.21-2ubuntu1) xenial; urgency=medium
* Don't build the libgpg-error-mingw-w64-dev package (mingw64 is in universe).
2016-02-08 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.21-2) unstable; urgency=medium
* build out-of-tree for cleanliness
* added libgpg-error-mingw-w64-dev package, in preparation for
cross-building win32-loader component gpgv.exe
2015-12-15 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.21-1) unstable; urgency=medium
* New upstream release.
2015-09-08 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.20-1) unstable; urgency=medium
* New upstream release
* use new upstream default of no embedding build timestamp
2015-06-04 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.19-2) unstable; urgency=medium
* upload to unstable
2015-04-13 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.19-1) experimental; urgency=medium
* New Upstream Version
2015-03-16 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.18-1) experimental; urgency=medium
* New Upstream Version
* debian/patches: dropped most, already applied upstream
* avoid breakage with gcc 5 (Closes: #777374)
2014-12-12 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.17-3) unstable; urgency=medium
[ David Prévot ]
* Force rebuild of gmo files
* Update Polish translation, thanks to Jakub Bogusz
* Update French translation
* Update Ukrainian translation, thanks to Yuri Chornoivan
* Update Danish translation, thanks to Joe Hansen
* Update Dutch translation, thanks to Freek de Kruijf
* Update Japanese translation, thanks to NIIBE Yutaka
* Add Russian translation, thanks to Ineiev
* Update Italian translation, thanks to Milo Casagrande
* Add Chinese (traditional) translation, thanks to Jedi Lin
* Add Portuguese translation, thanks to Paulo Tomé (Closes: #770893)
* Add Serbian translation, thanks to Мирослав Николић
* Update Czech translation, thanks to Petr Pisar
2014-10-24 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.17-2) unstable; urgency=medium
* added arch-specific lock-obj header for added
mips64el-unknown-linux-gnuabi64 (Closes: #766135)
2014-09-29 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.17-1) unstable; urgency=medium
* New upstream release (Closes: #762322)
- debian/patches: all merged upstream
* added arch-specific lock-obj header for i586-pc-linux-gnu
(Closes: #764881)
* bumped all symbols to 1.14 since version node GPG_ERROR_1.0 was
introduced there. (Closes: #765430)
* use upstream's manpage for gpg-error-config
* bump Standards-Version to 3.9.6 (no changes needed)

See Also

Package Description
libgpg-error0_1.21-2ubuntu1_amd64.deb library for common error values and messages in GnuPG components
libgpgme11-dev_1.6.0-1_amd64.deb GPGME - GnuPG Made Easy (development files)
libgpgme11_1.6.0-1_amd64.deb GPGME - GnuPG Made Easy (library)
libgphoto2-6_2.5.9-3_amd64.deb gphoto2 digital camera library
libgphoto2-dev-doc_2.5.9-3_all.deb gphoto2 digital camera library (development documentation)
libgphoto2-dev_2.5.9-3_amd64.deb gphoto2 digital camera library (development files)
libgphoto2-l10n_2.5.9-3_all.deb gphoto2 digital camera library - localized messages
libgphoto2-port12_2.5.9-3_amd64.deb gphoto2 digital camera port library
libgpm-dev_1.20.4-6.1_amd64.deb General Purpose Mouse - development files
libgpm2_1.20.4-6.1_amd64.deb General Purpose Mouse - shared library
libgpod-cil-dev_0.8.3-6ubuntu2_amd64.deb CLI bindings for libgpod -- development files
libgpod-cil_0.8.3-6ubuntu2_amd64.deb CLI bindings for libgpod
libgpod-common_0.8.3-6ubuntu2_amd64.deb common files for libgpod
libgpod-dev_0.8.3-6ubuntu2_amd64.deb development files for libgpod
libgpod-doc_0.8.3-6ubuntu2_all.deb documentation for libgpod
Advertisement
Advertisement