libgmime-2.6-dev_2.6.20-1_amd64.deb


Advertisement

Description

libgmime-2.6-dev - MIME message parser and creator library - development files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libgmime-2.6-dev_2.6.20-1_amd64.deb
Package name libgmime-2.6-dev
Package version 2.6.20
Package release 1
Package architecture amd64
Package type deb
Category libdevel
Homepage http://spruce.sourceforge.net/gmime/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 178.92 KB
Installed size 1.05 MB
GMime provides a core library and set of utilities which may be used for the
creation and parsing of messages using the Multipurpose Internet Mail
Extension (MIME).
This package contains the development files of GMime.

Alternatives

Package Version Architecture Repository
libgmime-2.6-dev_2.6.20-1_i386.deb 2.6.20 i386 Ubuntu Main
libgmime-2.6-dev - - -

Requires

Name Value
libc6-dev -
libglib2.0-dev -
libgmime-2.6-0 = 2.6.20-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgmime-2.6-dev_2.6.20-1_amd64.deb
Source Package gmime

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgmime-2.6-dev deb package:
    # sudo apt-get install libgmime-2.6-dev

Files

Path
/usr/include/gmime-2.6/gmime/gmime-certificate.h
/usr/include/gmime-2.6/gmime/gmime-charset.h
/usr/include/gmime-2.6/gmime/gmime-content-type.h
/usr/include/gmime-2.6/gmime/gmime-crypto-context.h
/usr/include/gmime-2.6/gmime/gmime-data-wrapper.h
/usr/include/gmime-2.6/gmime/gmime-disposition.h
/usr/include/gmime-2.6/gmime/gmime-encodings.h
/usr/include/gmime-2.6/gmime/gmime-error.h
/usr/include/gmime-2.6/gmime/gmime-filter-basic.h
/usr/include/gmime-2.6/gmime/gmime-filter-best.h
/usr/include/gmime-2.6/gmime/gmime-filter-charset.h
/usr/include/gmime-2.6/gmime/gmime-filter-crlf.h
/usr/include/gmime-2.6/gmime/gmime-filter-enriched.h
/usr/include/gmime-2.6/gmime/gmime-filter-from.h
/usr/include/gmime-2.6/gmime/gmime-filter-gzip.h
/usr/include/gmime-2.6/gmime/gmime-filter-html.h
/usr/include/gmime-2.6/gmime/gmime-filter-md5.h
/usr/include/gmime-2.6/gmime/gmime-filter-strip.h
/usr/include/gmime-2.6/gmime/gmime-filter-windows.h
/usr/include/gmime-2.6/gmime/gmime-filter-yenc.h
/usr/include/gmime-2.6/gmime/gmime-filter.h
/usr/include/gmime-2.6/gmime/gmime-gpg-context.h
/usr/include/gmime-2.6/gmime/gmime-header.h
/usr/include/gmime-2.6/gmime/gmime-iconv-utils.h
/usr/include/gmime-2.6/gmime/gmime-iconv.h
/usr/include/gmime-2.6/gmime/gmime-message-part.h
/usr/include/gmime-2.6/gmime/gmime-message-partial.h
/usr/include/gmime-2.6/gmime/gmime-message.h
/usr/include/gmime-2.6/gmime/gmime-multipart-encrypted.h
/usr/include/gmime-2.6/gmime/gmime-multipart-signed.h
/usr/include/gmime-2.6/gmime/gmime-multipart.h
/usr/include/gmime-2.6/gmime/gmime-object.h
/usr/include/gmime-2.6/gmime/gmime-param.h
/usr/include/gmime-2.6/gmime/gmime-parser.h
/usr/include/gmime-2.6/gmime/gmime-part-iter.h
/usr/include/gmime-2.6/gmime/gmime-part.h
/usr/include/gmime-2.6/gmime/gmime-pkcs7-context.h
/usr/include/gmime-2.6/gmime/gmime-signature.h
/usr/include/gmime-2.6/gmime/gmime-stream-buffer.h
/usr/include/gmime-2.6/gmime/gmime-stream-cat.h
/usr/include/gmime-2.6/gmime/gmime-stream-file.h
/usr/include/gmime-2.6/gmime/gmime-stream-filter.h
/usr/include/gmime-2.6/gmime/gmime-stream-fs.h
/usr/include/gmime-2.6/gmime/gmime-stream-gio.h
/usr/include/gmime-2.6/gmime/gmime-stream-mem.h
/usr/include/gmime-2.6/gmime/gmime-stream-mmap.h
/usr/include/gmime-2.6/gmime/gmime-stream-null.h
/usr/include/gmime-2.6/gmime/gmime-stream-pipe.h
/usr/include/gmime-2.6/gmime/gmime-stream.h
/usr/include/gmime-2.6/gmime/gmime-utils.h
/usr/include/gmime-2.6/gmime/gmime-version.h
/usr/include/gmime-2.6/gmime/gmime.h
/usr/include/gmime-2.6/gmime/internet-address.h
/usr/lib/x86_64-linux-gnu/libgmime-2.6.a
/usr/lib/x86_64-linux-gnu/libgmime-2.6.so
/usr/lib/x86_64-linux-gnu/pkgconfig/gmime-2.6.pc
/usr/share/doc/libgmime-2.6-dev/AUTHORS
/usr/share/doc/libgmime-2.6-dev/README.gz
/usr/share/doc/libgmime-2.6-dev/TODO
/usr/share/doc/libgmime-2.6-dev/changelog.Debian.gz
/usr/share/doc/libgmime-2.6-dev/copyright

Changelog

2014-05-23 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gmime (2.6.20-1) unstable; urgency=medium
* New Upsteam Release
* dropped debian/patches/fix-upstream-711305.diff, merged upstream.
2014-01-20 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gmime (2.6.19-3) unstable; urgency=low
* put the gmime-sharp-2.6.pc header in the right place (Closes: #735411)
* debian/control: bump Standards-Version to 3.9.5 (no changes needed)
2013-11-10 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gmime (2.6.19-2) unstable; urgency=low
* rewrite headers cleanly (cherrypick bugfix from upstream for
https://bugzilla.gnome.org/show_bug.cgi?id=711305
2013-10-22 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gmime (2.6.19-1) unstable; urgency=low
* New Upstream Release (Closes: #727093)
2013-09-20 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gmime (2.6.18-1) unstable; urgency=low
* New Upstream Release
* use dh_autoreconf
* clean up the --with=cli args in debian/rules
* upgrade to dh 9
* actually multi-arch the shared libraries (Thanks, mbiebl)
(Closes: #722609)
2013-09-10 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gmime (2.6.17-1) unstable; urgency=low
* New Upstream Release
2013-07-19 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gmime (2.6.16-1) unstable; urgency=low
* New Upstream Release
* bumped Standards-Version to 3.9.4 (no changes needed)
2012-06-22 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gmime (2.6.10-1) unstable; urgency=low
* New Upstream Release (Closes: #678185)
* moved libgmime2.6-cil-dev to Section: cli-mono.  Thanks, Lintian!
2012-05-18 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gmime (2.6.9-1) unstable; urgency=low
* New Upstream Release.
- drop debian/patches/fix_gmime-sharp.dll.config_reference.patch
(adopted upstream)
* added missing versioned build-dep on dpkg-dev for dpkg-buildflags
--export=configure.
* enabled S/MIME support (Closes: #673077)
2012-03-10 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gmime (2.6.7-1) unstable; urgency=low
* New Upstream Release.
* move gmime-bin to Section: utils
* debian/control: update Vcs-Browser (Closes: #663207)
* ensure gmime-sharp.dll.config points to the correct .so
Thanks, Michael Biebl! (Closes: #663220)
* bump Stanards-Version to 3.9.3 (no changes needed)
* update Format to debian/copyright format 1.0

See Also

Package Description
libgmime-2.6-doc_2.6.20-1_all.deb MIME message parser and creator library - documentation
libgmime2.6-cil-dev_2.6.20-1_all.deb CLI binding for the GMime library
libgmime2.6-cil_2.6.20-1_all.deb CLI binding for the GMime library
libgmp-dev_6.1.0+dfsg-2_amd64.deb Multiprecision arithmetic library developers tools
libgmp10-doc_6.1.0+dfsg-2_all.deb Multiprecision arithmetic library example code
libgmp10_6.1.0+dfsg-2_amd64.deb Multiprecision arithmetic library
libgmp3-dev_6.1.0+dfsg-2_amd64.deb Multiprecision arithmetic library developers tools
libgmpxx4ldbl_6.1.0+dfsg-2_amd64.deb Multiprecision arithmetic library (C++ bindings)
libgnome-2-0_2.32.1-5ubuntu1_amd64.deb The GNOME library - runtime files
libgnome-bluetooth-dev_3.18.2-1ubuntu2_amd64.deb GNOME Bluetooth tools - support library development files
libgnome-bluetooth13_3.18.2-1ubuntu2_amd64.deb GNOME Bluetooth tools - support library
libgnome-desktop-3-12_3.18.2-1ubuntu1_amd64.deb Utility library for loading .desktop files - runtime files
libgnome-desktop-3-dev_3.18.2-1ubuntu1_amd64.deb Utility library for loading .desktop files - development files
libgnome-keyring-common_3.12.0-1build1_all.deb GNOME keyring services library - data files
libgnome-keyring-dev_3.12.0-1build1_amd64.deb Development files for GNOME keyring service
Advertisement
Advertisement