libgdiplus_4.2-1ubuntu1_amd64.deb


Advertisement

Description

libgdiplus - interface library for System.Drawing of Mono

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libgdiplus_4.2-1ubuntu1_amd64.deb
Package name libgdiplus
Package version 4.2
Package release 1ubuntu1
Package architecture amd64
Package type deb
Category libs
Homepage http://www.mono-project.com/Libgdiplus
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 135.93 KB
Installed size 435.00 KB
This package contains a GDI+ API compatible implementation needed by the
System.Drawing library of Mono.

Alternatives

Package Version Architecture Repository
libgdiplus_4.2-1ubuntu1_i386.deb 4.2 i386 Ubuntu Main
libgdiplus - - -

Requires

Name Value
libc6 >= 2.14
libcairo2 >= 1.4
libexif12 >= 0.6.21-1~
libfontconfig1 >= 2.9.0
libfreetype6 >= 2.2.1
libgif7 >= 5.1
libglib2.0-0 >= 2.31.8
libjpeg8 >= 8c
libpng12-0 >= 1.2.13-4
libtiff5 >= 4.0.3
libx11-6 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgdiplus_4.2-1ubuntu1_amd64.deb
Source Package libgdiplus

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgdiplus deb package:
    # sudo apt-get install libgdiplus

Files

Path
/usr/lib/libgdiplus.so
/usr/lib/libgdiplus.so.0
/usr/lib/libgdiplus.so.0.0.0
/usr/lib/pkgconfig/libgdiplus.pc
/usr/share/doc/libgdiplus/changelog.Debian.gz
/usr/share/doc/libgdiplus/copyright

Changelog

2015-12-21 - Michael Terry <mterry@ubuntu.com>
libgdiplus (4.2-1ubuntu1) xenial; urgency=medium
* debian/control:
- Add powerpc back to the architecture list
2015-12-20 - Jo Shields <directhex@apebox.org>
libgdiplus (4.2-1) unstable; urgency=medium
* [f55e3da] Imported Upstream version 4.2 (Closes: #803274, #688361)
* [feca412] Refreshed list of architectures
2014-08-27 - Jo Shields <directhex@apebox.org>
libgdiplus (3.6-1) unstable; urgency=medium
* [a769019] Imported Upstream version 3.6
* [8b2203c] Change scanning URL for uscan
* [2da9293] It's 2014, we can handle bz2 orig
* [1ca4f93] Imported Upstream version 3.6
* [3ed0a39] Drop obsolete patch
* [0e8fc62] Add new arches, because why not
* [1e99dc2] Refresh debian/patches/initialize_png_transparency.patch
* [f5f9cd8] Use dh-autoreconf. Helps for ppc64el!
* [9ab1f97] Bump to DH7
* [72f12fa] Delete crud we don't need when using dh-autoreconf
* [1d6f7b0] Fix pngcodec.c which wasn't committed properly to Debian
2014-03-31 - Jo Shields <directhex@apebox.org>
libgdiplus (2.11+git20131008.9732566-5) unstable; urgency=low
* [5e251c5] Ensure PNG transparency values are initialized. Thanks to 
Tom Hindle (LP: #1296786) (Closes: #741980)
2013-12-16 - Jo Shields <directhex@apebox.org>
libgdiplus (2.11+git20131008.9732566-4) unstable; urgency=low
* [01b42b2] Add debian/patches/use_freetype_macros.patch, 
cherry-picked from upstream 180c02e0f2a2016eba8520b456ca929e9dcf03db, 
as a workaround to the FTBFS on FreeType 2.5+ (Closes: #732274)
2013-10-28 - Jo Shields <directhex@apebox.org>
libgdiplus (2.11+git20131008.9732566-3) unstable; urgency=low
* [9a8bde0] Remove SPARC from architecture list, since Mono no longer supports it
2013-10-24 - Jo Shields <directhex@apebox.org>
libgdiplus (2.11+git20131008.9732566-2) unstable; urgency=low
* [ecab77d] Refresh list of target architectures, to aid removal 
of arches which Mono no longer supports (Closes: #727591)
2013-10-10 - Jo Shields <directhex@apebox.org>
libgdiplus (2.11+git20131008.9732566-1) unstable; urgency=low
* [285d0a3] Imported Upstream version 2.11+git20131008.9732566 
(Closes: #649946)
* [b7b1355] Build-depends on libtiff5-dev | libtiff-dev, change 
from libtiff4-dev (Closes #681132)
* [fea5c93] Build-Depends on libpng-dev, change from libpng12-dev 
(Closes: #662402)
2012-01-18 - Jo Shields <directhex@apebox.org>
libgdiplus (2.10-3) unstable; urgency=low
[ Iain Lane ]
* [9ee065e] Change BD on libjpeg62-dev to libjpeg-dev, as part of the 
transition (Closes: #634138)
[ Jo Shields ]
* [6dc8f99] Replace s390 architecture with s390x, since s390 is no longer 
in Mono.
2011-06-10 - Jo Shields <directhex@apebox.org>
libgdiplus (2.10-2) experimental; urgency=low
* [9817aa7] Add ppc64 to list of architectures, for Ubuntu

See Also

Package Description
libgdk-pixbuf2.0-0_2.32.2-1ubuntu1_amd64.deb GDK Pixbuf library
libgdk-pixbuf2.0-common_2.32.2-1ubuntu1_all.deb GDK Pixbuf library - data files
libgdk-pixbuf2.0-dev_2.32.2-1ubuntu1_amd64.deb GDK Pixbuf library (development files)
libgdk-pixbuf2.0-doc_2.32.2-1ubuntu1_all.deb GDK Pixbuf library (documentation)
libgee-0.8-2_0.18.0-1_amd64.deb GObject based collection and utility library
libgee-0.8-dev_0.18.0-1_amd64.deb GObject based collection and utility library (development files)
libgeis-dev_2.2.17+16.04.20160126-0ubuntu1_amd64.deb Gesture engine interface support - dev files
libgeis-doc_2.2.17+16.04.20160126-0ubuntu1_all.deb Gesture engine interface support - documentation
libgeis1_2.2.17+16.04.20160126-0ubuntu1_amd64.deb Gesture engine interface support
libgeoclue-dev_0.12.99-4ubuntu1_amd64.deb C API for GeoClue (development files)
libgeoclue0_0.12.99-4ubuntu1_amd64.deb C API for GeoClue
libgeocode-glib-dev_3.18.2-1_amd64.deb development files for geocode-glib library
libgeocode-glib-doc_3.18.2-1_all.deb gtk-doc documentation for geocode-glib library
libgeocode-glib0_3.18.2-1_amd64.deb geocoding and reverse geocoding GLib library using Nominatim
libgeoip-dev_1.6.9-1_amd64.deb Development files for the GeoIP library
Advertisement
Advertisement