libgdbm-dev_1.8.3-13.1_amd64.deb


Advertisement

Description

libgdbm-dev - GNU dbm database routines (development files)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libgdbm-dev_1.8.3-13.1_amd64.deb
Package name libgdbm-dev
Package version 1.8.3
Package release 13.1
Package architecture amd64
Package type deb
Category libdevel
Homepage http://directory.fsf.org/project/gdbm/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 35.05 KB
Installed size 157.00 KB
GNU dbm ('gdbm') is a library of database functions that use extendible
hashing and works similarly to the standard UNIX 'dbm' functions.  This
package includes development support files.

Alternatives

Package Version Architecture Repository
libgdbm-dev_1.8.3-13.1_i386.deb 1.8.3 i386 Ubuntu Main
libgdbm-dev - - -

Requires

Name Value
libc-dev -
libc6-dev -
libgdbm3 = 1.8.3-13.1

Conflicts

Name Value
libgdbm1-dev -
libgdbmg1-dev -

Replaces

Name Value
libgdbm3 << 1.8.3-12.1
libgdbmg1-dev -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgdbm-dev_1.8.3-13.1_amd64.deb
Source Package gdbm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgdbm-dev deb package:
    # sudo apt-get install libgdbm-dev

Files

Path
/usr/include/dbm.h
/usr/include/gdbm-ndbm.h
/usr/include/gdbm.h
/usr/lib/x86_64-linux-gnu/libgdbm.a
/usr/lib/x86_64-linux-gnu/libgdbm.so
/usr/lib/x86_64-linux-gnu/libgdbm_compat.a
/usr/lib/x86_64-linux-gnu/libgdbm_compat.so
/usr/share/doc/libgdbm-dev/NEWS.gz
/usr/share/doc/libgdbm-dev/README.gz
/usr/share/doc/libgdbm-dev/changelog.Debian.gz
/usr/share/doc/libgdbm-dev/copyright
/usr/share/info/gdbm.info.gz
/usr/share/man/man3/dbm.3.gz
/usr/share/man/man3/dbm_clearerr.3.gz
/usr/share/man/man3/dbm_close.3.gz
/usr/share/man/man3/dbm_delete.3.gz
/usr/share/man/man3/dbm_dirfno.3.gz
/usr/share/man/man3/dbm_error.3.gz
/usr/share/man/man3/dbm_fetch.3.gz
/usr/share/man/man3/dbm_firstkey.3.gz
/usr/share/man/man3/dbm_nextkey.3.gz
/usr/share/man/man3/dbm_open.3.gz
/usr/share/man/man3/dbm_pagfno.3.gz
/usr/share/man/man3/dbm_rdonly.3.gz
/usr/share/man/man3/dbm_store.3.gz
/usr/share/man/man3/dbmclose.3.gz
/usr/share/man/man3/dbminit.3.gz
/usr/share/man/man3/delete.3.gz
/usr/share/man/man3/fetch.3.gz
/usr/share/man/man3/firstkey.3.gz
/usr/share/man/man3/gdbm.3.gz
/usr/share/man/man3/gdbm_close.3.gz
/usr/share/man/man3/gdbm_delete.3.gz
/usr/share/man/man3/gdbm_errno.3.gz
/usr/share/man/man3/gdbm_error.3.gz
/usr/share/man/man3/gdbm_exists.3.gz
/usr/share/man/man3/gdbm_fetch.3.gz
/usr/share/man/man3/gdbm_firstkey.3.gz
/usr/share/man/man3/gdbm_nextkey.3.gz
/usr/share/man/man3/gdbm_open.3.gz
/usr/share/man/man3/gdbm_reorganize.3.gz
/usr/share/man/man3/gdbm_setopt.3.gz
/usr/share/man/man3/gdbm_store.3.gz
/usr/share/man/man3/gdbm_strerror.3.gz
/usr/share/man/man3/gdbm_sync.3.gz
/usr/share/man/man3/nextkey.3.gz
/usr/share/man/man3/store.3.gz

Changelog

2014-11-16 - Julien Cristau <jcristau@debian.org>
gdbm (1.8.3-13.1) unstable; urgency=medium
* Non-maintainer upload.
* Use dh_installchangelogs (closes: #752465).
2014-07-17 - Anibal Monsalve Salazar <anibal@debian.org>
gdbm (1.8.3-13) unstable; urgency=high
[ Helmut Grohne ]
* Source upload. Closes: #752465
* Move documentation from libgdbm3 to libgdbm-dev to comply with policy 8.2.
Closes: #752830
[ Anibal Monsalve Salazar ]
* Bootstrap without texinfo.
Patch by Daniel Schepler.
Closes: #737943.
* Standards Version is 3.9.5.
* Remove debian/source/options.
* Refresh patches.
2013-06-02 - Anibal Monsalve Salazar <anibal@debian.org>
gdbm (1.8.3-12) unstable; urgency=low
* Fix texinfo errors
Add 08-709905-gdbm.texinfo.patch
Closes: #709905
* libtool is invoked with --mode=install
Update 04_fix-gdbm-compat-linking.patch
Patch by Igor Pashev
Closes: #651521
* Standards Version is 3.9.4
[ Wookey ]
* Fix crossbuild to use correct strip binary 
Closes: #604648
2012-06-10 - Anibal Monsalve Salazar <anibal@debian.org>
gdbm (1.8.3-11) unstable; urgency=low
* Debian source format is 3.0 (quilt)
* Standards version is 3.9.3
* Use hardening options
Closes: #657040
* Fix debian-rules-missing-recommended-target
2011-07-01 - Anibal Monsalve Salazar <anibal@debian.org>
gdbm (1.8.3-10) unstable; urgency=low
* Use multiarch library paths
Patch by Steve Langasek
Closes: 632295
* Set SHELL variable in Makefile.in to @SHELL@
Add debian/patches/03-Makefile.in.patch
Closes: 621934
* Fix out-of-date-standards-version
* Fix non-empty-dependency_libs-in-la-file
2009-11-21 - Anibal Monsalve Salazar <anibal@debian.org>
gdbm (1.8.3-9) unstable; urgency=low
* Update upstream homepage address
* Avoid entering an infinite loop reading a file
Patch by Sandro Serafini
Closes: 511250
2009-11-07 - Anibal Monsalve Salazar <anibal@debian.org>
gdbm (1.8.3-8) unstable; urgency=low
* Build depend on quilt 
2009-10-12 - Anibal Monsalve Salazar <anibal@debian.org>
gdbm (1.8.3-7) unstable; urgency=low
[ Sylvain Beucler <beuc@beuc.net> ]
* Non-maintainer upload.
* Replace obsoleted automake1.4 with automake; gdbm does not use
'automake' itself but uses 'aclocal' which is provided by that package
Closes: 549099 
* Fix patch-system-but-no-source-readme: add README.source refering to
/usr/share/doc/dpatch/README.source.gz
* Fix debian-rules-ignores-make-clean-error: test for Makefile presence
* Fix package-contains-empty-directory: drop empty usr/share/info/ from
libgdbm-dev
* Fix no-md5sums-control-file: manually generate md5sums control file
using code from dh_md5sums
* Fix install-info-used-in-maintainer-script: remove postinst.dev and
prerm.dev, and depends on 'dpkg (>= 1.15.4) | install-info'
* Fix no-symbols-control-file: import base symbols file from
http://qa.debian.org/cgi-bin/mole/seedsymbols/?pkgname=libgdbm3 to
'debian/symbols' and drop Debian version number. Keep private _gdbm
symbols pending discussion with upstream about declaring them
'static', but tag them 'optional'.
[ Anibal Monsalve Salazar ]
* Fix: gdbm source: out-of-date-standards-version
* Fix: libgdbm3: no-upstream-changelog
2009-07-09 - Anibal Monsalve Salazar <anibal@debian.org>
gdbm (1.8.3-6) unstable; urgency=low
* Remove gdbm.3.gz gdbm.info from libgdbm-dev. Closes: 536356
2009-07-09 - Anibal Monsalve Salazar <anibal@debian.org>
gdbm (1.8.3-5) unstable; urgency=low
* Update libtool, config.{sub,guess}. Closes: 528216
Drop 03_autoreconf.dpatch
* Fix out-of-date-standards-version
* Fix copyright-refers-to-symlink-license
* Fix info-document-not-compressed
* Fix manpage-not-compressed
* Fix manpage-section-mismatch

See Also

Package Description
libgdbm3_1.8.3-13.1_amd64.deb GNU dbm database routines (runtime version)
libgdiplus_4.2-1ubuntu1_amd64.deb interface library for System.Drawing of Mono
libgdk-pixbuf2.0-0_2.32.2-1ubuntu1_amd64.deb GDK Pixbuf library
libgdk-pixbuf2.0-common_2.32.2-1ubuntu1_all.deb GDK Pixbuf library - data files
libgdk-pixbuf2.0-dev_2.32.2-1ubuntu1_amd64.deb GDK Pixbuf library (development files)
libgdk-pixbuf2.0-doc_2.32.2-1ubuntu1_all.deb GDK Pixbuf library (documentation)
libgee-0.8-2_0.18.0-1_amd64.deb GObject based collection and utility library
libgee-0.8-dev_0.18.0-1_amd64.deb GObject based collection and utility library (development files)
libgeis-dev_2.2.17+16.04.20160126-0ubuntu1_amd64.deb Gesture engine interface support - dev files
libgeis-doc_2.2.17+16.04.20160126-0ubuntu1_all.deb Gesture engine interface support - documentation
libgeis1_2.2.17+16.04.20160126-0ubuntu1_amd64.deb Gesture engine interface support
libgeoclue-dev_0.12.99-4ubuntu1_amd64.deb C API for GeoClue (development files)
libgeoclue0_0.12.99-4ubuntu1_amd64.deb C API for GeoClue
libgeocode-glib-dev_3.18.2-1_amd64.deb development files for geocode-glib library
libgeocode-glib-doc_3.18.2-1_all.deb gtk-doc documentation for geocode-glib library
Advertisement
Advertisement