libgd-dev_2.1.1-4build2_amd64.deb


Advertisement

Description

libgd-dev - GD Graphics Library (development version)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libgd-dev_2.1.1-4build2_amd64.deb
Package name libgd-dev
Package version 2.1.1
Package release 4build2
Package architecture amd64
Package type deb
Category libdevel
Homepage http://www.libgd.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 249.40 KB
Installed size 847.00 KB
GD is a graphics library. It allows your code to quickly draw images
complete with lines, arcs, text, multiple colours, cut and paste from
other images, flood fills, and write out the result as a PNG file.
This is particularly useful in World Wide Web applications, where PNG is
one of the formats accepted for inline images by most browsers.
This is the full development version of the library.

Alternatives

Package Version Architecture Repository
libgd-dev_2.1.1-4ubuntu0.16.04.11_i386.deb 2.1.1 i386 Ubuntu Updates Main
libgd-dev_2.1.1-4ubuntu0.16.04.11_amd64.deb 2.1.1 amd64 Ubuntu Updates Main
libgd-dev_2.1.1-4build2_i386.deb 2.1.1 i386 Ubuntu Main
libgd-dev - - -

Requires

Name Value
libfontconfig-dev -
libfreetype6-dev -
libgd3 = 2.1.1-4build2
libjpeg-dev -
libpng-dev -
libtiff-dev -
libvpx-dev -
libx11-dev -
libxpm-dev -
libxt-dev -
libz-dev -

Provides

Name Value
libgd2-dev -
libgd2-noxpm-dev -
libgd2-xpm-dev -

Replaces

Name Value
libgd2-dev << 2.1.0~alpha1-2~
libgd2-noxpm-dev << 2.1.0~
libgd2-xpm-dev << 2.1.0~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgd-dev_2.1.1-4build2_amd64.deb
Source Package libgd2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgd-dev deb package:
    # sudo apt-get install libgd-dev

Files

Path
/usr/bin/gdlib-config
/usr/include/entities.h
/usr/include/gd.h
/usr/include/gd_color_map.h
/usr/include/gd_errors.h
/usr/include/gd_io.h
/usr/include/gdcache.h
/usr/include/gdfontg.h
/usr/include/gdfontl.h
/usr/include/gdfontmb.h
/usr/include/gdfonts.h
/usr/include/gdfontt.h
/usr/include/gdfx.h
/usr/include/gdpp.h
/usr/lib/x86_64-linux-gnu/libgd.a
/usr/lib/x86_64-linux-gnu/libgd.so
/usr/lib/x86_64-linux-gnu/pkgconfig/gdlib.pc
/usr/share/doc/libgd-dev/changelog.Debian.gz
/usr/share/doc/libgd-dev/copyright
/usr/share/doc/libgd-dev/examples/demoin.png
/usr/share/doc/libgd-dev/examples/gd2time.c
/usr/share/doc/libgd-dev/examples/gddemo.c.gz
/usr/share/doc/libgd-dev/examples/gdtest.c.gz
/usr/share/doc/libgd-dev/examples/gdtest.gd2.gz
/usr/share/doc/libgd-dev/examples/gdtest.png
/usr/share/doc/libgd-dev/examples/gdtest_200_300_150_100.png
/usr/share/doc/libgd-dev/examples/gdtest_merge.png
/usr/share/doc/libgd-dev/examples/gdtest_wbmp_to_png.png
/usr/share/doc/libgd-dev/examples/gdtestft.c.gz
/usr/share/doc/libgd-dev/examples/testac.c.gz
/usr/share/man/man1/gdlib-config.1.gz

Changelog

2016-01-07 - Colin Watson <cjwatson@ubuntu.com>
libgd2 (2.1.1-4build2) xenial; urgency=medium
* Rebuild against libvpx3.
2015-07-24 - Iain Lane <iain@orangesquash.org.uk>
libgd2 (2.1.1-4build1) wily; urgency=medium
* No-change rebuild against new libvpx
2015-07-07 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.1.1-4) unstable; urgency=medium
* Fix xmp vs xpm typo in Provides (Closes: #791435)
2015-07-07 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.1.1-3) unstable; urgency=medium
* Add libgd-{no,}xmp-dev to libgd-dev Provides to fix FTBFS in packages
still depending on old name (Closes: #791435).  Thanks Mattia Rizzolo
for catching this early.
2015-06-29 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.1.1-2) unstable; urgency=medium
* Drop libgd2-{xpm,noxmp}-dev dummy packages
2015-05-19 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.1.1-1) unstable; urgency=medium
[ Sebastian Ramacher ]
* Fix build against libvpx 1.4 (Closes: #785403)
[ Mario Lang ]
* Fix Vcs-* URL in debian/control.
[ Ondřej Surý ]
* New upstream version 2.1.1
* Update patches for GD 2.1.1 release
2014-12-18 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.1.0-5) unstable; urgency=high
* Remove seanius from Uploaders.  So Long, and Thanks for All the Fish.
(Closes: #773439)
* Fix buffer overflow found by Jan Bee and fixed by Remi Collet
2014-09-28 - Andreas Barth <aba@ayous.org>
libgd2 (2.1.0-4.1) unstable; urgency=medium
* Non-maintainer upload.
* Make package binNMU-safe by converting empty transitional packages
to arch=any. (Closes: #762325)
2014-08-04 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.1.0-4) unstable; urgency=medium
* [CVE-2014-2497]: NULL pointer dereference
2013-09-30 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.1.0-3) unstable; urgency=low
* Enable subdir-objects in AC_INIT_AUTOMAKE (Closes: #724841)

See Also

Package Description
libgd-graph-perl_1.48-2_all.deb Graph Plotting Module for Perl 5
libgd-perl_2.53-2.1_amd64.deb Perl module wrapper for libgd
libgd-text-perl_0.86-9_all.deb Text utilities for use with GD
libgd3_2.1.1-4build2_amd64.deb GD Graphics Library
libgdata-common_0.17.4-1_all.deb Library for accessing GData webservices - common data files
libgdata-dev_0.17.4-1_amd64.deb Library for accessing GData webservices - development files
libgdata-doc_0.17.4-1_all.deb Library for accessing GData webservices - documentation
libgdata22_0.17.4-1_amd64.deb Library for accessing GData webservices - shared libraries
libgdbm-dev_1.8.3-13.1_amd64.deb GNU dbm database routines (development files)
libgdbm3_1.8.3-13.1_amd64.deb GNU dbm database routines (runtime version)
libgdiplus_4.2-1ubuntu1_amd64.deb interface library for System.Drawing of Mono
libgdk-pixbuf2.0-0_2.32.2-1ubuntu1_amd64.deb GDK Pixbuf library
libgdk-pixbuf2.0-common_2.32.2-1ubuntu1_all.deb GDK Pixbuf library - data files
libgdk-pixbuf2.0-dev_2.32.2-1ubuntu1_amd64.deb GDK Pixbuf library (development files)
libgdk-pixbuf2.0-doc_2.32.2-1ubuntu1_all.deb GDK Pixbuf library (documentation)
Advertisement
Advertisement