libgcrypt20_1.6.5-2_amd64.deb


Advertisement

Description

libgcrypt20 - LGPL Crypto library - runtime library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libgcrypt20_1.6.5-2_amd64.deb
Package name libgcrypt20
Package version 1.6.5
Package release 2
Package architecture amd64
Package type deb
Category libs
Homepage http://directory.fsf.org/project/libgcrypt/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 329.70 KB
Installed size 967.00 KB
libgcrypt contains cryptographic functions.  Many important free
ciphers, hash algorithms and public key signing algorithms have been
implemented:
Arcfour, Blowfish, CAST5, DES, AES, Twofish, Serpent, rfc2268 (rc2), SEED,
Camellia, IDEA, Salsa, CRC, MD4, MD5, RIPE-MD160, SHA-1, SHA-256, SHA-512,
Tiger, Whirlpool, DSA, DSA2, ElGamal, RSA, ECC.

Alternatives

Package Version Architecture Repository
libgcrypt20_1.6.5-2ubuntu0.5_i386.deb 1.6.5 i386 Ubuntu Updates Main
libgcrypt20_1.6.5-2ubuntu0.5_amd64.deb 1.6.5 amd64 Ubuntu Updates Main
libgcrypt20_1.6.5-2_i386.deb 1.6.5 i386 Ubuntu Main
libgcrypt20 - - -

Requires

Name Value
libc6 >= 2.15
libgpg-error0 >= 1.14

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgcrypt20_1.6.5-2_amd64.deb
Source Package libgcrypt20

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgcrypt20 deb package:
    # sudo apt-get install libgcrypt20

Files

Path
/lib/x86_64-linux-gnu/libgcrypt.so.20
/lib/x86_64-linux-gnu/libgcrypt.so.20.0.5
/usr/share/doc/libgcrypt20/AUTHORS.gz
/usr/share/doc/libgcrypt20/NEWS.gz
/usr/share/doc/libgcrypt20/README.gz
/usr/share/doc/libgcrypt20/THANKS.gz
/usr/share/doc/libgcrypt20/changelog.Debian.gz
/usr/share/doc/libgcrypt20/copyright

Changelog

2016-02-10 - Andreas Metzler <ametzler@debian.org>
libgcrypt20 (1.6.5-2) unstable; urgency=medium
* serial-tests was added in automake 1.12, add versioned b-d.
* Upload to unstable.
2016-02-09 - Andreas Metzler <ametzler@debian.org>
libgcrypt20 (1.6.5-1) experimental; urgency=medium
* New upstream bugfix release.
+ Mitigate side-channel attack on ECDH with Weierstrass curves
[CVE-2015-7511].  See http://www.cs.tau.ac.IL/~tromer/ecdh/ for
details.
2016-01-24 - Andreas Metzler <ametzler@debian.org>
libgcrypt20 (1.6.4-5) unstable; urgency=medium
* Move Vcs-* from git/http to https.
* Add 30_support_source_date_epoch.diff: Support setting BUILD_TIMESTAMP
using SOURCE_DATE_EPOCH through the SOURCE_DATE_EPOCH environment
variable. (Thanks, Jérémy Bobbio!). Use/b-d on dh-autoreconf instead of
autotools-dev. Closes: #812428
2015-12-25 - Andreas Metzler <ametzler@debian.org>
libgcrypt20 (1.6.4-4) unstable; urgency=medium
* Delete build-aux/texinfo.tex and let texinfo use the system copy instead
to prevent breakage in pdf generation in UTF-8 locale. Closes: #803081
* Migrate from libgcrypt20-dbg to ddebs. dh_strip's --ddeb-migration
option was added to debhelper/unstable with version 9.20150628, bump
build-dependency accordingly.
2015-10-18 - Andreas Metzler <ametzler@debian.org>
libgcrypt20 (1.6.4-3) unstable; urgency=medium
* Upload to unstable.
* Ship pdf instead of postscript docs.
2015-10-03 - Andreas Metzler <ametzler@debian.org>
libgcrypt20 (1.6.4-2) experimental; urgency=medium
* Pull 20_fedora_libgcrypt-1.6.3-aliasing.patch from Fedora to fix testsuite
error with gcc5 on ppc64.
2015-09-26 - Andreas Metzler <ametzler@debian.org>
libgcrypt20 (1.6.4-1) experimental; urgency=medium
* libgcrypt-config: Do not fail on missing dpkg-architecture.
Closes: #796818
* New upstream version.
2015-03-01 - Andreas Metzler <ametzler@debian.org>
libgcrypt20 (1.6.3-2) unstable; urgency=medium
* Upload to unstable.
* Fix Vcs-Browser link.
2015-02-28 - Andreas Metzler <ametzler@debian.org>
libgcrypt20 (1.6.3-1) experimental; urgency=medium
* Use ascii-armored debian/upstream/signing-key.asc instead of
debian/upstream-signing-key.pgp for uscan's verification. This alllows us
to drop debian/source/include-binaries. Add 2071B08A33BD3F06 as accepted
key.
* New upstream release.
+ Use ciphertext blinding for Elgamal decryption [CVE-2014-3591].
See http://www.cs.tau.ac.il/~tromer/radioexp/ for details.
+ Fixed data-dependent timing variations in modular exponentiation
[related to CVE-2015-0837, Last-Level Cache Side-Channel Attacks
are Practical].
2014-09-27 - Andreas Metzler <ametzler@debian.org>
libgcrypt20 (1.6.2-4) unstable; urgency=medium
* Add libgcrypt11-dev transitional package. It Breaks libgnutls-dev
(<< 2.12.23-18), because addition of a dummy package does not magically
fix GnuTLS 2.x incompatibilities with libgcrypt20.

See Also

Package Description
libgd-dev_2.1.1-4build2_amd64.deb GD Graphics Library (development version)
libgd-graph-perl_1.48-2_all.deb Graph Plotting Module for Perl 5
libgd-perl_2.53-2.1_amd64.deb Perl module wrapper for libgd
libgd-text-perl_0.86-9_all.deb Text utilities for use with GD
libgd3_2.1.1-4build2_amd64.deb GD Graphics Library
libgdata-common_0.17.4-1_all.deb Library for accessing GData webservices - common data files
libgdata-dev_0.17.4-1_amd64.deb Library for accessing GData webservices - development files
libgdata-doc_0.17.4-1_all.deb Library for accessing GData webservices - documentation
libgdata22_0.17.4-1_amd64.deb Library for accessing GData webservices - shared libraries
libgdbm-dev_1.8.3-13.1_amd64.deb GNU dbm database routines (development files)
libgdbm3_1.8.3-13.1_amd64.deb GNU dbm database routines (runtime version)
libgdiplus_4.2-1ubuntu1_amd64.deb interface library for System.Drawing of Mono
libgdk-pixbuf2.0-0_2.32.2-1ubuntu1_amd64.deb GDK Pixbuf library
libgdk-pixbuf2.0-common_2.32.2-1ubuntu1_all.deb GDK Pixbuf library - data files
libgdk-pixbuf2.0-dev_2.32.2-1ubuntu1_amd64.deb GDK Pixbuf library (development files)
Advertisement
Advertisement