libgail-3-dev_3.18.9-1ubuntu3_amd64.deb


Advertisement

Description

libgail-3-dev - GNOME Accessibility Implementation Library -- development files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libgail-3-dev_3.18.9-1ubuntu3_amd64.deb
Package name libgail-3-dev
Package version 3.18.9
Package release 1ubuntu3
Package architecture amd64
Package type deb
Category libdevel
Homepage http://www.gtk.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 12.72 KB
Installed size 135.00 KB
Gail implements ATK interfaces for GTK+ widgets which are dynamically
loadable at runtime by a GTK+ application. Once loaded, those parts of
an application that use standard GTK+ widgets will have a basic level
of accessibility, without the need to modify the application at all.
This package contains the development files for Gail.

Alternatives

Package Version Architecture Repository
libgail-3-dev_3.18.9-1ubuntu3.3_amd64.deb 3.18.9 amd64 Ubuntu Updates Main
libgail-3-dev_3.18.9-1ubuntu3.3_i386.deb 3.18.9 i386 Ubuntu Updates Main
libgail-3-dev_3.18.9-1ubuntu3_i386.deb 3.18.9 i386 Ubuntu Main
libgail-3-dev - - -

Requires

Name Value
libatk1.0-dev >= 2.2.0
libgail-3-0 = 3.18.9-1ubuntu3
libgtk-3-dev = 3.18.9-1ubuntu3
pkg-config -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgail-3-dev_3.18.9-1ubuntu3_amd64.deb
Source Package gtk+3.0

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgail-3-dev deb package:
    # sudo apt-get install libgail-3-dev

Files

Path
/usr/include/gail-3.0/libgail-util/gail-util.h
/usr/include/gail-3.0/libgail-util/gailmisc.h
/usr/include/gail-3.0/libgail-util/gailtextutil.h
/usr/lib/x86_64-linux-gnu/libgailutil-3.so
/usr/lib/x86_64-linux-gnu/pkgconfig/gail-3.0.pc
/usr/share/doc/libgail-3-dev/AUTHORS
/usr/share/doc/libgail-3-dev/changelog.Debian.gz
/usr/share/doc/libgail-3-dev/copyright

Changelog

2016-03-24 - Iain Lane <iain.lane@canonical.com>
gtk+3.0 (3.18.9-1ubuntu3) xenial; urgency=medium
* Merge branch from Marco Trevisan to hide buttons in headerbar apps when
they are maximised under Unity, and to fix the gradient to look good.
2016-03-15 - Marco Trevisan (Treviño) <marco@ubuntu.com>
gtk+3.0 (3.18.9-1ubuntu2) xenial; urgency=medium
* debian/patches/unity-border-radius.patch:
- Export windows corners radius as an X11 property in unity (LP: #1516403)
* debian/patches/unity_rbga_tooltips.patch:
- Removed as it's now included in the border-radius patch
2016-03-14 - Iain Lane <iain.lane@canonical.com>
gtk+3.0 (3.18.9-1ubuntu1) xenial; urgency=low
* Merge with Debian. Remaining changes:
+ Install the settings.ini file to set our themes.
+ Enable parallel builds
+ Ubuntu specific patches:
- 073_treeview_almost_fixed.patch
- 074_eventbox_scroll_mask.patch
- bzg_gtkcellrenderer_grabbing_modifier.patch
- ubuntu_gtk_custom_menu_items.patch
- print-dialog-show-options-of-remote-dnssd-printers.patch
- uimanager-guard-against-nested-node-updates.patch
- x-canonical-accel.patch
- message-dialog-restore-traditional-look-on-unity.patch
- 0001-gtk-reftest-Force-icon-theme-to-Adwaita.patch
- restore_filechooser_typeaheadfind
- 0001-calendar-always-emit-day-selected-once.patch
- git_icon_fallback.patch
- unity_rgba_tooltips.patch
- git-refresh-mir-backend.patch
- 0001-gtkwindow-set-transparent-background-color.patch
- ubuntu_fileselector_behaviour
- git-x11-don-t-apply-scaling-factor-twice.patch
+ Add Breaks on gnome-shell << 3.16 - this needs to be updated at the same
time.
+ Add Breaks on old overlay-scrollbar versions which still provided the gtk3
module - we don't want to use this any more with GTK 3.16.
+ Install a gsettings override to start filechoosers in the cwd
* Should fix missing focus event bug affecting gnome-terminal (LP: #890784)
2016-03-12 - Michael Biebl <biebl@debian.org>
gtk+3.0 (3.18.9-1) unstable; urgency=medium
[ Michael Biebl ]
* New upstream release.
* Bump Standards-Version to 3.9.7.
[ Uwe Kleine-König ]
* Remove debian/{build,install} in clean target. (Closes: #792736)
2016-03-10 - Robert Ancell <robert.ancell@canonical.com>
gtk+3.0 (3.18.8-1ubuntu2) xenial; urgency=medium
* debian/patches/message-dialog-restore-traditional-look-on-unity.patch:
* debian/patches/unity_rbga_tooltips.patch:
- Correctly handle XDG_CURRENT_DESKTOP (LP: #1554878)
2016-02-25 - Iain Lane <iain.lane@canonical.com>
gtk+3.0 (3.18.8-1ubuntu1) xenial; urgency=medium
* Merge with Debian. Remaining changes:
+ Install the settings.ini file to set our themes.
+ Enable parallel builds
+ Ubuntu specific patches:
- 073_treeview_almost_fixed.patch
- 074_eventbox_scroll_mask.patch
- bzg_gtkcellrenderer_grabbing_modifier.patch
- ubuntu_gtk_custom_menu_items.patch
- print-dialog-show-options-of-remote-dnssd-printers.patch
- uimanager-guard-against-nested-node-updates.patch
- x-canonical-accel.patch
- message-dialog-restore-traditional-look-on-unity.patch
- 0001-gtk-reftest-Force-icon-theme-to-Adwaita.patch
- restore_filechooser_typeaheadfind
- 0001-calendar-always-emit-day-selected-once.patch
- git_icon_fallback.patch
- unity_rgba_tooltips.patch
- git-refresh-mir-backend.patch
- 0001-gtkwindow-set-transparent-background-color.patch
- ubuntu_fileselector_behaviour
- git-x11-don-t-apply-scaling-factor-twice.patch
+ Add Breaks on gnome-shell << 3.16 - this needs to be updated at the same
time.
+ Add Breaks on old overlay-scrollbar versions which still provided the gtk3
module - we don't want to use this any more with GTK 3.16.
+ Install a gsettings override to start filechoosers in the cwd
* Drop dep on libnettle-dev, no longer needed with current Mir.

See Also

Package Description
libgail-3-doc_3.18.9-1ubuntu3_all.deb documentation files of the Gail library
libgail-common_2.24.30-1ubuntu1_amd64.deb GNOME Accessibility Implementation Library -- common modules
libgail-dev_2.24.30-1ubuntu1_amd64.deb GNOME Accessibility Implementation Library -- development files
libgail-doc_2.24.30-1ubuntu1_all.deb documentation files of the Gail library
libgail18_2.24.30-1ubuntu1_amd64.deb GNOME Accessibility Implementation Library -- shared libraries
libgbm-dev-lts-utopic_10_amd64.deb Transitional package for libgbm-dev-lts-utopic
libgbm-dev-lts-vivid_10_amd64.deb Transitional package for libgbm-dev-lts-vivid
libgbm-dev-lts-wily_10_amd64.deb Transitional package for libgbm-dev-lts-wily
libgbm-dev_11.2.0-1ubuntu2_amd64.deb generic buffer management API -- development files
libgbm1-lts-utopic_10_amd64.deb Transitional package for libgbm1-lts-utopic
libgbm1-lts-vivid_10_amd64.deb Transitional package for libgbm1-lts-vivid
libgbm1-lts-wily_10_amd64.deb Transitional package for libgbm1-lts-wily
libgbm1_11.2.0-1ubuntu2_amd64.deb generic buffer management API -- runtime
libgc-dev_7.4.2-7.3_amd64.deb conservative garbage collector for C (development)
libgc1c2_7.4.2-7.3_amd64.deb conservative garbage collector for C and C++
Advertisement
Advertisement