libexiv2-14_0.25-2.1_amd64.deb


Advertisement

Description

libexiv2-14 - EXIF/IPTC metadata manipulation library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libexiv2-14_0.25-2.1_amd64.deb
Package name libexiv2-14
Package version 0.25
Package release 2.1
Package architecture amd64
Package type deb
Category libs
Homepage http://www.exiv2.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 657.88 KB
Installed size 2.61 MB
Exiv2 is a C++ library and a command line utility to manage image metadata.
It provides fast and easy read and write access to the Exif, IPTC and XMP
metadata of images in various formats
Exiv2 library provides:
* fast read and write access to the Exif, IPTC, and XMP metadata of an image
* an easy to use and extensively documented API
* conversions of Exif and IPTC metadata to XMP and vice versa
* a smart IPTC implementation that does not affect data that programs like
Photoshop store in the same image segment
* Exif Makernote support:
- Makernote tags can be read and written just like any other metadata
- a sophisticated write algorithm avoids corrupting the Makernote
* a simple interface to extract previews embedded in RAW images and Exif
thumbnails
* set and delete methods for Exif thumbnails

Alternatives

Package Version Architecture Repository
libexiv2-14_0.25-2.1ubuntu16.04.5_amd64.deb 0.25 amd64 Ubuntu Updates Main
libexiv2-14_0.25-2.1ubuntu16.04.5_i386.deb 0.25 i386 Ubuntu Updates Main
libexiv2-14_0.25-2.1_i386.deb 0.25 i386 Ubuntu Main
libexiv2-14 - - -

Requires

Name Value
libc6 >= 2.14
libexpat1 >= 2.0.1
libgcc1 >= 1:4.1.1
libstdc++6 >= 5.2
zlib1g >= 1:1.1.4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libexiv2-14_0.25-2.1_amd64.deb
Source Package exiv2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libexiv2-14 deb package:
    # sudo apt-get install libexiv2-14

Files

Path
/usr/lib/x86_64-linux-gnu/libexiv2.so.14
/usr/lib/x86_64-linux-gnu/libexiv2.so.14.0.0
/usr/share/doc/libexiv2-14/changelog.Debian.gz
/usr/share/doc/libexiv2-14/copyright

Changelog

2015-10-08 - YunQiang Su <syq@debian.org>
exiv2 (0.25-2.1) unstable; urgency=medium
* Non-maintainer upload
* Fix symbol files for amd64/mips64el/sparc64/sh4 (Closes: #799611).
2015-08-06 - Maximiliano Curia <maxy@debian.org>
exiv2 (0.25-2) unstable; urgency=medium
* Update symbols files from buildds logs (0.25-1) (Closes: #794728) Thanks
to Aaron M. Ucko.
* Update symbols files.
2015-08-05 - Maximiliano Curia <maxy@debian.org>
exiv2 (0.25-1) unstable; urgency=medium
[ Pino Toscano ]
* libexiv2-dev: stop again depending on pkg-config, as this is no more
needed now (for real this time).
[ Maximiliano Curia ]
* New upstream release (0.25). (Closes: #789956)
* Refresh patch: libtool_update.diff
* Remove upstream applied patch: CVE-2014-9449.patch
* Bump Standards-Version to 3.9.6, no changes needed.
* Update copyright information.
2015-01-07 - Salvatore Bonaccorso <carnil@debian.org>
exiv2 (0.24-4.1) unstable; urgency=medium
* Non-maintainer upload.
* Add CVE-2014-9449.patch patch.
CVE-2014-9449: buffer overflow in RiffVideo::infoTagsHandler
Thanks to Klaus Ethgen <Klaus@Ethgen.de> (Closes: #773846)
2014-09-05 - Pino Toscano <pino@debian.org>
exiv2 (0.24-4) unstable; urgency=medium
* Team upload.
* Upload to unstable. (See #732957)
* Re-add the pkg-config dependency in libexiv2-dev, as there is still one
source relying on it.
2014-08-28 - Pino Toscano <pino@debian.org>
exiv2 (0.24-3) experimental; urgency=medium
* Team upload.
* Integrate 0.23-1.1 NMU (thanks Wookey).
* Move the libjs-jquery, doxygen, graphviz build dependencies as
Build-Depend-Indep, as they are needed in indep-build only.
* Update libtool files for ppc64el. (Closes: #757412)
2014-01-17 - Pino Toscano <pino@debian.org>
exiv2 (0.24-2) experimental; urgency=low
* Team upload.
* Update Vcs-* headers.
* Fix the replacement of the doxygen-generated jquery.js with a symlink to
the system copy:
- properly replace any version with a symlink
- remove usage of dh-linktree: drop libexiv2-doc.linktrees and the
dh-linktree build dependency
- make libexiv2-doc depend on libjs-jquery
* Improve the .install files:
- use exiv2.install to install the exiv2.1 man page
- make them a bit more explicit
- remove the "debian/tmp/" prefix from the installed files
- sort them
* Remove the libtool .la file instead of installing it; dependencies have to
be rebuilt for the SONAME bump anyway, so there is no risk for breakages.
* Remove the doxygen-generated *.map and *.md5 files from the -doc package.
* Add a lintian override in libexiv2-doc for the duplicated files
(image graphs, basically) generated by doxygen.
* Bump to the debhelper compatibility 9:
- bump compat to 9
- bump the debhelper build dependency to >= 9~
- stop manually specifying the build flags, they are handled automatically
- adjust the library paths in .install files and rules to the multiarch
paths
- add Pre-Depends: ${misc:Pre-Depends} in libexiv2-13
* Mark libexiv2-13 and libexiv2-dbg as Multi-Arch: same.
* Tighten the exiv2 dependency on the same version of the libexiv2 library.
* Remove the extra "samples" subdirectory for the examples in libexiv2-dev.
* Bump Standards-Version to 3.9.5, no changes required.
* Do not compress .cpp files (found in examples).
* libexiv2-dev: stop depending on pkg-config, as this is no more needed now.

See Also

Package Description
libexiv2-dev_0.25-2.1_amd64.deb EXIF/IPTC metadata manipulation library - development files
libexiv2-doc_0.25-2.1_all.deb EXIF/IPTC metadata manipulation library - HTML documentation
libexpat1-dev_2.1.0-7_amd64.deb XML parsing C library - development kit
libexpat1_2.1.0-7_amd64.deb XML parsing C library - runtime library
libexporter-tiny-perl_0.042-1_all.deb tiny exporter similar to Sub::Exporter
libexttextcat-2.0-0_3.4.4-1ubuntu3_amd64.deb Language detection library
libexttextcat-data_3.4.4-1ubuntu3_all.deb Language detection library - data files
libexttextcat-dev_3.4.4-1ubuntu3_amd64.deb Language detection library - development files
libfakeroot_1.20.2-1ubuntu1_amd64.deb tool for simulating superuser privileges - shared libraries
libfcgi-dev_2.4.0-8.3_amd64.deb Header files of FastCGI
libfcgi-perl_0.77-1build1_amd64.deb helper module for FastCGI
libfcgi0ldbl_2.4.0-8.3_amd64.deb Shared library of FastCGI
libfcitx-config4_4.2.9.1-1ubuntu1_amd64.deb Flexible Input Method Framework - configuration support library
libfcitx-core0_4.2.9.1-1ubuntu1_amd64.deb Flexible Input Method Framework - library of core funtions
libfcitx-gclient0_4.2.9.1-1ubuntu1_amd64.deb Flexible Input Method Framework - D-Bus client library for Glib
Advertisement
Advertisement