libemail-valid-perl_1.198-1_all.deb


Advertisement

Description

libemail-valid-perl - Perl module for checking the validity of Internet email addresses

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libemail-valid-perl_1.198-1_all.deb
Package name libemail-valid-perl
Package version 1.198
Package release 1
Package architecture all
Package type deb
Category perl
Homepage https://metacpan.org/release/Email-Valid
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 16.13 KB
Installed size 56.00 KB
Email::Valid determines whether an email address is well-formed, and
optionally, whether a mail host exists for the domain.

Alternatives

Package Version Architecture Repository
libemail-valid-perl_1.198-1_all.deb 1.198 all Ubuntu Main
libemail-valid-perl - - -

Requires

Name Value
libmailtools-perl -
libnet-dns-perl -
libnet-domain-tld-perl -
netbase -
perl -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libemail-valid-perl_1.198-1_all.deb
Source Package libemail-valid-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libemail-valid-perl deb package:
    # sudo apt-get install libemail-valid-perl

Files

Path
/usr/share/doc/libemail-valid-perl/changelog.Debian.gz
/usr/share/doc/libemail-valid-perl/copyright
/usr/share/doc/libemail-valid-perl/examples/valid.t.gz
/usr/share/man/man3/Email::Valid.3pm.gz
/usr/share/perl5/Email/Valid.pm

Changelog

2015-10-26 - Salvatore Bonaccorso <carnil@debian.org>
libemail-valid-perl (1.198-1) unstable; urgency=medium
* Team upload.
* Import upstream version 1.198
2015-10-17 - gregor herrmann <gregoa@debian.org>
libemail-valid-perl (1.197-1) unstable; urgency=medium
* Import upstream version 1.197.
* Bump debhelper compatibility level to 9.
* Update test_net.patch.
Skip tests unconditionally which need network access.
2015-06-26 - gregor herrmann <gregoa@debian.org>
libemail-valid-perl (1.196-1) unstable; urgency=medium
* Import upstream version 1.196.
* Update years of packaging copyright.
* Mark package as autopkgtest-able.
* Declare compliance with Debian Policy 3.9.6.
2014-09-14 - Salvatore Bonaccorso <carnil@debian.org>
libemail-valid-perl (1.195-1) unstable; urgency=medium
* Team upload.
* Update Vcs-Browser URL to cgit web frontend
* Add debian/upstream/metadata
* Imported upstream version 1.195
2014-05-29 - gregor herrmann <gregoa@debian.org>
libemail-valid-perl (1.194-1) unstable; urgency=medium
* New upstream release.
2014-05-05 - gregor herrmann <gregoa@debian.org>
libemail-valid-perl (1.193-1) unstable; urgency=medium
* Drop xz compression for {binary,source} package, set by default by
dpkg since 1.17.{0,6}.
* Strip trailing slash from metacpan URLs.
* New upstream release.
* Update years of packaging copyright.
* Drop build dependency on libcapture-tiny-perl.
* Declare compliance with Debian Policy 3.9.5.
2013-09-30 - gregor herrmann <gregoa@debian.org>
libemail-valid-perl (1.192-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* New upstream release.
* Refresh patch test_net.patch.
* Update build dependencies.
* Drop Pre-Depends on old dpkg version.
* Update years of upstream and packaging copyright.
* Declare compliance with Debian Policy 3.9.4.
2012-04-07 - gregor herrmann <gregoa@debian.org>
libemail-valid-perl (0.190-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Imported Upstream version 0.188
* Refresh test_net.patch patch
* Drop email_valid_0-187-bug75736.patch patch.
Patch was applied upstream.
[ gregor herrmann ]
* New upstream release 0.190.
* Update years of packaging copyright.
2012-03-14 - Salvatore Bonaccorso <carnil@debian.org>
libemail-valid-perl (0.187-2) unstable; urgency=low
* Team upload.
* Refresh test_net.patch patch
* Add email_valid_0-187-bug75736.patch patch.
Handle correctly valid email addresses '0@example.com'.
Thanks to Christopher Vollick <0@psycoti.ca> for the report
(Closes: #663663)
* Bump Debhelper compat level to 8.
Adjust Build-Depends on versioned debhelper to (>= 8).
* Simplify (build-)dependency on libnet-domain-tld-perl.
Make versioned (Build-)Depends(-Indep) on libnet-domain-tld-perl
unversioned, as the required version is already satisfied in oldstable.
* Update format for copyright file.
Update format to copyright-format 1.0 as released together with Debian
policy 3.9.3.
* Bump Standards-Version to 3.9.3
2012-01-28 - Ansgar Burchardt <ansgar@debian.org>
libemail-valid-perl (0.187-1) unstable; urgency=low
* Team upload.
* New upstream release.
* Use xz compression for source and binary packages.
* debian/watch: Remove comment about the watch file being an example.

See Also

Package Description
libenchant-dev_1.6.0-10.1build2_amd64.deb Wrapper library for various spell checker engines (development)
libenchant-voikko_1.6.0-10.1build2_amd64.deb Voikko spell-checker libenchant plugin
libenchant1c2a_1.6.0-10.1build2_amd64.deb Wrapper library for various spell checker engines (runtime libs)
libencode-locale-perl_1.05-1_all.deb utility to determine the locale encoding
libeot-dev_0.01-3ubuntu1_amd64.deb Library for parsing/converting Embedded OpenType files -- development
libeot0_0.01-3ubuntu1_amd64.deb Library for parsing/converting Embedded OpenType files
libepoxy-dev_1.3.1-1_amd64.deb OpenGL function pointer management library- development
libepoxy0_1.3.1-1_amd64.deb OpenGL function pointer management library
liberasurecode-dev_1.1.0-3_amd64.deb support of multiple erasure code backends - development files
liberasurecode1_1.1.0-3_amd64.deb support of multiple erasure code backends - shared library
liberror-perl_0.17-1.2_all.deb Perl module for error/exception handling in an OO-ish way
libesmtp-dev_1.0.6-4_amd64.deb LibESMTP SMTP client library (development files)
libesmtp6_1.0.6-4_amd64.deb LibESMTP SMTP client library
libespeak-dev_1.48.04+dfsg-2_amd64.deb Multi-lingual software speech synthesizer: development files
libespeak1_1.48.04+dfsg-2_amd64.deb Multi-lingual software speech synthesizer: shared library
Advertisement
Advertisement