libdconf-dev_0.24.0-2_amd64.deb


Advertisement

Description

libdconf-dev - simple configuration storage system - development files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libdconf-dev_0.24.0-2_amd64.deb
Package name libdconf-dev
Package version 0.24.0
Package release 2
Package architecture amd64
Package type deb
Category libdevel
Homepage https://wiki.gnome.org/Projects/dconf
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 4.23 KB
Installed size 96.00 KB
DConf is a low-level key/value database designed for storing desktop
environment settings.
This package contains a static library and header files.

Alternatives

Package Version Architecture Repository
libdconf-dev_0.24.0-2_i386.deb 0.24.0 i386 Ubuntu Main
libdconf-dev - - -

Requires

Name Value
libdconf1 = 0.24.0-2
libglib2.0-dev >= 2.25.7

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libdconf-dev_0.24.0-2_amd64.deb
Source Package d-conf

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libdconf-dev deb package:
    # sudo apt-get install libdconf-dev

Files

Path
/usr/include/dconf/dconf.h
/usr/include/dconf/client/dconf-client.h
/usr/include/dconf/common/dconf-changeset.h
/usr/include/dconf/common/dconf-error.h
/usr/include/dconf/common/dconf-paths.h
/usr/lib/x86_64-linux-gnu/libdconf.so
/usr/lib/x86_64-linux-gnu/pkgconfig/dconf.pc
/usr/share/doc/libdconf-dev/NEWS.Debian.gz
/usr/share/doc/libdconf-dev/NEWS.gz
/usr/share/doc/libdconf-dev/README
/usr/share/doc/libdconf-dev/changelog.Debian.gz
/usr/share/doc/libdconf-dev/copyright
/usr/share/vala/vapi/dconf.deps
/usr/share/vala/vapi/dconf.vapi

Changelog

2015-05-27 - Michael Biebl <biebl@debian.org>
d-conf (0.24.0-2) unstable; urgency=medium
* Upload to unstable.
* Drop obsolete Breaks/Replaces from pre-wheezy.
* Update Homepage: URL.
* Sort entries in debian/libdconf1.symbols.
* Point Vcs-* to the unstable branch.
* Bump Standards-Version to 3.9.6.
* Bump debhelper compatibility level to 9.
2015-04-13 - Iain Lane <laney@debian.org>
d-conf (0.24.0-1) experimental; urgency=medium
* New upstream release 0.24.0.
* This release removes dconf-editor, which has moved to a different source.
Drop the dconf-editor binary package.
2014-09-22 - Iain Lane <laney@debian.org>
d-conf (0.22.0-1) unstable; urgency=medium
[ Andreas Henriksson ]
* debian/watch: only scan for stable releases.
[ Iain Lane ]
* New upstream release
2014-09-06 - Andreas Henriksson <andreas@fatal.se>
d-conf (0.21.0-1) experimental; urgency=medium
* New upstream development release.
* Preemptively set Vcs-* urls to unstable
* debian/dconf-editor.install:
change desktop file name to ca.desrt.dconf-editor.desktop to follow
upstream change to make application was made DBus-activatable.
2014-04-26 - Josselin Mouette <joss@debian.org>
d-conf (0.20.0-2) unstable; urgency=medium
* Force strict dependency between dconf-cli and libdconf1.
2014-03-24 - Andreas Henriksson <andreas@fatal.se>
d-conf (0.20.0-1) experimental; urgency=medium
[ Jackson Doak ]
* New upstream release
* Bump valac build-depend to 0.18.0
2014-03-10 - Iain Lane <laney@debian.org>
d-conf (0.19.91-1) experimental; urgency=medium
[ Iain Lane ]
* Update Vcs-* URLs for experimental
* Run with dh_install --fail-missing
* Install the appdata file
* New upstream release 0.19.91
[ Andreas Henriksson ]
* New upstream release 0.19.90.
* Bump glib build-dependency to 2.39.1 according to configure.ac
* Update debian/patches/01_env_path.patch to apply again.
* Update debian/libdconf1.symbols with one added symbol.
2013-10-17 - Andreas Henriksson <andreas@fatal.se>
d-conf (0.18.0-1) unstable; urgency=low
* New upstream release.
* Bump build-dependency on libgtk-3-dev to >= 3.4.0
* debian/dconf-editor.install: don't install usr/share/dconf-editor
- GLib UI resources are now embedded using glib-compile-resources
2013-07-17 - Iain Lane <laney@debian.org>
d-conf (0.16.1-1) unstable; urgency=low
[ Jeremy Bicha ]
* Update homepage
[ Iain Lane ]
* New upstream release 0.16.1
+ Fix a crash when using DConfChangeset in two threads (as can happen
during normal writes to dconf).
2013-06-04 - Michael Biebl <biebl@debian.org>
d-conf (0.16.0-4) unstable; urgency=low
* In dconf 0.13.4 support for some deprecated profile specification
syntax was removed which was still in use by gdm3. Add Breaks against
unfixed versions of gdm3.

See Also

Package Description
libdconf-doc_0.24.0-2_all.deb simple configuration storage system - documentation
libdconf1_0.24.0-2_amd64.deb simple configuration storage system - runtime library
libdebconfclient0-dev_0.198ubuntu1_amd64.deb Development files for cdebconf
libdebconfclient0_0.198ubuntu1_amd64.deb Debian Configuration Management System (C-implementation library)
libdebian-dpkgcross-perl_2.6.13ubuntu1_all.deb functions to aid cross-compiling Debian packages
libdebian-installer-extra4_0.102ubuntu1_amd64.deb Library of some extra debian-installer functions
libdebian-installer4-dev_0.102ubuntu1_amd64.deb Library of common debian-installer functions
libdebian-installer4_0.102ubuntu1_amd64.deb Library of common debian-installer functions
libdecoration0-dev_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb Compiz window decoration library - development files
libdecoration0_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb Compiz window decoration library
libdee-1.0-4_1.2.7+15.04.20150304-0ubuntu2_amd64.deb model to synchronize multiple instances over DBus - shared lib
libdee-dev_1.2.7+15.04.20150304-0ubuntu2_amd64.deb model to synchronize multiple instances over DBus - dev files
libdee-doc_1.2.7+15.04.20150304-0ubuntu2_all.deb model to synchronize multiple instances over DBus - documentation
libdee-qt4-3_3.3+14.04.20140317-0ubuntu2~gcc5.1_amd64.deb Qt4 binding for Dee - shared library
libdee-qt4-dev_3.3+14.04.20140317-0ubuntu2~gcc5.1_amd64.deb Qt binding for Dee - development files
Advertisement
Advertisement