libcurl4-gnutls-dev_7.47.0-1ubuntu2_amd64.deb


Advertisement

Description

libcurl4-gnutls-dev - development files and documentation for libcurl (GnuTLS flavour)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libcurl4-gnutls-dev_7.47.0-1ubuntu2_amd64.deb
Package name libcurl4-gnutls-dev
Package version 7.47.0
Package release 1ubuntu2
Package architecture amd64
Package type deb
Category libdevel
Homepage http://curl.haxx.se
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 254.32 KB
Installed size 1.19 MB
libcurl is an easy-to-use client-side URL transfer library, supporting DICT,
FILE, FTP, FTPS, GOPHER, HTTP, HTTPS, IMAP, IMAPS, LDAP, LDAPS, POP3, POP3S,
RTMP, RTSP, SCP, SFTP, SMTP, SMTPS, TELNET and TFTP.
libcurl supports SSL certificates, HTTP POST, HTTP PUT, FTP uploading, HTTP
form based upload, proxies, cookies, user+password authentication (Basic,
Digest, NTLM, Negotiate, Kerberos), file transfer resume, http proxy tunneling
and more!
libcurl is free, thread-safe, IPv6 compatible, feature rich, well supported,
fast, thoroughly documented and is already used by many known, big and
successful companies and numerous applications.
This package provides the development files (ie. includes, static library,
manual pages) that allow one to build software which uses libcurl.
SSL support is provided by GnuTLS.

Alternatives

Package Version Architecture Repository
libcurl4-gnutls-dev_7.47.0-1ubuntu2.14_amd64.deb 7.47.0 amd64 Ubuntu Updates Main
libcurl4-gnutls-dev_7.47.0-1ubuntu2.14_i386.deb 7.47.0 i386 Ubuntu Updates Main
libcurl4-gnutls-dev_7.47.0-1ubuntu2_i386.deb 7.47.0 i386 Ubuntu Main
libcurl4-gnutls-dev - - -

Requires

Name Value
libcurl3-gnutls = 7.47.0-1ubuntu2

Provides

Name Value
libcurl-dev -
libcurl-ssl-dev -
libcurl3-gnutls-dev -
libcurl4-dev -

Conflicts

Name Value
libcurl4-nss-dev -
libcurl4-openssl-dev -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libcurl4-gnutls-dev_7.47.0-1ubuntu2_amd64.deb
Source Package curl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcurl4-gnutls-dev deb package:
    # sudo apt-get install libcurl4-gnutls-dev

Files

Path
/usr/bin/curl-config
/usr/include/curl/curl.h
/usr/include/curl/curlbuild.h
/usr/include/curl/curlrules.h
/usr/include/curl/curlver.h
/usr/include/curl/easy.h
/usr/include/curl/mprintf.h
/usr/include/curl/multi.h
/usr/include/curl/stdcheaders.h
/usr/include/curl/typecheck-gcc.h
/usr/lib/x86_64-linux-gnu/libcurl-gnutls.a
/usr/lib/x86_64-linux-gnu/libcurl-gnutls.la
/usr/lib/x86_64-linux-gnu/libcurl-gnutls.so
/usr/lib/x86_64-linux-gnu/libcurl.a
/usr/lib/x86_64-linux-gnu/libcurl.la
/usr/lib/x86_64-linux-gnu/libcurl.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libcurl.pc
/usr/share/aclocal/libcurl.m4
/usr/share/doc/libcurl4-gnutls-dev/NEWS.Debian.gz
/usr/share/doc/libcurl4-gnutls-dev/changelog.Debian.gz
/usr/share/doc/libcurl4-gnutls-dev/copyright
/usr/share/man/man1/curl-config.1.gz

Changelog

2016-02-17 - Matthias Klose <doko@ubuntu.com>
curl (7.47.0-1ubuntu2) xenial; urgency=medium
* No-change rebuild for gnutls transition.
2016-01-27 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
curl (7.47.0-1ubuntu1) xenial; urgency=medium
* Merge from Debian. Remaining changes:
- Drop dependencies not in main:
+ Build-Depends: Drop stunnel4, libssh2-1-dev, and libnghttp2-dev.
+ Drop libssh2-1-dev from binary package Depends.
+ debian/control: drop --with-nghttp2
- Switch build depends from transitional libgnutsl28-dev to
libgnutls-dev
2016-01-27 - Alessandro Ghedini <ghedo@debian.org>
curl (7.47.0-1) unstable; urgency=high
* New upstream release
- Fix NTLM credentials not-checked for proxy connection re-use
as per CVE-2016-0755
http://curl.haxx.se/docs/adv_20160127A.html
- Set uyrgency=high accordingly
* Remove hard-coded dependency on libgnutls (Closes: #812542)
* Drop 08_fix-zsh-completion.patch (merged upstream)
* Refresh patches
2016-01-22 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
curl (7.46.0-1ubuntu1) xenial; urgency=medium
* Merge from Debian. Remaining changes:
- Drop dependencies not in main:
+ Build-Depends: Drop stunnel4, libssh2-1-dev, and libnghttp2-dev.
+ Drop libssh2-1-dev from binary package Depends.
+ debian/control: drop --with-nghttp2
- Switch build depends from transitional libgnutsl28-dev to
libgnutls-dev
2015-12-27 - Alessandro Ghedini <ghedo@debian.org>
curl (7.46.0-1) unstable; urgency=medium
* New upstream release
- Initialize OpenSSL algorithms after loading config (Closes: #805408)
* Install curl zsh completion (Closes: #805509)
- Add 08_fix-zsh-completion.patch to fix zsh completion generation
2015-11-04 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
curl (7.45.0-1ubuntu1) xenial; urgency=medium
* Merge from Debian. Remaining changes:
- Drop dependencies not in main:
+ Build-Depends: Drop stunnel4, libssh2-1-dev, and libnghttp2-dev.
+ Drop libssh2-1-dev from binary package Depends.
+ debian/control: drop --with-nghttp2
- Switch build depends from transitional libgnutsl28-dev to
libgnutls-dev
2015-10-07 - Alessandro Ghedini <ghedo@debian.org>
curl (7.45.0-1) unstable; urgency=medium
* New upstream release
* Drop 08_spelling.patch (merged upstream)
2015-09-10 - Alessandro Ghedini <ghedo@debian.org>
curl (7.44.0-2) unstable; urgency=medium
* Enable HTTP/2 support (Closes: #796302)
2015-08-12 - Alessandro Ghedini <ghedo@debian.org>
curl (7.44.0-1) unstable; urgency=medium
* New upstream release
* Refresh patches
* Update symbols files
* Add 08_spelling.patch to fix some spelling errors
2015-08-11 - Robert Ancell <robert.ancell@canonical.com>
curl (7.43.0-1ubuntu2) wily; urgency=medium
* debian/control:
- Switch build depends from transitional libgnutsl28-dev to libgnutls-dev

See Also

Package Description
libcurl4-nss-dev_7.47.0-1ubuntu2_amd64.deb development files and documentation for libcurl (NSS flavour)
libcurl4-openssl-dev_7.47.0-1ubuntu2_amd64.deb development files and documentation for libcurl (OpenSSL flavour)
libcwidget-dev_0.5.17-4ubuntu2_amd64.deb high-level terminal interface library for C++ (development files)
libcwidget-doc_0.5.17-4ubuntu2_all.deb high-level terminal interface library for C++ (documentation)
libcwidget3v5_0.5.17-4ubuntu2_amd64.deb high-level terminal interface library for C++ (runtime files)
libcxsparse3.1.4_4.4.6-1_amd64.deb concise sparse matrix library (complex, int and long int support)
libdaemon-dev_0.14-6_amd64.deb lightweight C library for daemons - development files
libdaemon-doc_0.14-6_all.deb lightweight C library for daemons - documentation
libdaemon0_0.14-6_amd64.deb lightweight C library for daemons - runtime library
libdata-alias-perl_1.20-1build1_amd64.deb module to create aliases instead of copies
libdate-manip-perl_6.52-1_all.deb module for manipulating dates
libdatrie-dev_0.2.10-2_amd64.deb Development files for double-array trie library
libdatrie-doc_0.2.10-2_all.deb Documentation files for double-array trie library
libdatrie1_0.2.10-2_amd64.deb Double-array trie library
libdb++-dev_5.3.21~exp1ubuntu2_amd64.deb Berkeley Database Libraries for C++ [development]
Advertisement
Advertisement