libcupsmime1-dev_2.1.3-4_amd64.deb


Advertisement

Description

libcupsmime1-dev - Common UNIX Printing System(tm) - Development files MIME library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libcupsmime1-dev_2.1.3-4_amd64.deb
Package name libcupsmime1-dev
Package version 2.1.3
Package release 4
Package architecture amd64
Package type deb
Category libdevel
Homepage http://www.cups.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 13.85 KB
Installed size 154.00 KB
The Common UNIX Printing System (or CUPS(tm)) is a printing system and
general replacement for lpd and the like.  It supports the Internet
Printing Protocol (IPP), and has its own filtering driver model for
handling various document types.
This package provides the files necessary for developing programs
using libcupsmime.

Alternatives

Package Version Architecture Repository
libcupsmime1-dev_2.1.3-4ubuntu0.10_amd64.deb 2.1.3 amd64 Ubuntu Updates Main
libcupsmime1-dev_2.1.3-4ubuntu0.10_i386.deb 2.1.3 i386 Ubuntu Updates Main
libcupsmime1-dev_2.1.3-4_i386.deb 2.1.3 i386 Ubuntu Main
libcupsmime1-dev - - -

Requires

Name Value
libcups2-dev = 2.1.3-4
libcupsmime1 = 2.1.3-4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libcupsmime1-dev_2.1.3-4_amd64.deb
Source Package cups

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcupsmime1-dev deb package:
    # sudo apt-get install libcupsmime1-dev

Files

Path
/usr/include/cups/mime.h
/usr/lib/x86_64-linux-gnu/libcupsmime.a
/usr/lib/x86_64-linux-gnu/libcupsmime.so
/usr/share/doc/libcupsmime1-dev/changelog.Debian.gz
/usr/share/doc/libcupsmime1-dev/copyright

Changelog

2016-03-18 - Didier Raboud <odyx@debian.org>
cups (2.1.3-4) unstable; urgency=medium
[ Till Kamppeter ]
* Quirk rule to make Lexmark C540n work (STR #4778)
* Quirk rule to make Xerox WorkCentre 3220 work (LP: #1406203, STR #4789)
2016-02-29 - Didier Raboud <odyx@debian.org>
cups (2.1.3-3) unstable; urgency=medium
* Install missing cups-snmp.8 manpage (Closes: #816316)
2016-02-24 - Didier Raboud <odyx@debian.org>
cups (2.1.3-2) unstable; urgency=medium
* Drop unused libslp-dev Build-Dependency (Closes: #815359)
* Bump Standards-Version to 3.9.7 without changes needed
2016-02-13 - Didier Raboud <odyx@debian.org>
cups (2.1.3-1) unstable; urgency=medium
* New 2.1.3 upstream release:
- /admin resource files (like config files of CUPS) were not served when
the web interface was disabled, breaking utilities like "cupsctl"
(CUPS STR #4755)
2016-01-13 - Didier Raboud <odyx@debian.org>
cups (2.1.2-2) unstable; urgency=medium
[ Till Kamppeter ]
* Add patch to avoid letting pending subscriptions prevent CUPS from
auto-shutdown when idle (CUPS STR#4754)
* Add patch to allow auto-shutdown when idle if the web interface is not
turned off in the CUPS configuration, the web interface is too important
(CUPS STR #4755)
[ Didier Raboud ]
* Remove libpng12-dev Build-Depends alternative to libpng-dev
(Closes: #810183)
2015-12-03 - Didier Raboud <odyx@debian.org>
cups (2.1.2-1) unstable; urgency=low
* New 2.1.2 upstream release
* Drop patches included upstream:
- usb-backend-fix-infinite-loop-when-usblp-module-attached.patch
- usb-backend-delayed-closing-for-old-laserjets.patch
- fix-ppd-file-load-for-ipp-printers.patch
Refresh 2 other patches
* Update Apple Inc. Copyright years in debian/copyright
2015-11-30 - Didier Raboud <odyx@debian.org>
cups (2.1.0-7) unstable; urgency=medium
[ Till Kamppeter ]
* Removed deprecated no-op "--upstart-only" option from dh_installinit call
in debian/rules (LP: #1519228)
* Moved empty directories /etc/cups/ppd and /etc/cups/interfaces to the
cups-core-drivers binary package
* Moved mime.convs from cups-server-common to cups-core-drivers to get it
onto mobile devices with level-2 printing stack (support for IPP printers
with common PDLs auto-set-up by cups-browsed)
2015-11-06 - Didier Raboud <odyx@debian.org>
cups (2.1.0-6) unstable; urgency=medium
[ Till Kamppeter ]
* Move /usr/lib/cups/daemom/cups-exec from the "cups" binary package to the
"cups-daemon" binary package as it is already needed for basic job
execution and therefore already in the level-1 (minimum) printing stack
(LP: #1509423)
2015-10-21 - Didier Raboud <odyx@debian.org>
cups (2.1.0-5) unstable; urgency=medium
[ Till Kamppeter ]
* Add upstream patch to fix cupsGetPPD* with IPP print queues
(CUPS STR #4725)
2015-09-16 - Didier Raboud <odyx@debian.org>
cups (2.1.0-4) unstable; urgency=medium
[ Till Kamppeter ]
* Corrected info header (author and Debian bug closure) of
usb-backend-fix-infinite-loop-when-usblp-module-attached.patch
* USB-backend: Added new quirk rules for delayed closing of the backend for
several older HP LaserJet printers (CUPS STR #4549)
[ Didier Raboud ]
* Add maintscript stanzas to properly remove the oopstops.{convs,types}
conffiles in /etc/cups that are not shipped since 1.3.10-3
(Closes: #799025)

See Also

Package Description
libcupsmime1_2.1.3-4_amd64.deb Common UNIX Printing System(tm) - MIME library
libcupsppdc1-dev_2.1.3-4_amd64.deb Common UNIX Printing System(tm) - Development files PPD library
libcupsppdc1_2.1.3-4_amd64.deb Common UNIX Printing System(tm) - PPD manipulation library
libcurl3-gnutls_7.47.0-1ubuntu2_amd64.deb easy-to-use client-side URL transfer library (GnuTLS flavour)
libcurl3-nss_7.47.0-1ubuntu2_amd64.deb easy-to-use client-side URL transfer library (NSS flavour)
libcurl3_7.47.0-1ubuntu2_amd64.deb easy-to-use client-side URL transfer library (OpenSSL flavour)
libcurl4-doc_7.47.0-1ubuntu2_all.deb documentation for libcurl
libcurl4-gnutls-dev_7.47.0-1ubuntu2_amd64.deb development files and documentation for libcurl (GnuTLS flavour)
libcurl4-nss-dev_7.47.0-1ubuntu2_amd64.deb development files and documentation for libcurl (NSS flavour)
libcurl4-openssl-dev_7.47.0-1ubuntu2_amd64.deb development files and documentation for libcurl (OpenSSL flavour)
libcwidget-dev_0.5.17-4ubuntu2_amd64.deb high-level terminal interface library for C++ (development files)
libcwidget-doc_0.5.17-4ubuntu2_all.deb high-level terminal interface library for C++ (documentation)
libcwidget3v5_0.5.17-4ubuntu2_amd64.deb high-level terminal interface library for C++ (runtime files)
libcxsparse3.1.4_4.4.6-1_amd64.deb concise sparse matrix library (complex, int and long int support)
libdaemon-dev_0.14-6_amd64.deb lightweight C library for daemons - development files
Advertisement
Advertisement