libcommons-dbcp-java_1.4-5ubuntu2_all.deb


Advertisement

Description

libcommons-dbcp-java - Database Connection Pooling Services

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libcommons-dbcp-java_1.4-5ubuntu2_all.deb
Package name libcommons-dbcp-java
Package version 1.4
Package release 5ubuntu2
Package architecture all
Package type deb
Category libs
Homepage http://commons.apache.org/dbcp/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 144.61 KB
Installed size 185.00 KB
The DBCP package provides database connection pooling services. The
following features are supported
* DataSource and Driver interfaces to the pool.
* Support for arbitrary sources of the underlying Connections.
* Integration with arbitrary org.apache.commons.pool.ObjectPool
implementations.
* Support for Connection validation, expiration, etc.
* Support for PreparedStatement pooling.
* XML configuration.
This is a part of the Apache Commons Project.

Alternatives

Package Version Architecture Repository
libcommons-dbcp-java_1.4-5ubuntu2_all.deb 1.4 all Ubuntu Main
libcommons-dbcp-java - - -

Requires

Name Value
libcommons-collections3-java -
libcommons-pool-java -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libcommons-dbcp-java_1.4-5ubuntu2_all.deb
Source Package libcommons-dbcp-java

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcommons-dbcp-java deb package:
    # sudo apt-get install libcommons-dbcp-java

Files

Path
/usr/share/doc/libcommons-dbcp-java/changelog.Debian.gz
/usr/share/doc/libcommons-dbcp-java/copyright
/usr/share/java/commons-dbcp-1.4.jar
/usr/share/java/commons-dbcp.jar
/usr/share/maven-repo/commons-dbcp/commons-dbcp/1.4/commons-dbcp-1.4.jar
/usr/share/maven-repo/commons-dbcp/commons-dbcp/1.4/commons-dbcp-1.4.pom
/usr/share/maven-repo/commons-dbcp/commons-dbcp/debian/commons-dbcp-debian.jar
/usr/share/maven-repo/commons-dbcp/commons-dbcp/debian/commons-dbcp-debian.pom

Changelog

2016-02-22 - Matthias Klose <doko@ubuntu.com>
libcommons-dbcp-java (1.4-5ubuntu2) xenial; urgency=medium
* Build-depend on libtomcat8-java.
2014-12-08 - James Page <james.page@ubuntu.com>
libcommons-dbcp-java (1.4-5ubuntu1) vivid; urgency=low
* Merge from Debian unstable.  Remaining changes:
- d/ant.properties: Specifiy location of dependencies for build, set
source/target version of Java to 1.5.
- d/control: Switch BD/BDI's for ant based build, manually specify
dependencies for binary packages.
- d/libcommons-dbcp-java-doc.install: Pickup docs from ant build
location.
- d/maven.rules: Specify mappings for installed maven artifacts.
- d/patches/01_build.patch: Patch ant build file for Javadoc locations.
- d/rules: Rewrite for ant based build.
- d/maven.*, d/patches/0001-configure-source-and-target-version-1.5.patch,
d/README.source: Dropped as not required for ant based build.
2014-10-25 - Emmanuel Bourg <ebourg@apache.org>
libcommons-dbcp-java (1.4-5) unstable; urgency=medium
* Build depend on libtomcat8-java instead of libtomcat7-java (Closes: #759640)
* Standards-Version updated to 3.9.6 (no changes)
* Moved the package to Git
2014-03-11 - Emmanuel Bourg <ebourg@apache.org>
libcommons-dbcp-java (1.4-4) unstable; urgency=medium
* Enabled the unit tests
* debian/control:
- Removed the unused build dependency on libclirr-maven-plugin-java
- Suggest the optional Maven dependencies instead of recommending them
- Standards-Version updated to 3.9.5 (no changes)
- Use canonical URLs for the Vcs-* fields
* Install the upstream changelog
* Use XZ compression for the upstream tarball
* Switch to debhelper level 9
* debian/copyright: Updated to the Copyright Format 1.0
2012-07-09 - James Page <james.page@ubuntu.com>
libcommons-dbcp-java (1.4-3ubuntu1) quantal; urgency=low
* Resync from Debian unstable.
* Revert package to ant buildsystem:
+ d/ant.properties: Specifiy location of dependencies for build, set
source/target version of Java to 1.5.
+ d/control: Switch BD/BDI's for ant based build, manually specify
dependencies for binary packages.
+ d/libcommons-dbcp-java-doc.install: Pickup docs from ant build 
location.
+ d/maven.rules: Specify mappings for installed maven artifacts.
+ d/patches/01_build.patch: Patch ant build file for Javadoc locations.
+ d/rules: Rewrite for ant based build.
+ d/maven.*, d/patches/0001-configure-source-and-target-version-1.5.patch,
d/README.source: Dropped as not required for ant based build.
2012-06-19 - Niels Thykier <niels@thykier.net>
libcommons-dbcp-java (1.4-3) unstable; urgency=low
* Team upload.
* Apply patch from James Page that:
- fixes FTBFS with Openjdk-7
- Bumps geronimo-jta (build-)dependencies
(Closes: #678167)
* Remove Michael Koch from uploaders - Thanks for you work on
this package so far.  (Closes: #654051)
2011-09-11 - Torsten Werner <twerner@debian.org>
libcommons-dbcp-java (1.4-2) unstable; urgency=low
* Team upload.
* Switch to source format 3.0.
* Remove Java runtime from Depends.
* Update Standards-Version: 3.9.1.
* Use Maven to build the package.
2012-06-08 - James Page <james.page@ubuntu.com>
libcommons-dbcp-java (1.4-1ubuntu2) quantal; urgency=low
* Fix FTBFS with openjdk-7 (LP: #888125):
- debian/patches/02_java7_compat.patch: Cherry picked patch from 
Fedora transition for compatibility with Java 7. 
* d/control: Use libgeronimo-jta-1.1-spec-java instead of deprecated
libgeronimo-jta-1.0.1b-spec-java.
2010-06-11 - Thierry Carrez <thierry.carrez@ubuntu.com>
libcommons-dbcp-java (1.4-1ubuntu1) maverick; urgency=low
* Merge from debian testing. Remaining changes:
- Replace glassfish-javaee by libgeronimo-jta-1.0.1b-spec-java, since the
former is in universe and the latter in main

See Also

Package Description
libcommons-pool-java-doc_1.6-2_all.deb pooling implementation for Java objects - documentation
libcommons-pool-java_1.6-2_all.deb pooling implementation for Java objects
libcompizconfig0-dev_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb Development file for plugin settings - OpenCompositing Project
libcompizconfig0_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb Settings library for plugins - OpenCompositing Project
libconfig-auto-perl_0.44-1_all.deb magical config file parser
libconfig-general-perl_2.60-1_all.deb generic configuration module
libconfig-inifiles-perl_2.88-1_all.deb Read .ini-style configuration files
libconvert-asn1-perl_0.27-2_all.deb Perl module for encoding and decoding ASN.1 data structures
libconvert-binhex-perl_1.125-1_all.deb Perl5 module for extracting data from macintosh BinHex files
libconvert-tnef-perl_0.18-1_all.deb Perl module to read TNEF files
libconvert-uulib-perl_1.4~dfsg-1build5_amd64.deb Perl interface to the uulib library (a.k.a. uudeview/uuenview)
libcorosync-common-dev_2.3.5-3ubuntu1_amd64.deb cluster engine common development
libcorosync-common4_2.3.5-3ubuntu1_amd64.deb cluster engine common library
libcpg-dev_2.3.5-3ubuntu1_amd64.deb cluster engine CPG library development
libcpg4_2.3.5-3ubuntu1_amd64.deb cluster engine CPG library
Advertisement
Advertisement