libcolord2_1.2.12-1ubuntu1_amd64.deb


Advertisement

Description

libcolord2 - system service to manage device colour profiles -- runtime

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libcolord2_1.2.12-1ubuntu1_amd64.deb
Package name libcolord2
Package version 1.2.12
Package release 1ubuntu1
Package architecture amd64
Package type deb
Category libs
Homepage http://www.freedesktop.org/software/colord/
License -
Maintainer Christopher James Halse Rogers <raof@ubuntu.com>
Download size 101.15 KB
Installed size 375.00 KB
colord is a system service that makes it easy to manage, install and generate
colour profiles to accurately colour manage input and output devices.
It provides a D-Bus API for system frameworks to query, a persistent data
store, and a mechanism for session applications to set system policy.
This package contains a gobject-based convenience library for programs to
interact with the colord system daemon.

Alternatives

Package Version Architecture Repository
libcolord2_1.2.12-1ubuntu1_i386.deb 1.2.12 i386 Ubuntu Main
libcolord2 - - -

Requires

Name Value
libc6 >= 2.4
libglib2.0-0 >= 2.37.3
liblcms2-2 >= 2.6
libudev1 >= 196

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libcolord2_1.2.12-1ubuntu1_amd64.deb
Source Package colord

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcolord2 deb package:
    # sudo apt-get install libcolord2

Files

Path
/usr/lib/x86_64-linux-gnu/libcolord.so.2
/usr/lib/x86_64-linux-gnu/libcolord.so.2.0.4
/usr/lib/x86_64-linux-gnu/libcolordprivate.so.2
/usr/lib/x86_64-linux-gnu/libcolordprivate.so.2.0.4
/usr/share/doc/libcolord2/changelog.Debian.gz
/usr/share/doc/libcolord2/copyright

Changelog

2015-11-06 - Christopher James Halse Rogers <raof@ubuntu.com>
colord (1.2.12-1ubuntu1) xenial; urgency=medium
* Merge from Debian unstable. Remaining Ubuntu changes:
+ debian/control: Don't build-depend on Argyll; not in main.
+ debian/rules: Don't build extra print profiles; requires Argyll
2015-11-06 - Christopher James Halse Rogers <raof@ubuntu.com>
colord (1.2.12-1) unstable; urgency=medium
* Bump standards-version; no changes required
* Use canonical Vcs-Git URL
* Fix Files: glob in debian/copyright to actually match
* Drop obsolete XS-Testsuite stanza; dpkg handles this now
* Move hardening-check lintian override to correct package
* Fix FTBFS on !Linux architectures.
Argyll is now linux-only, so guard all the features that rely on it
behind linux-any.
Thanks to Pino Toscano <pino@debian.org> (Closes: 795536)
* Update libcolorhug symbols for 1.2.12 release
* Really, truly, remove obsolete colord.conf. (Closes: 751212)
* colord-plugin-argyll: fix upgrade from Jessie.
This package was split out of colord as argyll has become Linux-only, so we need
to do the Breaks/Replaces dance. (Closes: 798355)
2015-08-13 - Christopher James Halse Rogers <raof@ubuntu.com>
colord (1.2.11-1) unstable; urgency=medium
* Add missing GFDL licence for documentation
* Merge new upstream 1.2.11 release. (Closes: 782477)
* Cherry pick commit to check for, and prefer, libsystemd over
libsystemd-login. (Closes: 779777)
* debian/libcolorhug2.symbols: Add new ch_device_close symbol.
* Remove no-longer-used colord.conf (Closes: 751212)
* Add new symbols to libcolord-private symbols file
* Add new functions to libcolorhug2 symbols file
* Add newly-introduced symbols to symbols file
* Update DEP8 control for libtool-bin split
* Output better logs on DEP8 failures
* Add colord-sensor-argyll package
* Disable strangely-failing DEP8 test
2015-02-19 - Christopher James Halse Rogers <raof@ubuntu.com>
colord (1.2.8-0ubuntu1) vivid; urgency=medium
* Pseudo-merge from unreleased Debian package. Remaining Ubuntu changes:
+ Don't Build-Depend on argyll; not in main.
+ Don't build extra print profiles; requires argyll.
* New upstream 1.2.8 release.
* Remove no-longer-used colord.conf (Closes: 751212)
* Add new symbols to libcolord-private symbols file
* Add new functions to libcolorhug2 symbols file
* Add newly-introduced symbols to symbols file
* Update DEP8 control for libtool-bin split
* Output better logs on DEP8 failures
* Add colord-sensor-argyll package
2014-06-05 - Christopher James Halse Rogers <raof@ubuntu.com>
colord (1.2.1-1) unstable; urgency=medium
* New upstream stable release. Fixes unsafe pointer cast, so
cd-create-profile no longer tries to allocate terabytes of
memory on 64bit big-endiane machines. (Closes: 750013)
* Move (very slow) print-profile generation to build-indep rule.
2014-05-29 - Martin Pitt <mpitt@debian.org>
colord (1.2.0-3) unstable; urgency=medium
* Actually upload to unstable. Yay sponsors who don't pay enough attention.
2014-05-29 - Christopher James Halse Rogers <raof@ubuntu.com>
colord (1.2.0-2) unstable; urgency=medium
* Fix Replaces/Breaks for files moved from colord to colord-data
(Closes: 749299)
* Explicitly disable udev on !Linux fixes FTBFS (Closes: 749221)
* Don't Build-Depend on argyll on Hurd (Closes: 749222)

See Also

Package Description
libcolorhug-dev_1.2.12-1ubuntu1_amd64.deb library to access the ColorHug colourimeter -- development files
libcolorhug2_1.2.12-1ubuntu1_amd64.deb library to access the ColorHug colourimeter -- runtime
libcolumbus1-common_1.1.0+15.10.20150806-0ubuntu4_all.deb error tolerant matching engine - common files
libcolumbus1-dev_1.1.0+15.10.20150806-0ubuntu4_amd64.deb error tolerant matching engine - development files
libcolumbus1v5_1.1.0+15.10.20150806-0ubuntu4_amd64.deb error tolerant matching engine - shared library
libcomerr2_1.42.13-1ubuntu1_amd64.deb common error description library
libcommon-sense-perl_3.74-1build1_amd64.deb module that implements some sane defaults for Perl programs
libcommons-collections3-java-doc_3.2.2-1_all.deb Documentation for libcommons-collections3-java
libcommons-collections3-java_3.2.2-1_all.deb Apache Commons Collections - Extended Collections API for Java
libcommons-dbcp-java_1.4-5ubuntu2_all.deb Database Connection Pooling Services
libcommons-pool-java-doc_1.6-2_all.deb pooling implementation for Java objects - documentation
libcommons-pool-java_1.6-2_all.deb pooling implementation for Java objects
libcompizconfig0-dev_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb Development file for plugin settings - OpenCompositing Project
libcompizconfig0_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb Settings library for plugins - OpenCompositing Project
libconfig-auto-perl_0.44-1_all.deb magical config file parser
Advertisement
Advertisement