libclucene-contribs1v5_2.3.3.4-4.1_amd64.deb


Advertisement

Description

libclucene-contribs1v5 - language specific text analyzers (runtime)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libclucene-contribs1v5_2.3.3.4-4.1_amd64.deb
Package name libclucene-contribs1v5
Package version 2.3.3.4
Package release 4.1
Package architecture amd64
Package type deb
Category libs
Homepage http://clucene.sourceforge.net
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 77.41 KB
Installed size 402.00 KB
CLucene is a C++ port of the popular Apache Lucene search engine
(http://lucene.apache.org/java). It is released under LGPL or the Apache
License.
CLucene aims to be a high-speed alternative to Java Lucene, its API is very
similar to that of the Java version. CLucene has recently been brought up to
date with Lucene 1.4.3. It contains most of the same functionality as the
Java version, except for Socket, Threading and the special caching
modifications.
This package contains the files necessary for running applications that
use the CLucene contribs library (language specific text analyzers for
CLucene).

Alternatives

Package Version Architecture Repository
libclucene-contribs1v5_2.3.3.4-4.1_i386.deb 2.3.3.4 i386 Ubuntu Main
libclucene-contribs1v5 - - -

Requires

Name Value
libc6 >= 2.14
libclucene-core1v5 >= 2.3.3.4
libgcc1 >= 1:4.1.1
libstdc++6 >= 5.2
zlib1g >= 1:1.1.4

Conflicts

Name Value
libclucene-contribs1 -

Replaces

Name Value
libclucene-contribs1 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libclucene-contribs1v5_2.3.3.4-4.1_amd64.deb
Source Package clucene-core

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libclucene-contribs1v5 deb package:
    # sudo apt-get install libclucene-contribs1v5

Files

Path
/usr/lib/x86_64-linux-gnu/libclucene-contribs-lib.so.1
/usr/lib/x86_64-linux-gnu/libclucene-contribs-lib.so.2.3.3.4
/usr/share/doc/libclucene-contribs1v5/changelog.Debian.gz
/usr/share/doc/libclucene-contribs1v5/copyright
/usr/share/lintian/overrides/libclucene-contribs1v5

Changelog

2015-08-16 - Julien Cristau <jcristau@debian.org>
clucene-core (2.3.3.4-4.1) unstable; urgency=medium
* Non-maintainer upload.
* Rename library packages for g++5 ABI transition (closes: 791004).
2013-07-29 - Fathi Boudra <fabo@debian.org>
clucene-core (2.3.3.4-4) unstable; urgency=low
* Add bug718187-ftbfs-hurd.patch to fix build failure on HURD.
Thanks to Pino Toscano. (Closes: #718187)
2013-07-28 - Fathi Boudra <fabo@debian.org>
clucene-core (2.3.3.4-3) unstable; urgency=low
* Add bug715474-no-boost-headers.patch to drop boost headers from
clucene-core. (Closes: #715474)
* Update debian/control:
- Upload to Sid.
- bump Standards-Version to 3.9.3.
2012-08-14 - Fathi Boudra <fabo@debian.org>
clucene-core (2.3.3.4-2) experimental; urgency=low
* Update multiarch patch: add multiarch path to pkg-config's cflags.
(Closes: #684715)
2012-08-11 - Fathi Boudra <fabo@debian.org>
clucene-core (2.3.3.4-1) experimental; urgency=low
* New upstream release (Closes: #661703).
* Convert package to multiarch.
* Drop obsolete patches:
- 01_add_missing_include_bug505667.diff
- 02_posixness_fix_bug530308.diff
* Add patches:
- Fixing_ZLIB_configuration_in_shared_CMakeLists.patch
- Fix-pkgconfig-file-by-adding-clucene-shared-library.patch
- Install-contribs-lib.patch
- multiarch.patch
* Update debian/compat: bump to 8.
* Update debian/control:
- update build dependencies (add cmake, libboost-dev and libz-dev).
- bump Standards-Version to 3.9.3.
- rename packages due to ABI bump: libclucene0ldbl -> libclucene-core1.
- add libclucene-contribs1 package.
* Update debian/rules:
- rewrite to use CMake.
- add multiarch support.
2009-08-19 - Fathi Boudra <fabo@debian.org>
clucene-core (0.9.21b-2) unstable; urgency=low
* Restore libclucene0ldbl package name. (Closes: #542337)
* Bump Standards-Version to 3.8.3 (no changes needed).
2009-08-12 - Fathi Boudra <fabo@debian.org>
clucene-core (0.9.21b-1) unstable; urgency=low
* New upstream release.
* Drop '01_stack_fix' patch - fixed upstream.
* Add patches:
- 01_add_missing_include_bug505667
Thanks to Martin Michlmayr. (Closes: #505667)
- 02_posixness_fix_bug530308
fix POSIX incompatibilities causing FTBFS on hurd-i386.
Thanks to Marc Dequènes. (Closes: #530308)
* Bump debian/compat to 7.
* Update debian/control:
- Remove cdbs build dependency.
- Bump Standards-Version: 3.8.2
- Replace libclucene0ldbl package by libclucene0 package.
* Update debian/copyright file.
* Convert debian/rules to dh_usage.
2008-02-21 - Fathi Boudra <fabo@debian.org>
clucene-core (0.9.20-3) unstable; urgency=low
* Lower compat/debhelper to 5.
* Re-enable static library build.
2008-02-07 - Fathi Boudra <fabo@debian.org>
clucene-core (0.9.20-2) unstable; urgency=low
* Re-add stack fix for x86_64. Not merged upstream. (Closes: #460328)
* Bump compat/debhelper to 6.
* Update my e-mail address.
* Use quilt patch system.
* Bump Standards-Version to 3.7.3.
* Use Homepage field.
* Build with --no-undefined and --as-needed linker flags.
* Disable static library build.
2007-10-03 - Fathi Boudra <fboudra@free.fr>
clucene-core (0.9.20-1) unstable; urgency=low
* New upstream release.
* Remove libclucene.la from libclucene-dev package.

See Also

Package Description
libclucene-core1v5_2.3.3.4-4.1_amd64.deb core library for full-featured text search engine (runtime)
libclucene-dev_2.3.3.4-4.1_amd64.deb library for full-featured text search engine (development)
libcluster-glue-dev_1.0.12~rc1+hg2777-1.2_all.deb Reusable cluster components for Linux HA (transitional package)
libclutter-1.0-0_1.24.2-1_amd64.deb Open GL based interactive canvas library
libclutter-1.0-common_1.24.2-1_all.deb Open GL based interactive canvas library (common files)
libclutter-1.0-dev_1.24.2-1_amd64.deb Open GL based interactive canvas library (development files)
libclutter-1.0-doc_1.24.2-1_all.deb Open GL based interactive canvas library (documentation)
libclutter-gst-3.0-0_3.0.18-1_amd64.deb Open GL based interactive canvas library GStreamer elements
libclutter-gst-3.0-dev_3.0.18-1_amd64.deb Open GL based interactive canvas library GStreamer elements (development files)
libclutter-gst-3.0-doc_3.0.18-1_all.deb Open GL based interactive canvas library GStreamer elements (documentation)
libclutter-gtk-1.0-0_1.6.6-1_amd64.deb Open GL based interactive canvas library GTK+ widget
libclutter-gtk-1.0-dev_1.6.6-1_amd64.deb Open GL based interactive canvas library GTK+ widget (development files)
libclutter-gtk-1.0-doc_1.6.6-1_all.deb Open GL based interactive canvas library GTK+ widget (documentation)
libcmap-dev_2.3.5-3ubuntu1_amd64.deb cluster engine CMAP library development
libcmap4_2.3.5-3ubuntu1_amd64.deb cluster engine CMAP library
Advertisement
Advertisement