libbonoboui2-common_2.24.5-3ubuntu1_all.deb


Advertisement

Description

libbonoboui2-common - Bonobo UI library - common files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libbonoboui2-common_2.24.5-3ubuntu1_all.deb
Package name libbonoboui2-common
Package version 2.24.5
Package release 3ubuntu1
Package architecture all
Package type deb
Category libs
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 11.63 KB
Installed size 132.00 KB
Bonobo is a set of language and system independent CORBA interfaces
for creating reusable components, controls and creating compound
documents.
The Bonobo distribution includes a GTK+ based implementation of the
Bonobo interfaces, enabling developers to create reusable
components and applications that can be used to form more complex
documents.
This package contains the support files needed by the GTK+ part of the
Bonobo library.

Alternatives

Package Version Architecture Repository
libbonoboui2-common_2.24.5-3ubuntu1_all.deb 2.24.5 all Ubuntu Main
libbonoboui2-common - - -

Conflicts

Name Value
libbonoboui2-0 <= 2.4.3-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libbonoboui2-common_2.24.5-3ubuntu1_all.deb
Source Package libbonoboui

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libbonoboui2-common deb package:
    # sudo apt-get install libbonoboui2-common

Files

Path
/usr/share/doc/libbonoboui2-common/NEWS.gz
/usr/share/doc/libbonoboui2-common/README
/usr/share/doc/libbonoboui2-common/changelog.Debian.gz
/usr/share/doc/libbonoboui2-common/copyright
/usr/share/gnome-2.0/ui/Bonobo_Sample_Container-ui.xml
/usr/share/gnome-2.0/ui/Bonobo_Sample_Hello.xml
/usr/share/gnome-2.0/ui/bonobo-browser.xml

Changelog

2015-08-27 - Matthias Klose <doko@debian.org>
libbonoboui (2.24.5-3ubuntu1) wily; urgency=low
* Merge with Debian; remaining changes:
- Build-depend on gtk-doc-tools.
- Use standards-version 3.9.6.
- Add Vcs-Bzr link.
- Adjust Breaks/Replaces version.
2015-07-07 - Andreas Henriksson <andreas@fatal.se>
libbonoboui (2.24.5-3) unstable; urgency=medium
[ Matthias Klose ]
* Avoid new warning with GCC 5. (Closes: #777939)
2013-12-29 - Josselin Mouette <joss@debian.org>
libbonoboui (2.24.5-2) unstable; urgency=low
* Add missing build-dependency on gtk-doc-tools.
* Fix copyright file. Closes: #733487.
2013-12-26 - Josselin Mouette <joss@debian.org>
libbonoboui (2.24.5-1) unstable; urgency=low
[ Josselin Mouette ]
* Move documentation to libbonoboui2-dev. Closes: #583121.
+ Stop symlinking to /usr/share/doc.
+ Remove the sylink in libbonoboui2-dev.preinst.
[ Loïc Minier ]
* Fix globbing in watch file.
[ Emilio Pozuelo Monfort ]
* debian/source/format,
debian/rules:
+ Switch to source format 3.0 (quilt).
* debian/patches/01_dont_check_for_pangox.patch:
+ Stop checking for pangox during configure. It's not needed
and pangox is going away. Closes: #702008.
[ Josselin Mouette ]
* New upstream translation & bugfix release.
* Move to 3.0 quilt format, using tar.bz2 tarball.
* Use dh_autoreconf.
* 01_dont_check_for_pangox.patch. Stop using pangox entirely for 
irrelevant checks. Explicitly depend on X11 libraries since 
libbonoboui uses them regardless.
* Convert to multi-arch:
+ Require appropriate cdbs/debhelper versions.
+ Bump requirement on libbonobo2-dev for the new server path.
+ Bump requirement on libglade2-dev for the new modules path.
+ Make libbonoboui2-common MA: foreign and libbonoboui2-0 MA: same.
+ Update installation paths.
* Move to section oldlibs.
* Update descriptions.
* Drop .la files.
* Drop gnome:version stuff.
* Move bonobo-browser and test-moniker to a new libbonobo2-bin 
package.
+ This allows us to make libbonoboui2-dev MA: same.
2015-03-05 - Matthias Klose <doko@ubuntu.com>
libbonoboui (2.24.5-0ubuntu4) vivid; urgency=medium
* Avoid new warning with GCC 5.
2013-12-16 - William Grant <wgrant@ubuntu.com>
libbonoboui (2.24.5-0ubuntu3) trusty; urgency=medium
* Build with dh-autoreconf for new libtool.
2012-04-17 - Tom Ellis <tom.ellis@canonical.com>
libbonoboui (2.24.5-0ubuntu2) quantal; urgency=low
* Rebuild with multi-arch support (LP: #977952) 
2011-04-06 - Robert Ancell <robert.ancell@canonical.com>
libbonoboui (2.24.5-0ubuntu1) natty; urgency=low
* New upstream release
* debian/control:
- Use standards-version 3.9.1
- Add Vcs-Bzr link
2010-11-17 - Robert Ancell <robert.ancell@canonical.com>
libbonoboui (2.24.4-0ubuntu1) natty; urgency=low
* New upstream release
2010-05-25 - Sebastien Bacher <seb128@ubuntu.com>
libbonoboui (2.24.3-1ubuntu1) maverick; urgency=low
* Resync on debian
* Don't install the documentation with the runtime library

See Also

Package Description
libbonoboui2-dev_2.24.5-3ubuntu1_amd64.deb Bonobo UI library - development files
libboost-date-time1.58.0_1.58.0+dfsg-5ubuntu3_amd64.deb set of date-time libraries based on generic programming concepts
libboost-dev_1.58.0.1ubuntu1_amd64.deb Boost C++ Libraries development files (default version)
libboost-doc_1.58.0.1ubuntu1_all.deb Boost.org libraries documentation (default version)
libboost-filesystem1.58.0_1.58.0+dfsg-5ubuntu3_amd64.deb filesystem operations (portable paths, iteration over directories, etc) in C++
libboost-iostreams1.58.0_1.58.0+dfsg-5ubuntu3_amd64.deb Boost.Iostreams Library
libboost-program-options-dev_1.58.0.1ubuntu1_amd64.deb program options library for C++ (default version)
libboost-program-options1.58-dev_1.58.0+dfsg-5ubuntu3_amd64.deb program options library for C++
libboost-program-options1.58.0_1.58.0+dfsg-5ubuntu3_amd64.deb program options library for C++
libboost-random1.58.0_1.58.0+dfsg-5ubuntu3_amd64.deb Boost Random Number Library
libboost-regex1.58.0_1.58.0+dfsg-5ubuntu3_amd64.deb regular expression library for C++
libboost-system1.58.0_1.58.0+dfsg-5ubuntu3_amd64.deb Operating system (e.g. diagnostics support) library
libboost-thread1.58.0_1.58.0+dfsg-5ubuntu3_amd64.deb portable C++ multi-threading
libboost1.58-dev_1.58.0+dfsg-5ubuntu3_amd64.deb Boost C++ Libraries development files
libboost1.58-doc_1.58.0+dfsg-5ubuntu3_all.deb Boost.org libraries documentation
Advertisement
Advertisement