libavc1394-dev_0.5.4-4_amd64.deb


Advertisement

Description

libavc1394-dev - control IEEE 1394 audio/video devices (development files)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libavc1394-dev_0.5.4-4_amd64.deb
Package name libavc1394-dev
Package version 0.5.4
Package release 4
Package architecture amd64
Package type deb
Category libdevel
Homepage http://sourceforge.net/projects/libavc1394/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 7.19 KB
Installed size 48.00 KB
libavc1394 is a programming interface for the 1394 Trade Association AV/C
(Audio/Video Control) Digital Interface Command Set. It allows you to
remote control camcorders and similar devices connected to your computer
via an IEEE 1394 (aka Firewire) link.
This package includes the libraries and header files needed to compile
programs using libavc1394, as well as the command line tool dvcont that
acts as a simple remote control, the tool mkrfc2734 that is needed
to advertise IP over IEEE 1394 (RFC 2734) capabilities with the Linux
2.4 kernel series, and the utility panelctl, a remote control for
set-top boxes.

Alternatives

Package Version Architecture Repository
libavc1394-dev_0.5.4-4_i386.deb 0.5.4 i386 Ubuntu Main
libavc1394-dev - - -

Requires

Name Value
libavc1394-0 = 0.5.4-4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libavc1394-dev_0.5.4-4_amd64.deb
Source Package libavc1394

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libavc1394-dev deb package:
    # sudo apt-get install libavc1394-dev

Files

Path
/usr/include/libavc1394/avc1394.h
/usr/include/libavc1394/avc1394_vcr.h
/usr/include/libavc1394/rom1394.h
/usr/lib/x86_64-linux-gnu/libavc1394.so
/usr/lib/x86_64-linux-gnu/librom1394.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libavc1394.pc
/usr/share/doc/libavc1394-dev/changelog.Debian.gz
/usr/share/doc/libavc1394-dev/copyright

Changelog

2016-02-16 - Sebastian Ramacher <sramacher@debian.org>
libavc1394 (0.5.4-4) unstable; urgency=medium
* debian/control:
- Adopt package. (Closes: #814887)
- Remove obsolete Breaks+Replaces.
- Remove unnecessary subst vars.
* debian/*.docs: Install README in -tools.
* debian/libavc1394-dev.preinst: Removed, no longer needed.
* debian/libavc1394-0.symbols: Add symbols file.
2016-02-16 - Alessio Treglia <alessio@debian.org>
libavc1394 (0.5.4-3) unstable; urgency=medium
* QA upload.
* Orphaning this
* Fix noopt flag in debian/rules.
Thanks to Michael Tautschnig for reporting this (Closes: #779886)
* Bump Standards
* Update debian/copyright, fix lintian warning
* Bump debhelper dependency's version in debian/control
2013-02-18 - Alessio Treglia <alessio@debian.org>
libavc1394 (0.5.4-2) unstable; urgency=low
* Add libavc1394-dev.preinst to prevent symlink-to-directory conversion.
Thanks to Andreas Beckmann for reporting this. (Closes: #700788)
2012-02-08 - Alessio Treglia <alessio@debian.org>
libavc1394 (0.5.4-1) unstable; urgency=low
* New maintainer (Closes: #654648);
thanks to Daniel Kobras for the great work done.
* New upstream release (Closes: #600784):
- test/panelctl.[c1]: apply patch from Jerry Fiddler to add options
--guid, --specid, --swversion, and --commands.
* Switch to source package format 3.0 (quilt) plus DH 7.
* Build-depend on dh-autoreconf.
* Move files under /usr/bin into a new support package: libavc1394-tools.
* Remove ancient Conflicts/Replaces on libavc1394-0 (<= 0.3.1-3).
* Set priority to optional. (Closes: #425382)
* Build with Multiarch support. (Closes: #651010)
* Explicitly disable the build of static libraries.
* Get rid of unneeded .la files. (Closes: #633190)
* Implement DEB_BUILD_OPTIONS noopt flag. (Closes: #372894)
* Drop libc6-dev from -DEV's Depends field.
* Add missing {misc,shlibs}:Depends wherever needed.
* Replace deprecated Source-Version substvar with binary:Version.
* Add Homepage field.
* Fix lintian's warning binary-control-field-duplicates-source.
* Add watch file.
* Update debian/copyright as per DEP-5.
* Convert dpatch patches to quilt format.
* Small improvements to the manpages
- Fix hyphen-used-as-minus-sign.
- Set an appropriate whatis entry to panelctl's manpage.
* Fix various misspellings in the libraries and tools.
* Refresh patches.
* Run wrap-and-sort -a -s.
* Bump Standards.
2006-05-22 - Daniel Kobras <kobras@debian.org>
libavc1394 (0.5.3-1) unstable; urgency=low
* New upstream version.
+ Adds new API/ABI functions avc1394_transaction_block2() and
avc1394_transaction_block_close().
+ Adds new macros for panel subunit commands and operands to API.
* debian/rules: Bump shlibs version to 0.5.3 because of ABI additions.
* debian/libavc1394-dev.manpages: Add manpages for new utilities mkrfc2734
and panelctl.
* debian/control: Complies with version 3.7.2 of Debian policy. Adjust
Standards-Version accordingly.
* debian/control: Add information about panelctl to long description of
libavc1394-dev.
* debian/copyright: Include license information for new utilities mkrfc2734
and panelctl, and update FSF address.
2005-07-05 - Daniel Kobras <kobras@debian.org>
libavc1394 (0.5.1-1) unstable; urgency=low
* New upstream version.
2005-06-12 - Daniel Kobras <kobras@debian.org>
libavc1394 (0.5.0-2) unstable; urgency=low
* Move new upstream version from experimental to unstable.

See Also

Package Description
libbabeltrace-ctf-dev_1.3.2-1_amd64.deb Common Trace Format (CTF) development files
libbabeltrace-ctf1_1.3.2-1_amd64.deb Common Trace Format (CTF) library
libbabeltrace-dev_1.3.2-1_amd64.deb Babeltrace development files
libbabeltrace1_1.3.2-1_amd64.deb Babeltrace conversion libraries
libbamf-doc_0.5.3~bzr0+16.04.20160415-0ubuntu1_all.deb Window matching library - documentation
libbamf3-2_0.5.3~bzr0+16.04.20160415-0ubuntu1_amd64.deb Window matching library - shared library
libbamf3-dev_0.5.3~bzr0+16.04.20160415-0ubuntu1_amd64.deb Window matching library - development files
libbasicobjects-dev_0.5.0-1_amd64.deb Basic object types for C -- development files
libbasicobjects0_0.5.0-1_amd64.deb Basic object types for C
libberkeleydb-perl_0.55-1build1_amd64.deb use Berkeley DB databases from Perl
libbind-dev_9.10.3.dfsg.P4-8_amd64.deb Static Libraries and Headers used by BIND
libbind-export-dev_9.10.3.dfsg.P4-8_amd64.deb Development files for the exported BIND libraries
libbind9-140_9.10.3.dfsg.P4-8_amd64.deb BIND9 Shared Library used by BIND
libbison-dev_3.0.4.dfsg-1_amd64.deb YACC-compatible parser generator - development library
libblas-common_3.6.0-2ubuntu2_amd64.deb Dependency package for all BLAS implementations
Advertisement
Advertisement