libatomic1_5.3.1-14ubuntu2_amd64.deb


Advertisement

Description

libatomic1 - support library providing __atomic built-in functions

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libatomic1_5.3.1-14ubuntu2_amd64.deb
Package name libatomic1
Package version 5.3.1
Package release 14ubuntu2
Package architecture amd64
Package type deb
Category libs
Homepage http://gcc.gnu.org/
License -
Maintainer Ubuntu Core developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 8.68 KB
Installed size 41.00 KB
library providing __atomic built-in functions. When an atomic call cannot
be turned into lock-free instructions, GCC will make calls into this library.

Alternatives

Package Version Architecture Repository
libatomic1_5.4.0-6ubuntu1~16.04.11_i386.deb 5.4.0 i386 Ubuntu Updates Main
libatomic1_5.4.0-6ubuntu1~16.04.11_amd64.deb 5.4.0 amd64 Ubuntu Updates Main
libatomic1_5.3.1-14ubuntu2_i386.deb 5.3.1 i386 Ubuntu Main
libatomic1 - - -

Requires

Name Value
gcc-5-base = 5.3.1-14ubuntu2
libc6 >= 2.14

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libatomic1_5.3.1-14ubuntu2_amd64.deb
Source Package gcc-5

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libatomic1 deb package:
    # sudo apt-get install libatomic1

Files

Path
/usr/lib/x86_64-linux-gnu/libatomic.so.1
/usr/lib/x86_64-linux-gnu/libatomic.so.1.1.0
/usr/share/doc/libatomic1

Changelog

2016-04-13 - Matthias Klose <doko@ubuntu.com>
gcc-5 (5.3.1-14ubuntu2) xenial; urgency=medium
* Update to SVN 20160413 (r234931, 5.3.1) from the gcc-5-branch.
- PR target/70630 (sparc), PR target/70107 (PPC, wrong-code),
PR c++/70096 (wrong code).
* Fix ICE on ARM32. Revert r234641 for gcc-linaro, which removed support
for %( and %) output modifiers.
2016-04-12 - Matthias Klose <doko@ubuntu.com>
gcc-5 (5.3.1-14ubuntu1) xenial; urgency=medium
* Update to SVN 20160412 (r234893, 5.3.1) from the gcc-5-branch.
- Fix PR target/70566 (ARM, wrong-code), PR target/70117 (PPC, wrong-code).
2016-04-09 - Matthias Klose <doko@debian.org>
gcc-5 (5.3.1-14) unstable; urgency=medium
* Update to SVN 20160409 (r234858, 5.3.1) from the gcc-5-branch.
- Fix PR c++/69826, PR c++/69797, PR target/70421, PR target/70329,
PR rtl-optimization/70429, PR target/70296, PR rtl-optimization/70222,
PR tree-optimization/70169, PR tree-optimization/70152, PR target/70062,
PR target/69888, PR target/70028, PR target/69969, PR debug/69705,
PR rtl-optimization/69891, PR middle-end/69838, PR target/69875,
PR tree-optimization/69802, PR rtl-optimization/69764, PR ipa/68672,
PR rtl-optimization/69771, PR rtl-optimization/69764, PR target/70052,
PR rtl-optimization/69771, PR target/70406, PR target/70319,
PR c++/70272, PR c++/67767, PR fortran/70397, PR target/70296,
PR target/69614, PR c++/70393, PR target/70453, PR rtl-optimization/69307,
PR rtl-optimization/69102, PR rtl-optimization/69032, PR target/66660,
PR target/64411, PR rtl-optimization/70460, PR target/68973,
PR middle-end/70457 (LP: #1563134), PR rtl-optimization/68236,
PR target/67896 (AArch64), PR fortran/66911, PR fortran/65795,
PR target/67172 (MingW), PR target/70525 (x86), PR libgfortran/70235,
PR tree-optimization/70177, PR middle-end/69760, PR middle-end/68963,
PR tree-optimization/69983, PR middle-end/70022, PR middle-end/70424,
PR tree-optimization/70115, PR middle-end/70450, PR middle-end/70333,
PR rtl-optimization/70484, PR target/70510 (x86), PR c++/70430.
* Fix PR target/70496 (ARM32), taken from the trunk.
2016-04-07 - Matthias Klose <doko@ubuntu.com>
gcc-5 (5.3.1-13ubuntu6) xenial; urgency=medium
* Fix applying the gcc-linaro patches.
2016-04-07 - Matthias Klose <doko@ubuntu.com>
gcc-5 (5.3.1-13ubuntu5) xenial; urgency=medium
* Update to SVN 20160407 (r234805, 5.3.1) from the gcc-5-branch.
- Fix PR tree-optimization/70177, PR middle-end/69760, PR middle-end/68963,
PR tree-optimization/69983, PR middle-end/70022, PR middle-end/70424,
PR tree-optimization/70115, PR middle-end/70450, PR middle-end/70333,
PR rtl-optimization/70484, PR target/70510 (x86), PR c++/70430.
* Fix PR target/70496 (ARM32), taken from the trunk.
2016-04-05 - Matthias Klose <doko@ubuntu.com>
gcc-5 (5.3.1-13ubuntu4) xenial; urgency=medium
* Update to SVN 20160404 (r234723, 5.3.1) from the gcc-5-branch.
- Fix PR c++/70393, PR target/70453, PR rtl-optimization/69307,
PR rtl-optimization/69102, PR rtl-optimization/69032, PR target/66660,
PR target/64411, PR rtl-optimization/70460, PR target/68973,
PR middle-end/70457 (LP: #1563134), PR rtl-optimization/68236,
PR target/67896 (AArch64), PR fortran/66911, PR fortran/65795,
PR target/67172 (MingW), PR target/70525 (x86), PR libgfortran/70235.
* Update the ibm branch to 20160324.
2016-03-31 - Matthias Klose <doko@ubuntu.com>
gcc-5 (5.3.1-13ubuntu3) xenial; urgency=medium
* Fix the build from the Linaro branch on armhf.

See Also

Package Description
libatspi2.0-0_2.18.3-4ubuntu1_amd64.deb Assistive Technology Service Provider Interface - shared library
libatspi2.0-dev_2.18.3-4ubuntu1_amd64.deb Development files for the assistive technology service provider
libattr1-dev_2.4.47-2_amd64.deb Extended attribute static libraries and headers
libattr1_2.4.47-2_amd64.deb Extended attribute shared library
libaudio-dev_1.9.4-4_amd64.deb Network Audio System - development files
libaudio2_1.9.4-4_amd64.deb Network Audio System - shared libraries
libaudit-common_2.4.5-1ubuntu2_all.deb Dynamic library for security auditing - common files
libaudit-dev_2.4.5-1ubuntu2_amd64.deb Header files and static library for security auditing
libaudit1_2.4.5-1ubuntu2_amd64.deb Dynamic library for security auditing
libaugeas-dev_1.4.0-0ubuntu1_amd64.deb Development files for writing applications based on libaugeas0
libaugeas0_1.4.0-0ubuntu1_amd64.deb Augeas configuration editing library and API
libauparse-dev_2.4.5-1ubuntu2_amd64.deb Header files and static library for the libauparse0 library
libauparse0_2.4.5-1ubuntu2_amd64.deb Dynamic library for parsing security auditing
libauthen-sasl-perl_2.1600-1_all.deb Authen::SASL - SASL Authentication framework
libavahi-client-dev_0.6.32~rc+dfsg-1ubuntu2_amd64.deb Development files for the Avahi client library
Advertisement
Advertisement