libappstream-glib-dev_0.5.13-1_amd64.deb


Advertisement

Description

libappstream-glib-dev - GNOME library to access AppStream services (development files)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libappstream-glib-dev_0.5.13-1_amd64.deb
Package name libappstream-glib-dev
Package version 0.5.13
Package release 1
Package architecture amd64
Package type deb
Category libdevel
Homepage http://people.freedesktop.org/~hughsient/appstream-glib/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 38.69 KB
Installed size 503.00 KB
AppStream is a cross-distribution effort for creating and sharing
metadata about software components available in the package repositories
of a distribution.
This package contains development files necessary to develop
tools which use the libappstream-glib library.

Alternatives

Package Version Architecture Repository
libappstream-glib-dev_0.5.13-1ubuntu6_amd64.deb 0.5.13 amd64 Ubuntu Updates Main
libappstream-glib-dev_0.5.13-1ubuntu6_i386.deb 0.5.13 i386 Ubuntu Updates Main
libappstream-glib-dev_0.5.13-1_i386.deb 0.5.13 i386 Ubuntu Main
libappstream-glib-dev - - -

Requires

Name Value
libappstream-glib8 = 0.5.13-1
libarchive-dev -
libgcab-dev >= 0.6
libgdk-pixbuf2.0-dev -
libglib2.0-dev >= 2.40
uuid-dev -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libappstream-glib-dev_0.5.13-1_amd64.deb
Source Package appstream-glib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libappstream-glib-dev deb package:
    # sudo apt-get install libappstream-glib-dev

Files

Path
/usr/include/libappstream-glib/appstream-glib.h
/usr/include/libappstream-glib/as-app-builder.h
/usr/include/libappstream-glib/as-app.h
/usr/include/libappstream-glib/as-bundle.h
/usr/include/libappstream-glib/as-checksum.h
/usr/include/libappstream-glib/as-content-rating.h
/usr/include/libappstream-glib/as-enums.h
/usr/include/libappstream-glib/as-icon.h
/usr/include/libappstream-glib/as-image.h
/usr/include/libappstream-glib/as-inf.h
/usr/include/libappstream-glib/as-markup.h
/usr/include/libappstream-glib/as-node.h
/usr/include/libappstream-glib/as-problem.h
/usr/include/libappstream-glib/as-profile.h
/usr/include/libappstream-glib/as-provide.h
/usr/include/libappstream-glib/as-release.h
/usr/include/libappstream-glib/as-screenshot.h
/usr/include/libappstream-glib/as-store.h
/usr/include/libappstream-glib/as-tag.h
/usr/include/libappstream-glib/as-translation.h
/usr/include/libappstream-glib/as-utils.h
/usr/include/libappstream-glib/as-version.h
/usr/lib/x86_64-linux-gnu/libappstream-glib.so
/usr/lib/x86_64-linux-gnu/pkgconfig/appstream-glib.pc
/usr/share/doc/libappstream-glib-dev/changelog.Debian.gz
/usr/share/doc/libappstream-glib-dev/copyright
/usr/share/gir-1.0/AppStreamGlib-1.0.gir
/usr/share/installed-tests/appstream-glib/appdata-validate.test
/usr/share/installed-tests/appstream-glib/destdir-check.test

Changelog

2016-04-06 - Matthias Klumpp <mak@debian.org>
appstream-glib (0.5.13-1) unstable; urgency=medium
* New upstream release: 0.5.13
* xappstreamignore.patch: Support the X-AppStream-Ignore field
in .desktop files
* Add build dependency: libjson-glib-dev
* Update symbols file
2016-03-04 - Matthias Klumpp <mak@debian.org>
appstream-glib (0.5.10-2) unstable; urgency=medium
* fix-parameter-order.patch:
- Fix loading of AppStream metadata
* support-mediabaseurl.patch:
- Implement DEP-11 MediaBaseUrl support (Closes: #808993)
2016-02-28 - Matthias Klumpp <mak@debian.org>
appstream-glib (0.5.10-1) unstable; urgency=medium
* New upstream release: 0.5.10
* Update symbols file
2016-02-04 - Matthias Klumpp <mak@debian.org>
appstream-glib (0.5.8-1) unstable; urgency=medium
* New upstream release: 0.5.8
* Update symbols file
2015-12-17 - Matthias Klumpp <mak@debian.org>
appstream-glib (0.5.5-1) unstable; urgency=medium
* New upstream release: 0.5.5
* Update package descriptions
* Update symbols file
2015-12-04 - Matthias Klumpp <mak@debian.org>
appstream-glib (0.5.4-1) unstable; urgency=medium
* New upstream release: 0.5.4
* Drop patches: Applied upstream
* Update symbols file
2015-11-05 - Matthias Klumpp <mak@debian.org>
appstream-glib (0.5.2-2) unstable; urgency=medium
* libappstream-glib-dev: Requires libgcab to be installed now
2015-11-02 - Matthias Klumpp <mak@debian.org>
appstream-glib (0.5.2-1) unstable; urgency=medium
* New upstream release: 0.5.2
- Closes: #803327
* Tighten dependency on GLib
* 01_Strip-paths-when-decompressing-fw.patch: Fix firmware update support
* Drop 01_fix-dep11.patch: Applied upstream
* Add build-dependency on libgcab-dev to enable firmware support
2015-10-14 - Matthias Klumpp <mak@debian.org>
appstream-glib (0.5.1-1) unstable; urgency=medium
* New upstream release: 0.5.1
* 01_fix-dep11.patch: Make asglib process DEP-11 data again
* Drop appdata-validate: Nobody should use it anymore
* Disable tests
2015-07-20 - Matthias Klumpp <mak@debian.org>
appstream-glib (0.4.1-1) unstable; urgency=medium
* New upstream bugfix release: 0.4.1
- Closes: #791860
* Add dependency on libarchive-dev to libappstream-glib-dev
(Closes: #789578)
* Drop patches: Applied upstream
* Update symbols file

See Also

Package Description
libappstream-glib8_0.5.13-1_amd64.deb GNOME library to access AppStream services
libappstream3_0.9.4-1_amd64.deb Library to access AppStream services
libappstreamqt-dev_0.9.4-1_amd64.deb Qt5 library to access AppStream services (development files)
libappstreamqt1_0.9.4-1_amd64.deb Qt5 library to access AppStream services
libapr1-dev_1.5.2-3_amd64.deb Apache Portable Runtime Library - Development Headers
libapr1_1.5.2-3_amd64.deb Apache Portable Runtime Library
libaprutil1-dbd-sqlite3_1.5.4-1build1_amd64.deb Apache Portable Runtime Utility Library - SQLite3 Driver
libaprutil1-dev_1.5.4-1build1_amd64.deb Apache Portable Runtime Utility Library - Development Headers
libaprutil1-ldap_1.5.4-1build1_amd64.deb Apache Portable Runtime Utility Library - LDAP Driver
libaprutil1_1.5.4-1build1_amd64.deb Apache Portable Runtime Utility Library
libapt-inst2.0_1.2.10ubuntu1_amd64.deb deb package format runtime library
libapt-pkg-dev_1.2.10ubuntu1_amd64.deb development files for APT's libapt-pkg and libapt-inst
libapt-pkg-doc_1.2.10ubuntu1_all.deb documentation for APT development
libapt-pkg-perl_0.1.29build7_amd64.deb Perl interface to libapt-pkg
libapt-pkg5.0_1.2.10ubuntu1_amd64.deb package management runtime library
Advertisement
Advertisement