libapache2-mod-wsgi_4.3.0-1.1build1_amd64.deb


Advertisement

Description

libapache2-mod-wsgi - Python WSGI adapter module for Apache

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libapache2-mod-wsgi_4.3.0-1.1build1_amd64.deb
Package name libapache2-mod-wsgi
Package version 4.3.0
Package release 1.1build1
Package architecture amd64
Package type deb
Category python
Homepage http://www.modwsgi.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 75.72 KB
Installed size 242.00 KB
The mod_wsgi adapter is an Apache module that provides a WSGI (Web Server
Gateway Interface, a standard interface between web server software and
web applications written in Python) compliant interface for hosting Python
based web applications within Apache. The adapter provides significantly
better performance than using existing WSGI adapters for mod_python or CGI.
This package provides module for Python 2.X.

Alternatives

Package Version Architecture Repository
libapache2-mod-wsgi_4.3.0-1.1build1_i386.deb 4.3.0 i386 Ubuntu Main
libapache2-mod-wsgi - - -

Requires

Name Value
apache2-api-20120211 -
apache2-bin >= 2.4.16
libc6 >= 2.14
libpython2.7 >= 2.7
python << 2.8
python >= 2.7

Provides

Name Value
httpd-wsgi -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libapache2-mod-wsgi_4.3.0-1.1build1_amd64.deb
Source Package mod-wsgi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libapache2-mod-wsgi deb package:
    # sudo apt-get install libapache2-mod-wsgi

Files

Path
/etc/apache2/mods-available/wsgi.conf
/etc/apache2/mods-available/wsgi.load
/usr/lib/apache2/modules/mod_wsgi.so
/usr/lib/apache2/modules/mod_wsgi.so-2.7
/usr/share/doc/libapache2-mod-wsgi/README.rst.gz
/usr/share/doc/libapache2-mod-wsgi/changelog.Debian.gz
/usr/share/doc/libapache2-mod-wsgi/copyright
/usr/share/python/runtime.d/libapache2-mod-wsgi.rtupdate

Changelog

2016-01-25 - Matthias Klose <doko@ubuntu.com>
mod-wsgi (4.3.0-1.1build1) xenial; urgency=medium
* No-change rebuild to drop python3.4 support.
2015-11-27 - Thomas Goirand <zigo@debian.org>
mod-wsgi (4.3.0-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Fixed broken depends when rebuilt: applied patch sent to the BTS, thanks to
peter green <plugwash@p10link.net> for the patch (Closes: #805435).
2014-10-05 - Bernd Zeimetz <bzed@debian.org>
mod-wsgi (4.3.0-1) unstable; urgency=medium
[ Felix Geyer ]
* Shorten the rules file using the dh(1) helper.
* Add autopkgtests.
[ Bernd Zeimetz ]
* New upstream release.
2014-08-09 - Bernd Zeimetz <bzed@debian.org>
mod-wsgi (4.2.7-1) unstable; urgency=medium
* New upstream release. 
* Use find instead of a simple cp to copy the source into build
directories.
* README was renamed to README.rst
2014-05-21 - Felix Geyer <fgeyer@debian.org>
mod-wsgi (3.5-1) unstable; urgency=high
* New upstream release.
- Fixes CVE-2014-0240: Local privilege escalation when using daemon mode.
* Drop fix_crash_daemon_mode.patch, applied upstream.
* Refresh python-config.patch.
* Drop obsolete shlibs.local.
* Update watch file to check GitHub instead of Google Code.
* Bump Standards-Version to 3.9.5, no changes needed.
2013-08-10 - Felix Geyer <fgeyer@debian.org>
mod-wsgi (3.4-4) unstable; urgency=low
* Fix wsgi applications segfaulting when run in daemon mode under Apache 2.4.
Thanks to Stephan Adig. (Closes: #719304)
- Add fix_crash_daemon_mode.patch, cherry-picked from upstream.
* Add myself as uploader.
2013-05-30 - Piotr Ożarowski <piotr@debian.org>
mod-wsgi (3.4-3) unstable; urgency=low
* Upload to unstable (python3 build dependency removed)
* Remove myself from Uploaders
2013-05-21 - Piotr Ożarowski <piotr@debian.org>
mod-wsgi (3.4-2) experimental; urgency=low
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Felix Geyer ]
* Fix building against python3.3. Thanks to Dmitrijs Ledkovs for the
initial patch. (Closes: #692390)
- Add python-config.patch to make configure.ac query pythonX.Y-config
instead of python-distutils.
* Add support for Apache 2.4. Thanks to Ondřej Surý for the patch.
(Closes: #666818)
* Export build flags using /usr/share/dpkg/buildflags.mk.
* Bump Standards-Version to 3.9.4, no changes needed.
[ Piotr Ożarowski ]
* Add temporary python (>= 3.3) build dependency to make sure
python3-defaults from experimental is used during build
2012-08-23 - Clint Byrum <clint@ubuntu.com>
mod-wsgi (3.4-1) experimental; urgency=low
* New upstream release.
* d/p/python-3.2-compat.patch: Dropped, superseded by new release.
2011-10-06 - Piotr Ożarowski <piotr@debian.org>
mod-wsgi (3.3-4) unstable; urgency=low
[ James Page ]
* Add a patch for Python 3.2 compatibility 
- debian/patches/python-3.2-compat.patch: full patch to support 
python >= 3.2 from Graham Dumpleton.
* Converted to source/format "3.0 (quilt)"
[ Piotr Ożarowski ]
* Add build-arch and build-indep targets in debian/rules
* Bump Standards-Version to 3.9.2 (no changes needed)

See Also

Package Description
libapache2-reload-perl_0.13-1_all.deb module for reloading Perl modules when changed on disk
libapparmor-dev_2.10.95-0ubuntu2_amd64.deb AppArmor development libraries and header files
libapparmor-perl_2.10.95-0ubuntu2_amd64.deb AppArmor library Perl bindings
libapparmor1_2.10.95-0ubuntu2_amd64.deb changehat AppArmor library
libappconfig-perl_1.66-1_all.deb Perl module for configuration file and command line handling
libappindicator-dev_12.10.1+15.04.20141110-0ubuntu1_amd64.deb Application Indicators
libappindicator-doc_12.10.1+15.04.20141110-0ubuntu1_all.deb Application Indicators
libappindicator0.1-cil-dev_12.10.1+15.04.20141110-0ubuntu1_all.deb Application Indicators
libappindicator0.1-cil_12.10.1+15.04.20141110-0ubuntu1_all.deb CLI bindings for libappindicator
libappindicator1_12.10.1+15.04.20141110-0ubuntu1_amd64.deb Application Indicators
libappindicator3-1_12.10.1+15.04.20141110-0ubuntu1_amd64.deb Application Indicators
libappindicator3-dev_12.10.1+15.04.20141110-0ubuntu1_amd64.deb Application Indicators
libappstream-dev_0.9.4-1_amd64.deb Library to access AppStream services (development files)
libappstream-glib-dev_0.5.13-1_amd64.deb GNOME library to access AppStream services (development files)
libappstream-glib8_0.5.13-1_amd64.deb GNOME library to access AppStream services
Advertisement
Advertisement