libaccountsservice-dev_0.6.40-2ubuntu10_amd64.deb


Advertisement

Description

libaccountsservice-dev - query and manipulate user account information - header files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libaccountsservice-dev_0.6.40-2ubuntu10_amd64.deb
Package name libaccountsservice-dev
Package version 0.6.40
Package release 2ubuntu10
Package architecture amd64
Package type deb
Category libdevel
Homepage http://www.freedesktop.org/wiki/Software/AccountsService/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 9.64 KB
Installed size 124.00 KB
The AccountService project provides a set of D-Bus
interfaces for querying and manipulating user account
information and an implementation of these interfaces,
based on the useradd, usermod and userdel commands.
This package provides the development files for the
AccountService library.

Alternatives

Package Version Architecture Repository
libaccountsservice-dev_0.6.40-2ubuntu11.3_i386.deb 0.6.40 i386 Ubuntu Updates Main
libaccountsservice-dev_0.6.40-2ubuntu11.3_amd64.deb 0.6.40 amd64 Ubuntu Updates Main
libaccountsservice-dev_0.6.40-2ubuntu10_i386.deb 0.6.40 i386 Ubuntu Main
libaccountsservice-dev - - -

Requires

Name Value
gir1.2-accountsservice-1.0 = 0.6.40-2ubuntu10
libaccountsservice0 = 0.6.40-2ubuntu10
libglib2.0-dev >= 2.25.11
libpolkit-gobject-1-dev -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libaccountsservice-dev_0.6.40-2ubuntu10_amd64.deb
Source Package accountsservice

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libaccountsservice-dev deb package:
    # sudo apt-get install libaccountsservice-dev

Files

Path
/usr/include/accountsservice-1.0/act/act-user-enum-types.h
/usr/include/accountsservice-1.0/act/act-user-manager.h
/usr/include/accountsservice-1.0/act/act-user.h
/usr/include/accountsservice-1.0/act/act.h
/usr/lib/x86_64-linux-gnu/libaccountsservice.so
/usr/lib/x86_64-linux-gnu/pkgconfig/accountsservice.pc
/usr/share/doc/libaccountsservice-dev/changelog.Debian.gz
/usr/share/doc/libaccountsservice-dev/copyright
/usr/share/gir-1.0/AccountsService-1.0.gir

Changelog

2016-04-19 - Sebastien Bacher <seb128@ubuntu.com>
accountsservice (0.6.40-2ubuntu10) xenial; urgency=medium
* debian/patches/change-own-data-inactive.patch:
- let inactive user sessions update their own datas without 
triggering authentification dialogs. Indicator-messages does that to
indicate to the greeter that the user received messages, which
currently leads to auth dialog to be stacked in the locked session,
thanks Alkis Georgopoulos (lp: #1512002)
2016-04-06 - Tim Lunn <tim@feathertop.org>
accountsservice (0.6.40-2ubuntu9) xenial; urgency=medium
* debian/patches/0005-gdm_config_file_path_ubuntu.patch:
Copy patch from Debian packaging to correct the path to the
GDM config file. (LP: #1547297)
* debian/patches/0007-add-lightdm-support.patch:
Update paths to gdm config directory
2016-03-16 - Gunnar Hjalmarsson <gunnarhj@ubuntu.com>
accountsservice (0.6.40-2ubuntu8) xenial; urgency=medium
* debian/patches/0009-language-tools.patch:
- Make the language2locale script return a locale name also when
the argument is a complete locale name including codeset
(LP: #1556684).
2016-01-08 - Michael Terry <mterry@ubuntu.com>
accountsservice (0.6.40-2ubuntu7) xenial; urgency=medium
* Drop 0014-pam-pin.patch and 0015-pam-pin-ubuntu.patch, along with
the associated libpam-pin package.  Added a Breaks on the old
package to get it off systems too.  These patches were from an
upstream bug but they never made progress there.  And we never used
the module in Ubuntu Touch like we planned either.  So I'm dropping
it before the LTS is released.
2015-12-07 - Dimitri John Ledkov <xnox@ubuntu.com>
accountsservice (0.6.40-2ubuntu6) xenial; urgency=high
* Build-depend on libsystemd-dev, rather than split name dev packages.
2015-10-06 - Gunnar Hjalmarsson <gunnarhj@ubuntu.com>
accountsservice (0.6.40-2ubuntu5) wily; urgency=medium
* debian/patches/0009-language-tools.patch:
- Correction of a code inconsistency introduced in version
0.6.40-2ubuntu2 (LP: #1502921).
2015-08-14 - Robert Ancell <robert.ancell@canonical.com>
accountsservice (0.6.40-2ubuntu4) wily; urgency=medium
* debian/patches/0007-add-lightdm-support.patch:
- Use [Seat:*] instead of deprecated [SeatDefaults]
2015-08-07 - Robert Ancell <robert.ancell@canonical.com>
accountsservice (0.6.40-2ubuntu3) wily; urgency=medium
* debian/control:
- Switch build-depends from transitional libgcrypt11-dev to libgcrypt20-dev
2015-06-29 - Gunnar Hjalmarsson <gunnarhj@ubuntu.com>
accountsservice (0.6.40-2ubuntu2) wily; urgency=medium
* debian/patches/0009-language-tools.patch:
- Make it possible to set the "Catalan - valencia" language from
the Ubuntu GNOME GUI (LP: #1440275).

See Also

Package Description
libaccountsservice-doc_0.6.40-2ubuntu10_all.deb query and manipulate user account information - documentation
libaccountsservice0_0.6.40-2ubuntu10_amd64.deb query and manipulate user account information - shared libraries
libacl1-dev_2.2.52-3_amd64.deb Access control list static libraries and headers
libacl1_2.2.52-3_amd64.deb Access control list shared library
libaio-dev_0.3.110-2_amd64.deb Linux kernel AIO access library - development files
libaio1_0.3.110-2_amd64.deb Linux kernel AIO access library - shared library
libalgorithm-diff-perl_1.19.03-1_all.deb module to find differences between files
libalgorithm-diff-xs-perl_0.04-4build1_amd64.deb module to find differences between files (XS accelerated)
libalgorithm-merge-perl_0.08-3_all.deb Perl module for three-way merge of textual data
libamd2.4.1_4.4.6-1_amd64.deb approximate minimum degree ordering library for sparse matrices
libandroid-properties-dev_0.1.0+git20151016+6d424c9-0ubuntu7_amd64.deb Development headers files for libandroid-properties
libandroid-properties1_0.1.0+git20151016+6d424c9-0ubuntu7_amd64.deb Library to provide access to get, set and list Android properties
libanthy-dev_9100h-25ubuntu1_amd64.deb input method for Japanese - development files
libanthy0_9100h-25ubuntu1_amd64.deb input method for Japanese - runtime library
libantlr-dev_2.7.7+dfsg-6ubuntu1_amd64.deb language tool for constructing recognizers, compilers etc
Advertisement
Advertisement