lib32phobos-5-dev_5.3.1-14ubuntu2_amd64.deb


Advertisement

Description

lib32phobos-5-dev - Phobos D standard library (64bit development files)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename lib32phobos-5-dev_5.3.1-14ubuntu2_amd64.deb
Package name lib32phobos-5-dev
Package version 5.3.1
Package release 14ubuntu2
Package architecture amd64
Package type deb
Category libdevel
Homepage http://gcc.gnu.org/
License -
Maintainer Ubuntu Core developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 4.66 MB
Installed size 31.82 MB
This is the Phobos standard library that comes with the D2 compiler.
For more information check http://www.dlang.org/phobos/

Alternatives

Package Version Architecture Repository
lib32phobos-5-dev_5.4.0-6ubuntu1~16.04.11_amd64.deb 5.4.0 amd64 Ubuntu Updates Main
lib32phobos-5-dev - - -

Requires

Name Value
gcc-5-base = 5.3.1-14ubuntu2
lib32gcc-5-dev = 5.3.1-14ubuntu2
lib32z1-dev -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package lib32phobos-5-dev_5.3.1-14ubuntu2_amd64.deb
Source Package gcc-5

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lib32phobos-5-dev deb package:
    # sudo apt-get install lib32phobos-5-dev

Files

Path
/usr/lib/gcc/x86_64-linux-gnu/5/32/libgphobos2.a
/usr/share/doc/lib32phobos-5-dev

Changelog

2016-04-13 - Matthias Klose <doko@ubuntu.com>
gcc-5 (5.3.1-14ubuntu2) xenial; urgency=medium
* Update to SVN 20160413 (r234931, 5.3.1) from the gcc-5-branch.
- PR target/70630 (sparc), PR target/70107 (PPC, wrong-code),
PR c++/70096 (wrong code).
* Fix ICE on ARM32. Revert r234641 for gcc-linaro, which removed support
for %( and %) output modifiers.
2016-04-12 - Matthias Klose <doko@ubuntu.com>
gcc-5 (5.3.1-14ubuntu1) xenial; urgency=medium
* Update to SVN 20160412 (r234893, 5.3.1) from the gcc-5-branch.
- Fix PR target/70566 (ARM, wrong-code), PR target/70117 (PPC, wrong-code).
2016-04-09 - Matthias Klose <doko@debian.org>
gcc-5 (5.3.1-14) unstable; urgency=medium
* Update to SVN 20160409 (r234858, 5.3.1) from the gcc-5-branch.
- Fix PR c++/69826, PR c++/69797, PR target/70421, PR target/70329,
PR rtl-optimization/70429, PR target/70296, PR rtl-optimization/70222,
PR tree-optimization/70169, PR tree-optimization/70152, PR target/70062,
PR target/69888, PR target/70028, PR target/69969, PR debug/69705,
PR rtl-optimization/69891, PR middle-end/69838, PR target/69875,
PR tree-optimization/69802, PR rtl-optimization/69764, PR ipa/68672,
PR rtl-optimization/69771, PR rtl-optimization/69764, PR target/70052,
PR rtl-optimization/69771, PR target/70406, PR target/70319,
PR c++/70272, PR c++/67767, PR fortran/70397, PR target/70296,
PR target/69614, PR c++/70393, PR target/70453, PR rtl-optimization/69307,
PR rtl-optimization/69102, PR rtl-optimization/69032, PR target/66660,
PR target/64411, PR rtl-optimization/70460, PR target/68973,
PR middle-end/70457 (LP: #1563134), PR rtl-optimization/68236,
PR target/67896 (AArch64), PR fortran/66911, PR fortran/65795,
PR target/67172 (MingW), PR target/70525 (x86), PR libgfortran/70235,
PR tree-optimization/70177, PR middle-end/69760, PR middle-end/68963,
PR tree-optimization/69983, PR middle-end/70022, PR middle-end/70424,
PR tree-optimization/70115, PR middle-end/70450, PR middle-end/70333,
PR rtl-optimization/70484, PR target/70510 (x86), PR c++/70430.
* Fix PR target/70496 (ARM32), taken from the trunk.
2016-04-07 - Matthias Klose <doko@ubuntu.com>
gcc-5 (5.3.1-13ubuntu6) xenial; urgency=medium
* Fix applying the gcc-linaro patches.
2016-04-07 - Matthias Klose <doko@ubuntu.com>
gcc-5 (5.3.1-13ubuntu5) xenial; urgency=medium
* Update to SVN 20160407 (r234805, 5.3.1) from the gcc-5-branch.
- Fix PR tree-optimization/70177, PR middle-end/69760, PR middle-end/68963,
PR tree-optimization/69983, PR middle-end/70022, PR middle-end/70424,
PR tree-optimization/70115, PR middle-end/70450, PR middle-end/70333,
PR rtl-optimization/70484, PR target/70510 (x86), PR c++/70430.
* Fix PR target/70496 (ARM32), taken from the trunk.
2016-04-05 - Matthias Klose <doko@ubuntu.com>
gcc-5 (5.3.1-13ubuntu4) xenial; urgency=medium
* Update to SVN 20160404 (r234723, 5.3.1) from the gcc-5-branch.
- Fix PR c++/70393, PR target/70453, PR rtl-optimization/69307,
PR rtl-optimization/69102, PR rtl-optimization/69032, PR target/66660,
PR target/64411, PR rtl-optimization/70460, PR target/68973,
PR middle-end/70457 (LP: #1563134), PR rtl-optimization/68236,
PR target/67896 (AArch64), PR fortran/66911, PR fortran/65795,
PR target/67172 (MingW), PR target/70525 (x86), PR libgfortran/70235.
* Update the ibm branch to 20160324.
2016-03-31 - Matthias Klose <doko@ubuntu.com>
gcc-5 (5.3.1-13ubuntu3) xenial; urgency=medium
* Fix the build from the Linaro branch on armhf.

See Also

Package Description
lib32quadmath0_5.3.1-14ubuntu2_amd64.deb GCC Quad-Precision Math Library (32bit)
lib32readline6-dev_6.3-8ubuntu2_amd64.deb GNU readline and history libraries, development files (32-bit)
lib32readline6_6.3-8ubuntu2_amd64.deb GNU readline and history libraries, run-time libraries (32-bit)
lib32stdc++-5-dev_5.3.1-14ubuntu2_amd64.deb GNU Standard C++ Library v3 (development files)
lib32stdc++6_5.3.1-14ubuntu2_amd64.deb GNU Standard C++ Library v3 (32 bit Version)
lib32tinfo-dev_6.0+20160213-1ubuntu1_amd64.deb developer's library for the low-level terminfo library (32-bit)
lib32tinfo5_6.0+20160213-1ubuntu1_amd64.deb shared low-level terminfo library for terminal handling (32-bit)
lib32ubsan0_5.3.1-14ubuntu2_amd64.deb UBSan -- undefined behaviour sanitizer (32bit)
lib32z1-dev_1.2.8.dfsg-2ubuntu4_amd64.deb compression library - 32 bit development
lib32z1_1.2.8.dfsg-2ubuntu4_amd64.deb compression library - 32 bit runtime
liba11y-profile-manager-0.1-0_0.1.10-0ubuntu3_amd64.deb Accessibility profile manager - Shared library
liba11y-profile-manager-0.1-dev_0.1.10-0ubuntu3_amd64.deb Development files for the accessibility profile manager library
liba11y-profile-manager-data_0.1.10-0ubuntu3_all.deb Accessibility Profile Manager - GSettings data
libaa1-dev_1.4p5-44build1_amd64.deb ASCII art library, development kit
libaa1_1.4p5-44build1_amd64.deb ASCII art library
Advertisement
Advertisement