ldap-utils_2.4.42+dfsg-2ubuntu3_amd64.deb


Advertisement

Description

ldap-utils - OpenLDAP utilities

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename ldap-utils_2.4.42+dfsg-2ubuntu3_amd64.deb
Package name ldap-utils
Package version 2.4.42+dfsg
Package release 2ubuntu3
Package architecture amd64
Package type deb
Category net
Homepage http://www.openldap.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 119.21 KB
Installed size 674.00 KB
This package provides utilities from the OpenLDAP (Lightweight
Directory Access Protocol) package. These utilities can access a
local or remote LDAP server and contain all the client programs
required to access LDAP servers.

Alternatives

Package Version Architecture Repository
ldap-utils_2.4.42+dfsg-2ubuntu3.4_amd64.deb 2.4.42+dfsg amd64 Ubuntu Updates Main
ldap-utils_2.4.42+dfsg-2ubuntu3.4_i386.deb 2.4.42+dfsg i386 Ubuntu Updates Main
ldap-utils_2.4.42+dfsg-2ubuntu3_i386.deb 2.4.42+dfsg i386 Ubuntu Main
ldap-utils - - -

Requires

Name Value
libc6 >= 2.14
libldap-2.4-2 = 2.4.42+dfsg-2ubuntu3
libsasl2-2 -

Provides

Name Value
ldap-client -
openldap-utils -

Conflicts

Name Value
ldap-client -
openldap-utils -
umich-ldap-utils -

Replaces

Name Value
openldap-utils -
openldapd -
slapd << 2.2.23-0.pre6

Download

Type URL
Mirror archive.ubuntu.com
Binary Package ldap-utils_2.4.42+dfsg-2ubuntu3_amd64.deb
Source Package openldap

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ldap-utils deb package:
    # sudo apt-get install ldap-utils

Files

Path
/usr/bin/ldapadd
/usr/bin/ldapcompare
/usr/bin/ldapdelete
/usr/bin/ldapexop
/usr/bin/ldapmodify
/usr/bin/ldapmodrdn
/usr/bin/ldappasswd
/usr/bin/ldapsearch
/usr/bin/ldapurl
/usr/bin/ldapwhoami
/usr/share/doc/ldap-utils/README.Debian
/usr/share/doc/ldap-utils/changelog.Debian.gz
/usr/share/doc/ldap-utils/copyright
/usr/share/man/man1/ldapadd.1.gz
/usr/share/man/man1/ldapcompare.1.gz
/usr/share/man/man1/ldapdelete.1.gz
/usr/share/man/man1/ldapexop.1.gz
/usr/share/man/man1/ldapmodify.1.gz
/usr/share/man/man1/ldapmodrdn.1.gz
/usr/share/man/man1/ldappasswd.1.gz
/usr/share/man/man1/ldapsearch.1.gz
/usr/share/man/man1/ldapurl.1.gz
/usr/share/man/man1/ldapwhoami.1.gz
/usr/share/man/man5/ldif.5.gz

Changelog

2016-02-18 - Matthias Klose <doko@ubuntu.com>
openldap (2.4.42+dfsg-2ubuntu3) xenial; urgency=medium
* Fix building with gssapi suppport:
- Explicitly add -I/usr/include/heimdal to CFLAGS.
- Explicitly add -I/usr/lib/<multiarch>/heimdal to LDFLAGS.
2016-02-17 - Matthias Klose <doko@ubuntu.com>
openldap (2.4.42+dfsg-2ubuntu2) xenial; urgency=medium
* No-change rebuild for gnutls transition.
2016-01-10 - Ryan Tandy <ryan@nardis.ca>
openldap (2.4.42+dfsg-2ubuntu1) xenial; urgency=medium
* Merge from Debian testing (LP: #1532648). Remaining changes:
- Enable AppArmor support:
- d/apparmor-profile: add AppArmor profile
- d/rules: use dh_apparmor
- d/control: Build-Depends on dh-apparmor
- d/slapd.README.Debian: add note about AppArmor
- Enable GSSAPI support:
- d/patches/gssapi.diff, thanks to Jerry Carter (Likewise):
- Add --with-gssapi support
- Make guess_service_principal() more robust when determining
principal
- d/configure.options: Configure with --with-gssapi
- d/control: Added heimdal-dev as a build depend
- Enable ufw support:
- d/control: suggest ufw.
- d/rules: install ufw profile.
- d/slapd.ufw.profile: add ufw profile.
- Enable nss overlay:
- d/{patches/nssov-build,rules}: Apply, build and package the
nss overlay.
- d/{rules,slapd.py}: Add apport hook.
- d/slapd.init.ldif: don't set olcRootDN since it's not defined in
either the default DIT nor via an Authn mapping.
- d/slapd.scripts-common:
- add slapcat_opts to local variables.
- Remove unused variable new_conf.
- Fix backup directory naming for multiple reconfiguration.
- d/{slapd.default,slapd.README.Debian}: use the new configuration style.
- d/rules: Enable -DLDAP_CONNECTIONLESS to build CLDAP (UDP) support
in the openldap library, as required by Likewise-Open
- Show distribution in version:
- d/control: added lsb-release
- d/patches/fix-ldap-distribution.patch: show distribution in version
* Drop CVE-2015-6908.patch, included in Debian.
* Remove DEB_HOST_ARCH from debian/rules: left over from when mdb was 
disabled on ppc64el, no longer used, and missed in the previous merge.

See Also

Package Description
less_481-2.1_amd64.deb pager program similar to more
leveldb-doc_1.18-5_all.deb LevelDB documentation
lftp_4.6.3a-1build2_amd64.deb Sophisticated command-line FTP/HTTP/BitTorrent client programs
lib32asan2_5.3.1-14ubuntu2_amd64.deb AddressSanitizer -- a fast memory error detector (32bit)
lib32atomic1_5.3.1-14ubuntu2_amd64.deb support library providing __atomic built-in functions (32bit)
lib32cilkrts5_5.3.1-14ubuntu2_amd64.deb Intel Cilk Plus language extensions (32bit)
lib32gcc-5-dev_5.3.1-14ubuntu2_amd64.deb GCC support library (32 bit development files)
lib32gcc1_6.0.1-0ubuntu1_amd64.deb GCC support library (32 bit Version)
lib32gfortran-5-dev_5.3.1-14ubuntu2_amd64.deb Runtime library for GNU Fortran applications (32bit development files)
lib32gfortran3_5.3.1-14ubuntu2_amd64.deb Runtime library for GNU Fortran applications (32bit)
lib32gomp1_5.3.1-14ubuntu2_amd64.deb GCC OpenMP (GOMP) support library (32bit)
lib32itm1_5.3.1-14ubuntu2_amd64.deb GNU Transactional Memory Library (32bit)
lib32lsan0_5.3.1-14ubuntu2_amd64.deb LeakSanitizer -- a memory leak detector (32bit)
lib32mpx0_5.3.1-14ubuntu2_amd64.deb Intel memory protection extensions (32bit)
lib32ncurses5-dev_6.0+20160213-1ubuntu1_amd64.deb developer's libraries for ncurses (32-bit)
Advertisement
Advertisement