lbdb_0.40ubuntu1_amd64.deb


Advertisement

Description

lbdb - Little Brother's DataBase for the mutt mail reader

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename lbdb_0.40ubuntu1_amd64.deb
Package name lbdb
Package version 0.40ubuntu1
Package release -
Package architecture amd64
Package type deb
Category mail
Homepage http://www.spinnaker.de/lbdb/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 61.28 KB
Installed size 254.00 KB
This package consists of a set of small tools, which collect mail
addresses from several sources and offer these addresses to the mutt
external query feature. At the moment the following modules are
supported:
- m_finger (uses the finger(1) command)
- m_inmail (scans incoming mail for addresses)
- m_passwd (searches /etc/passwd)
- m_yppasswd (searches the YP password database)
- m_nispasswd (searches the NIS password database)
- m_getent (searches the configured password database)
- m_pgp2, m_pgp5, m_gpg (searches your PGP or GnuPG keyrings)
- m_fido (searches the Fidonet nodelist)
- m_abook (uses the address book application abook(1))
- m_addr_email (uses addr-email from the addressbook Tk program)
- m_muttalias (searches your Mutt mail aliases)
- m_pine (searches your Pine addressbook files)
- m_wanderlust (search the WanderLust alias database)
- m_palm (uses your Palm database; needs libpalm-perl package)
- m_gnomecard (uses GnomeCard database files)
- m_bbdb (search your BBDB (big brother database))
- m_ldap (query some LDAP server)
- m_evolution (search in the Evolution addressbook)
- m_vcf (search in vcard files using libvformat)

Alternatives

Package Version Architecture Repository
lbdb_0.40ubuntu1_i386.deb 0.40ubuntu1 i386 Ubuntu Main
lbdb - - -

Requires

Name Value
emacsen-common >= 2.0.8
libc6 >= 2.14
libvformat0 >= 1.13-6~
perl -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package lbdb_0.40ubuntu1_amd64.deb
Source Package lbdb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lbdb deb package:
    # sudo apt-get install lbdb

Files

Path
/etc/lbdb.rc
/etc/lbdb_ldap.rc
/etc/emacs/site-start.d/50lbdb.el
/usr/bin/lbdb-fetchaddr
/usr/bin/lbdb_dotlock
/usr/bin/lbdbq
/usr/bin/nodelist2lbdb
/usr/lib/emacsen-common/packages/compat/lbdb
/usr/lib/emacsen-common/packages/install/lbdb
/usr/lib/emacsen-common/packages/remove/lbdb
/usr/lib/lbdb/fetchaddr
/usr/lib/lbdb/lbdb-munge
/usr/lib/lbdb/lbdb_bbdb_query.el
/usr/lib/lbdb/lbdb_lib
/usr/lib/lbdb/m_abook
/usr/lib/lbdb/m_addr_email
/usr/lib/lbdb/m_bbdb
/usr/lib/lbdb/m_evolution
/usr/lib/lbdb/m_fido
/usr/lib/lbdb/m_finger
/usr/lib/lbdb/m_getent
/usr/lib/lbdb/m_gnomecard
/usr/lib/lbdb/m_gpg
/usr/lib/lbdb/m_inmail
/usr/lib/lbdb/m_ldap
/usr/lib/lbdb/m_muttalias
/usr/lib/lbdb/m_palm
/usr/lib/lbdb/m_passwd
/usr/lib/lbdb/m_pgp2
/usr/lib/lbdb/m_pgp5
/usr/lib/lbdb/m_pine
/usr/lib/lbdb/m_vcf
/usr/lib/lbdb/m_wanderlust
/usr/lib/lbdb/m_yppasswd
/usr/lib/lbdb/munge
/usr/lib/lbdb/munge-keeporder
/usr/lib/lbdb/mutt_ldap_query
/usr/lib/lbdb/palm_lsaddr
/usr/lib/lbdb/qpto8bit
/usr/lib/lbdb/vcquery
/usr/share/doc/lbdb/README.gz
/usr/share/doc/lbdb/TODO
/usr/share/doc/lbdb/changelog.gz
/usr/share/doc/lbdb/copyright
/usr/share/doc/lbdb/mutt_ldap_query.ChangeLog
/usr/share/doc/lbdb/examples/lbdb.sl
/usr/share/emacs/site-lisp/lbdb/lbdb.el
/usr/share/man/man1/lbdb-fetchaddr.1.gz
/usr/share/man/man1/lbdb_dotlock.1.gz
/usr/share/man/man1/lbdbq.1.gz
/usr/share/man/man1/mutt_ldap_query.1.gz
/usr/share/man/man1/nodelist2lbdb.1.gz

Changelog

2016-02-09 - Chris J Arges <chris.j.arges@canonical.com>
lbdb (0.40ubuntu1) xenial; urgency=medium
* Drop mutt_ldap_query fix in favor of Debian's fix.
2016-01-30 - Roland Rosenfeld <roland@debian.org>
lbdb (0.40) unstable; urgency=medium
* Upgrade to Standards-Version 3.9.6 (no changes).
* Avoid gpg trustdb check in m_gpg, since this may take a long time
while lbdb is not responsible.  Thanks to Gregor Zattler for providing
a patch (Closes: #805235).
* mutt_ldap_query: escape parentheses, since perl 5.22 complains about
this otherwise.  Thanks to Olivier Mehani and Francois Charlier.
(Closes: #812785).  This also solves launcpad bug 1539774 and RedHat
bug 1259881.
* Update emacs support (Add dependency on emacsen-common >=2.0.8, add
emacsen-compat).
* Run wrap-and-sort.
* Fix several man page typos.
2016-01-29 - Chris J Arges <chris.j.arges@canonical.com>
lbdb (0.39ubuntu1) xenial; urgency=medium
* Fix mutt_ldap_query deprecation warnings. (LP: #1539774)
2014-05-10 - Roland Rosenfeld <roland@debian.org>
lbdb (0.39) unstable; urgency=low
* Use dh_autotools-dev (Closes: #727289).
* Update packaged autotools files.
* Rebuild aclocal/autoconf.
* Change debian/source-format to 3.0 (native).
* Remove mutt-ja from Suggests, since this no longer exists.
* Upgrade build depenency to debhelper (>= 9).
* Change debian/compat to "9".
* Complete rewrite of debian/rules.
* Now uses hardening via debhelper.
* Add $CPPFLAGS to $CFLAGS to really use hardening.
* Upgrade to Standards-Version 3.9.5 (no changes).
* m_vcf: Optimize missing names handling (Thanks to Jamey Sharp)
(Closes: #633920).
* Made debian/copyright machine readable.
* m_abook: fix formatting (Thanks to Alfredo Finelli) (Closes: #681526).
* mutt-ldap-query: Add parameters for TLS and SASL_MECH (Thanks to
Alexandra N. Kossovsky) (Closes: #512074).
* Mention user mutt-ldap-query configuration files in lbdbq(1) man page
(Closes: #534710).
* Update ABQuery build mechanism (Thanks to Brendan Cully).
2011-06-25 - Roland Rosenfeld <roland@debian.org>
lbdb (0.38) unstable; urgency=low
* m_evolution: Try to evaluate the location of
evolution-addressbook-export at runtime, since it is no longer
available in /usr/bin since evolution 2.30.1.2-3 
(Closes: #583851, #598380).
* m_vcf: Apply patch by Jamey Sharp <jamey@minilop.net> to support VCF
contacts without real name (Closes: #624590).
* vcquery: Apply patch by martin f krafft <madduck@debian.org> to search
in NICKNAME field, too. (Closes: #586300).
* Add debian/source/format (1.0).
* Upgrade to Standards-Version 3.9.2:
- Add line break to Suggests.
* Remove "the" from description synopsis to make lintian happy.
* Fix some typos in changelog.
2011-06-05 - Thomas Preud'homme <robotux@celest.fr>
lbdb (0.37+nmu1) unstable; urgency=low
* Non-maintainer upload.
* Build-Depend on libvformat-dev instead of libvformat1-dev
(Closes: #583073).
2010-05-18 - Roland Rosenfeld <roland@debian.org>
lbdb (0.37) unstable; urgency=low
* Fix bashisms in m_bbdb (Closes: #530113).
* Fix query shell functions to catch non-zero exit status in case they
get invoked in set -e context.  Thanks to martin f. krafft
<madduck@debian.org> for providing a patch (Closes: #515076).
* m_evolution: support line breaks and long lines.  Thanks to Jan Larres
<jan@majutsushi.net> for providing a patch (Closes: #505540).
* Fix documentation concerning the quotes on lbdbq call (Closes: #542012).
* Upgrade to Standards-Version 3.8.4 (no changes).

See Also

Package Description
ldap-utils_2.4.42+dfsg-2ubuntu3_amd64.deb OpenLDAP utilities
less_481-2.1_amd64.deb pager program similar to more
leveldb-doc_1.18-5_all.deb LevelDB documentation
lftp_4.6.3a-1build2_amd64.deb Sophisticated command-line FTP/HTTP/BitTorrent client programs
lib32asan2_5.3.1-14ubuntu2_amd64.deb AddressSanitizer -- a fast memory error detector (32bit)
lib32atomic1_5.3.1-14ubuntu2_amd64.deb support library providing __atomic built-in functions (32bit)
lib32cilkrts5_5.3.1-14ubuntu2_amd64.deb Intel Cilk Plus language extensions (32bit)
lib32gcc-5-dev_5.3.1-14ubuntu2_amd64.deb GCC support library (32 bit development files)
lib32gcc1_6.0.1-0ubuntu1_amd64.deb GCC support library (32 bit Version)
lib32gfortran-5-dev_5.3.1-14ubuntu2_amd64.deb Runtime library for GNU Fortran applications (32bit development files)
lib32gfortran3_5.3.1-14ubuntu2_amd64.deb Runtime library for GNU Fortran applications (32bit)
lib32gomp1_5.3.1-14ubuntu2_amd64.deb GCC OpenMP (GOMP) support library (32bit)
lib32itm1_5.3.1-14ubuntu2_amd64.deb GNU Transactional Memory Library (32bit)
lib32lsan0_5.3.1-14ubuntu2_amd64.deb LeakSanitizer -- a memory leak detector (32bit)
lib32mpx0_5.3.1-14ubuntu2_amd64.deb Intel memory protection extensions (32bit)
Advertisement
Advertisement