keepalived_1.2.19-1_amd64.deb


Advertisement

Description

keepalived - Failover and monitoring daemon for LVS clusters

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename keepalived_1.2.19-1_amd64.deb
Package name keepalived
Package version 1.2.19
Package release 1
Package architecture amd64
Package type deb
Category admin
Homepage http://keepalived.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 145.75 KB
Installed size 511.00 KB
keepalived is used for monitoring real servers within a Linux
Virtual Server (LVS) cluster.  keepalived can be configured to
remove real servers from the cluster pool if it stops responding,
as well as send a notification email to make the admin aware of
the service failure.
In addition, keepalived implements an independent Virtual Router
Redundancy Protocol (VRRPv2; see rfc2338 for additional info)
framework for director failover.
You need a kernel >= 2.4.28 or >= 2.6.11 for keepalived.
See README.Debian for more information.

Alternatives

Package Version Architecture Repository
keepalived_1.2.24-1ubuntu0.16.04.1_amd64.deb 1.2.24 amd64 Ubuntu Updates Main
keepalived_1.2.24-1ubuntu0.16.04.1_i386.deb 1.2.24 i386 Ubuntu Updates Main
keepalived_1.2.19-1_i386.deb 1.2.19 i386 Ubuntu Main
keepalived - - -

Requires

Name Value
init-system-helpers >= 1.18~
iproute2 -
libc6 >= 2.15
libnl-3-200 >= 3.2.7
libnl-genl-3-200 >= 3.2.7
libsnmp30 >= 5.7.2~dfsg
libssl1.0.0 >= 1.0.0

Download

Type URL
Mirror archive.ubuntu.com
Binary Package keepalived_1.2.19-1_amd64.deb
Source Package keepalived

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install keepalived deb package:
    # sudo apt-get install keepalived

Files

Path
/etc/default/keepalived
/etc/init.d/keepalived
/lib/systemd/system/keepalived.service
/usr/bin/genhash
/usr/sbin/keepalived
/usr/share/doc/keepalived/AUTHOR
/usr/share/doc/keepalived/CONTRIBUTORS
/usr/share/doc/keepalived/README
/usr/share/doc/keepalived/TODO
/usr/share/doc/keepalived/changelog.Debian.gz
/usr/share/doc/keepalived/copyright
/usr/share/doc/keepalived/keepalived.conf.SYNOPSIS.gz
/usr/share/doc/keepalived/samples/client.pem
/usr/share/doc/keepalived/samples/dh1024.pem
/usr/share/doc/keepalived/samples/keepalived.conf.HTTP_GET.port
/usr/share/doc/keepalived/samples/keepalived.conf.IPv6
/usr/share/doc/keepalived/samples/keepalived.conf.SMTP_CHECK
/usr/share/doc/keepalived/samples/keepalived.conf.SSL_GET
/usr/share/doc/keepalived/samples/keepalived.conf.fwmark
/usr/share/doc/keepalived/samples/keepalived.conf.inhibit
/usr/share/doc/keepalived/samples/keepalived.conf.misc_check
/usr/share/doc/keepalived/samples/keepalived.conf.misc_check_arg
/usr/share/doc/keepalived/samples/keepalived.conf.quorum
/usr/share/doc/keepalived/samples/keepalived.conf.sample
/usr/share/doc/keepalived/samples/keepalived.conf.status_code
/usr/share/doc/keepalived/samples/keepalived.conf.track_interface
/usr/share/doc/keepalived/samples/keepalived.conf.virtual_server_group
/usr/share/doc/keepalived/samples/keepalived.conf.virtualhost
/usr/share/doc/keepalived/samples/keepalived.conf.vrrp
/usr/share/doc/keepalived/samples/keepalived.conf.vrrp.localcheck
/usr/share/doc/keepalived/samples/keepalived.conf.vrrp.lvs_syncd
/usr/share/doc/keepalived/samples/keepalived.conf.vrrp.routes
/usr/share/doc/keepalived/samples/keepalived.conf.vrrp.scripts
/usr/share/doc/keepalived/samples/keepalived.conf.vrrp.static_ipaddress
/usr/share/doc/keepalived/samples/keepalived.conf.vrrp.sync
/usr/share/doc/keepalived/samples/root.pem
/usr/share/doc/keepalived/samples/sample.misccheck.smbcheck.sh
/usr/share/man/man1/genhash.1.gz
/usr/share/man/man5/keepalived.conf.5.gz
/usr/share/man/man8/keepalived.8.gz
/usr/share/snmp/mibs/KEEPALIVED-MIB
/usr/share/snmp/mibs/VRRP-MIB

Changelog

2015-08-15 - Alexander Wirt <formorer@debian.org>
keepalived (1:1.2.19-1) unstable; urgency=medium
* [3594525] Imported Upstream version 1.2.19
2015-03-31 - Alexander Wirt <formorer@debian.org>
keepalived (1:1.2.16-1) experimental; urgency=medium
* [3cc1f17] Depend on ipvsadm2 instead of ipvsadm
* [e09b760] Move ipvsadm to recommends 
(Closes: #755771)
* [afa7293] Imported Upstream version 1.2.16
* [e86c672] Add systemd unitfile (Closes: #779347)
* [81fac5f] Remove syslog dependency in service file
* [40a44f0] Bump standards version
2014-05-28 - Alexander Wirt <formorer@debian.org>
keepalived (1:1.2.13-1) unstable; urgency=medium
* [1e9c32b] Imported Upstream version 1.2.11
* [bac64d6] Imported Upstream version 1.2.13
- keep retry in case of early TCP failures in checks
(Closes: #626466 #504069)
- Add To header for SMTP alerts. 
(Closes: #627169)
- handle passwords up to 8 characters
(Closes: #614562)
- modprobe handling fixed
(Closes: #714377)
- Support more than 31 interfaces
(Closes: #723106)
- Fix ipv6 realserver handling
(Closes: #740258)
- extend ip parser to support default and default6
(Closes: #740573)
* [65d5b11] Add pkg-config to build-deps
* [af497e7] Disable obsolete patches
* [4761254] Bump standards version (no changes)
2013-11-11 - Alexander Wirt <formorer@debian.org>
keepalived (1:1.2.9-1) unstable; urgency=low
* [8cd7bad] Imported Upstream version 1.2.9
2013-09-13 - Alexander Wirt <formorer@debian.org>
keepalived (1:1.2.8-1) unstable; urgency=low
* [b25f231] Patch configure.in instead of configure
* [aa70432] Fix configure
* [3a728cd] Enable sha1 support
* [e257779] Add Homepage field
* Allow providing of daemon args via /etc/defaul/keepalived
Closes: #693877
* Import upstream version 1.2.8 (Closes: #721966)
- Fix reload handling (Closes: #652260)
2013-07-01 - Alexander Wirt <formorer@debian.org>
keepalived (1:1.2.7-1) unstable; urgency=low
* [b46efb0] Imported Upstream version 1.2.7
- Don't use bind() with AF_UNSPEC
(Closes: #699540)
- new upstream version (Closes: #703085) 
* [6058efd] wrap-and-sort
* [a128718] Build with snmp support
* [d9783f9] Remove obsolete patches
* [2deaa4e] Move to dh and 3.0(quilt)
* [cd5a314] Use libnl3 (Closes: #688164)
* [d6493e1] Convert package to dh and quilt(3.0)
* [e7f5489] Bump dh compat to dh9
* [f6ca92d] Bump standards version
* [525415b] Fix errors in manpage
* [35dbfe3] Remove unneeded files
2012-08-21 - Alexander Wirt <formorer@debian.org>
keepalived (1:1.2.6-1) experimental; urgency=low
* [b72cd7a] Remove obsolete patches
* [0cadef0] Enable snmp support
* [7442e85] Build-depend against libsnmp-dev
* [b84e381] Imported Upstream version 1.2.4
* [9f29e62] Imported Upstream version 1.2.6
2011-12-18 - Alexander Wirt <formorer@debian.org>
keepalived (1:1.2.2-3) unstable; urgency=low
* [c28d5f0] Readd ip_vs.h - this reenables ipvs (Closes: #649778)
2011-11-10 - Alexander Wirt <formorer@debian.org>
keepalived (1:1.2.2-2) unstable; urgency=low
* [9db4134] Fix override disparity
* [8f0c721] Remove obsolete patch
* [897c0a0] Set correct permissions on pid file.
This is a fix for CVE-2011-1784.
(Closes: #626281)
* [5ab4b8d] Don't use modprobe -k.
Thanks to Sven Ulland for the patch
* [c87fe40] Add vcs headers to control file
* [8107104] Bump standards version - no changes
2011-03-06 - Alexander Wirt <formorer@debian.org>
keepalived (1:1.2.2-1) unstable; urgency=low
* New upstream version
* Don't remove configure in clean target
* Refresh 95_use_linux_ip_vs_h.patch for 1.2
* Build depend on libnl-dev

See Also

Package Description
kernel-wedge_2.90ubuntu1_all.deb udeb package builder for Debian-Installer
kerneloops-daemon_0.12+git20140509-2ubuntu1_amd64.deb kernel oops tracker
kexec-tools_2.0.10-1ubuntu2_amd64.deb tools to support fast kexec reboots
keyboard-configuration_1.108ubuntu15_all.deb system-wide keyboard preferences
keystone-doc_9.0.0-0ubuntu1_all.deb OpenStack identity service - Documentation
keystone_9.0.0-0ubuntu1_all.deb OpenStack identity service - Daemons
keyutils_1.5.9-8ubuntu1_amd64.deb Linux Key Management Utilities
klibc-utils_2.0.4-8ubuntu1_amd64.deb small utilities built with klibc for early boot
kmod_22-1ubuntu4_amd64.deb tools for managing Linux kernel modules
kpartx-boot_0.5.0+git1.656f8865-5ubuntu2_all.deb Provides kpartx during boot
kpartx_0.5.0+git1.656f8865-5ubuntu2_amd64.deb create device mappings for partitions
krb5-config_2.3_all.deb Configuration files for Kerberos Version 5
krb5-doc_1.13.2+dfsg-5_all.deb Documentation for MIT Kerberos
krb5-locales_1.13.2+dfsg-5_all.deb Internationalization support for MIT Kerberos
krb5-multidev_1.13.2+dfsg-5_amd64.deb Development files for MIT Kerberos without Heimdal conflict
Advertisement
Advertisement